Unable to connect to the UCP Node Server because: 'Error: xhr poll error

Hello all,
I’m have troubles with my User control panel.
Error” Unable to connect to the UCP Node Server because: ‘Error: xhr poll error’

My environment as follow;
CentOS 7 Virtual machine, 2 CPU, 4GB Ram, 100GB HDD
ISO Used= SNG7-FPBX-64bit-1712-2.iso
User Control Panel14.0.2.5

I installed FreePBX on Virtual machine, Logged in Admin console then executed all updates for modules and the system. Once updates were finished, I created EXT (101), enable UCP. With http I had no problems. I wanted to test Softphone system on UCP, it requests HTTPS, I configured self-signed cert as show in image URL above. After logging back in I received the error “Unable to connect to the UCP Node Server because: ‘Error: xhr poll error’”

Research the following places;


The following steps have been executed;

  1. fwconsole stop ucpnode
  2. fwconsole start ucpnode
  3. yum remove nodejs
  4. yum install nodejs
  5. I tried fwconsole ma uninstall/install/download ucpnode
  6. Restarted the server after making Certs, completed
  7. Uninstalled XMPP
  8. Installed XMPP again

    Port Management

    Any more adice or direction would be appreciated.
    Thanks in advance

For testing purposes I install a earlier version of FreePBX ISO
Release Date: 2016
FreePBX 13 • Linux 6.6 • Asterisk 11 or 13”

The Phone was enable without https

So the newer version is not working for me but the older version seems like it will. I need to test further.

Per your screenshots, the newer one you accessed it through a fqdn which is probably going through your firewall (unless you have a internal DNS) the older one you are accessing by IP which seems internally…

So your issue is likely that you didn’t open the required ports.

Also the certificate is invalid over https in the first screenshot but is not over https in the second one. Which is why it’s failing to connect.

Also in 14 there is no ucpnode. Its all combined in UCP itself.

@PitzKey Thank you for the reply.
Just to clarify, This is a lab environment, with internal DNS server. I’m test different functions of FreePBX (Free Version) before I purchase modules. As for firewall I dropped it to see if it made a difference, No joy. Same error occurred.

But with HTTPS you can only use the FQDN that the cert is setup for and it can not be a self signed cert.

Thank you for the reply
So if I understand this right, I can not use a self-singed Certificate for UCP?
I have to have a CA?

@tm1000 I corrected the Second Image to use a self-signed cert.

I realized my mistake, sorry about that.

Drop the firewall so nothing is in the way.
Looks like I’m still get the same error from Both versions.

This seems to be very simple to enable Soft-phone on UCP that has HTTPS while using a self-signed cert.
I think I might be missing something.
It was suggested that Port/s were my problem so I drop the firewall,No joy on either Version of Freepbx

Self-Signed seem not to work for UCP.
I should use Let’s encrypt and/or have a CA.

Go complain to Google and firerox. They are the ones who refuse to allow WebRTC to work with self signed certs or with HTTP at all. Nothing to do with us.

Thank you for reply.
Unfortunately I do not complain, I try to solve problems. As stated from the first post I 'm trying to figure out why I’m receiving this error, And the setup for HTTPS using self-signed cert was made simple. Chrome is working fine with FreePBX . I believe the Connection between UCP and Server its self is the problem after enabling HTTPS.
Now Im creating CA in my lab, going to see if that solve the problem

Chrome working with FreePBX has nothing to do with this. Your issue is the soft phone you want to use in UCP is WebRTC and the browsers REQUIRE you to use HTTPS and it has to be with a trusted Cert. We have no control over this.

NOTE: This Test Server is using Old Version of FreePBX.
I think I solved my connection problems; when creating Self-Signed Cert and then Imported it.

I decide to use the Cert “sysadmin”. Then went into edit that cert

I copied & Pasted the self-signed Certificates in the proper section as shown below;

The Output as shown below when finished;

UCP error is gone.

Even thou this test server work on earlier version . Im going to test it on the newer one.


I agree

@tm1000 @PitzKey I was looking at what you guys suggested, some configuration were over looked/ thanks again

Thank you all for our advice and suggestions.
I was able to use Self-cert for testing and enable UCP without error. Problem was the configuration between my self-cert that was created and configuration in the Certificate Manger Front end. Hope this might help someone in the future.

Steps that was execute to accomplish task on using self-certification using Freepbx 14

FreePBX 14 ISO
Create Virtual machine with 2 CPU 4 GB memory, 100 GB HDD add ISO from FreePBX dl section
Configured static IP Address
Edit hostname
Edit /etc/hosts file < IP Address>
Edit local DNS an add FreePBX server to DOMAIN + PTR (reverse lookup)
During the Installation I create user = root +password
Active Account = email log into portal “Active”
Enable firewall
Update System through GUI. Admin > Updates > System Updates execute check online /process
Update Modules through GUI Admin > Updates > module Updates execute check on line /process
Create EXT=101 + called greg + Create user greg and configured password
Certificate manager create a new on with FQDN of FreePBX server
Navigate to > System Admin > HTTPS SETUP then Import Certificate
Configure Ports
Navigate to System Admin > port Management

then Update Now.
Create self-signed cert
root# openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout webserver.key -out webserver.crt
Copy Created certs made

Navigate to Certificate Management
and filled out the cert name “sysadmin”

Apply configuration

Enable sysadmin ( green check mark)

Enabled Phone Service for user
and Completed, No problems and error /s are gone UCP working fine

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.