SOLVED: Freepbx 13: Unable to connect to the UCP Node Server

I’m running freepbx 13 and I have an error across to top of the page when logging in to User Control Panel.
Unable to connect to the UCP Node Server because: 'Error: xhr poll error'
is there a fix for this? I can’t find anything that works using google. I tried uninstall and reinstalling ucp but that didn’y make a difference…

bump, anybody? please?
my system is all jammed up because of this error:
Unable to connect to the UCP Node Server because: ‘timeout’

Check this link, please:

thanks for your response, I’ve already seen the page at the link you gave but nothing in it solved this issue in my freepbx-13 install. Any other ideas would be appreciated…

Uninstall ucpnode module if you do not require it (XMPP/Conferences Pro)


thankyou I uninstalled XMPP and Conferences Pro and now the error in UCP has gone, however when I log in to the user there are no call recordings. I have my extension set to record everything. It was working fine in freepbx 12 but this is an upgrade to 13. Am I looking in the right place for recordings? All I have in the UCP are:
I used to have a link that gave me the call recordings but it’s no longer there.

There’s never been a link to “Call Recordings”. You are looking for “Call History” and you’ll have to modify your permissions in User Manager.

yeah that’s it, Call History. Thanks for your help with the previous problem btw.
I went into admin/user management/ but couldn’t see anywhere to alter the permissions you speak of. Am I looking in the wrong place?

User Manager > User > UCP > Call History

yes that fixed it, thankyou for your help andrew.