UCP unable to connect to UCP node server


(Clark Nielsen) #1

After some updates this weekend, I get the following error when any user logs into UCP. "Unable to connect to the UCP node server because: ‘Error: xhr poll error’ " This occurs after any user logs into UCP and it is in a red bar at the top of the screen.

Does anyone have any suggestions on where I should go to troubleshoot this issue?


Unable to connect to the UCP Node Server because: 'Error: xhr poll error
#2

I have ran into this issue from time to time. If you have console access, issue this command: fwconsole start ucpnode
If it’s already running, as in my most recent case, then you need to restart it. fwconsole stop ucpnode followed by fwconsole start ucpnode

I used this post to solve my issue:

Hope that helps,
-Eric


(Clark Nielsen) #3

Eric,
Thaks for your suggestions! I really appreciate your help. I tried that and here’s the output:
"[root@phoneserver ~]# fwconsole start ucpnode
Running FreePBX startup…
Setting Permissions…
Collecting Files…Done
5403/5403 [============================] 100%
Finished setting permissions
Unable to run Pre-Asterisk hooks, because Asterisk is already running on PID 1982 and has been running for 6 hours, 26 minutes, 48 seconds
Starting UCP Server
UCP Server Failed to run: ‘runuser -l asterisk -c “cd /var/www/html/admin/modules/ucpnode/node && mkdir -p /var/lib/asterisk/ucp && mkdir -p logs && export FOREVER_ROOT=/var/lib/asterisk/ucp && export ASTLOGDIR=/var/log/asterisk && export HOME=/home/asterisk && npm start”’

I’m guessing that it’s a port issue in my case. Any suggestions on where I’d go to fix that?


(Clark Nielsen) #4

I found a solution that worked for me. Eric, thanks again for your help, it pointed me in the right direction. I think my issue had to do something with the ports, so I decided to uninstall, remove and then reinstall, but when I went to reinstall, it wouldn’t let me, so I used the following console commands:
yum remove nodejs
yum remove npm
yum install nodejs
amportal a ma uninstall ucpnode
amportal a ma remove ucpnode
amportal a ma download ucpnode
amportal a ma install ucpnode

This solution worked for me.


#5

Great! I was going to suggest exactly that. I assumed you were at the latest version and that’s my fault. Glad you found the answer.


(Don) #6

I have had this problem ever since I installed Fax Pro. Have tried both of these solutions and neither worked for me. One note on the second command ‘yum remove npm’, this is what I get:

'#yum remove npm
Loaded plugins: fastestmirror, kmod
Setting up Remove Process
No Match for argument: npm
Loading mirror speeds from cached hostfile
Package(s) npm available, but not installed.
No Packages marked for removal

Any other suggestions for this?


#7

Don,

The yum npm error just means you are trying to remove a package that is not installed. Are you on FreePBX 13? What happens when you do ‘yum install nodejs’? Does it install?

-Eric


"Unable to connect to the UCP Node Server"
(Don) #8

Yes, I am on FreePBX 13. I believe all the other commands worked fine. This seems to be related to the TLS in Settings / Advanced Settings, and then under the UCP NodeJS Server section, I can disable the ‘Enable TLS for the NodeJS Server’ and the error goes away for a short time. This setting automatically re-enables itself and the problem comes back. I do have an SSL Certificate installed and working properly. The TLS Certificate and TLS Private Key paths look fine.


(Andrew Nagy) #9

Have you restarted the server since you installed the certificates?

If you aren’t using Conferences Pro or XMPP you can uninstall ucpnode.


(Brazil) #10

Looked for a solution everywhere. The solution for me was using:

fwconsole ma install ucp

not fwconsole ma install ucpnode as most of discussions says


(Lorne Gaetz) closed #11