FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX - Unable to connect to the UCP Node Server because: 'Error: xhr poll error'

(Noahbalboah91) #1

When logging into UCP on any account I’m getting “Unable to connect to the UCP Node Server because: ‘Error: xhr poll error’” I’ve removed and reinstalled UCP, ran all system updates, ran all module updates and still no luck. Any ideas on how to resolve this?

Resolved: Turns out this was caused by the “Default Certificate” in “Certificate Management” not matching the SSL under “System Admin > HTTPS Setup”. I changed it to match and the message no longer comes up.

(Lorne Gaetz) #2

The Node ports are as defined in Advanced Settings, they need to be accessible from the browser. See:

(Noahbalboah91) #3

As far as I can tell, this is all setup properly. I even tried disabling the firewall and still get the error message in UCP.

(Noahbalboah91) #4

Another SS.

(Noahbalboah91) #5

Anyone have any ideas? :frowning:

(Itzik) #6

Did you reboot after you made the last change that caused this?

(Tom Ray) #7

Open up the browser’s developer console and look at the logs produced there while getting the error.

(Noahbalboah91) #8

Getting this in the console over and over every couple of seconds.

(Noahbalboah91) #9

Funny enough nothing changed, it just started happening. Have tried rebooting though and no dice.

(Noahbalboah91) #10

The console suggestion led me to the fix.


Same issue new Installation. I used this fix but now the error has returned 24 hours or so later