Res_pjsip_registrar.c:1166 find_registrar_aor: AOR '' not found for endpoint

Hi, I am trying to configure a Grandstream HT813 (FXO gateway) to connect a PSTN phone line to my recently installed FreePBX VM. I am a noob with FreePBX and I am mostly trying to do things from the UI, although I have some previous experience with older Asterisks.

In rasterisk I get this message recurrently, approximately every 20 seconds:

WARNING[141870]: res_pjsip_registrar.c:1166 find_registrar_aor: AOR '' not found for endpoint 'LinhaMeo' (

I’d like to remove this message, it’s making my terminal scroll while I examine SIP and asterisk debug output, making it really hard to work. And it’s probably an error I need to fix, any way.

Where can I find the place in the UI where that is coming from? I basically configured a few extensions, and a trunk called LinhaMeo. I didn’t define Users. That IP address is the HT813. But I’ve tried a few changes and the error is always there.

Is that an error caused by the HT813 trying to contact Asterisk, or the other way around?

I assume you’ll want more information about my configs, just tell me what you need and I’ll be happy to provide it. Thanks in advance!

I don’t understand what you mean by the user interface here. The message is coming from the core processing:

I think it is saying that is trying to register without any user part (extension number) in the registration request (in its To header).

It’ll also happen if the given AOR in the To doesn’t match a configured AOR on the endpoint. The logic should be reworked to make that clearer, but it hasn’t bubbled up as a huge thing.

I’ve seen this happen when matching incoming requests based on IP address (without a port), so it gets associated with the wrong endpoint.

Wouldn’t you seen the unknown AOR in the message text, rather than ’ ', or is that what needs reworking?

That is what needs reworking.

Thanks for your replies. I don’t fully understand some of the terminology (endpoints, AOR, … ), but let me try and make things clearer for you so you can help make things clearer for me :slight_smile:

What I mean by “place in the UI” is “this error is probably something that I configured incorrectly either in the FreePBX UI, or in the HT813 configuration UI”.

But while it should be straight-forward to go back in the screens and find out, I am actually having trouble finding it.

Here are some more details (I obfuscated my phone number which starts with 21 by overwriting 212212212 manually):

<--- Received SIP request (554 bytes) from UDP: --->
Via: SIP/2.0/UDP;branch=z9hG4bK1989114344;rport
From: <sip:[email protected]>;tag=1868922450
To: <sip:[email protected]>
Call-ID: [email protected]
Contact: <sip:[email protected]:5062>;reg-id=2;+sip.instance="<urn:uuid:00000000-0000-1000-8000-C074AD90A2AE>"
Max-Forwards: 70
User-Agent: Grandstream HT813
Supported: outbound, path, gruu
Expires: 3600
Content-Length: 0

<--- Transmitting SIP response (321 bytes) to UDP: --->
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP;rport=5062;received=;branch=z9hG4bK1989114344
Call-ID: [email protected]
From: <sip:[email protected]>;tag=1868922450
To: <sip:[email protected]>;tag=z9hG4bK1989114344
Server: FPBX-16.0.26(18.13.0)
Content-Length:  0

[2022-12-21 15:02:39] WARNING[40600]: res_pjsip_registrar.c:1166 find_registrar_aor: AOR '' not found for endpoint 'LinhaMeo' (

Some configuration screens, I don’t know which are relevant. Note that is the FreePBX.

From what I gather from your replies, it seems…

  1. The error is caused by “initiative” of the HT813, trying to register with FreePBX, but FreePBX is not happy and rejects it
  2. I am probably quite confused about what entity (trunk? extension? user?) I should be configuring for this on the FreePBX. I think I only have a trunk. Should I create some other entity so that FreePBX is happy with the registration request?

BTW, I have the calls working in both directions, which is curious…

I also see this old thread, I don’t know if it is related:

I think I solved this - I changed two things, I don’t know which one made the difference:

  1. Changed trunk name to numeric following this advice.

  2. In trunk PJSIP settings changed registration to None. The calls still go through fine.

I’d still appreciate any further educational advice you have for me.

You have FreePBX set to send registrations, but whatever is generating the complaint is expecting it to be set to receive them.

You either need to disable registration in the gateway, and set Asterisk for no registration, or set registration to Receive, in Asterisk, and remove the static addresses.

Trunk and extension are FreePBX terms. Extension, for SIP, is something that looks like a phone and trunk is something that looks like a PABX or exchange. I forget the exact significance of user to FreePBX,

If receiving registration, the trunk name needs to be the HT813’s SIP User ID, but that need not be numeric.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.