FreePBX | Register | Issues | Wiki | Portal | Support

PBXact OS bug

bug
Tags: #<Tag:0x00007f749daba590>

(David Aas) #1

Got a bug with PBXact going on here. New PBXact 60 out of the box. Plugged it in and got to a command line. Ran “yum update” and “fwconsole ma updateall”. Rebooted. Now I have two boot options: “Sangoma Linux (3.10.0-862.2.3…” and “Sangoma Linux (3.10.0-693.11.1…” If the PBXact boots normally into v862, it locks up. The screen says “Probing EDD(edd=off to disable)…ok”. If I hard reboot, and select v693, it boots and I can get into it to configure. This is the second PBXact that this has done this to me, so it must be reproducible.


After doing OS updates through FreePBX systems fails to boot can boot by selecting older OS version
(Rob Thomas) #2

Unfortunately, I don’t have a UC60 here, but I’ve raised this internally as an issue. In the interim, to see what the actual problem is, can you push ‘e’ when selecting 862, and remove ‘rhgb’ and ‘quiet’ from the boot line. That will show us where it actually is hanging.

Here’s a screenshot of where they are:


(David Aas) #3

Thanks for the response, Rob. I don’t have those options. This is my screen when I hit “e”:


(David Aas) #4

OK, so I deleted the “Console=” command, and I got a boot screen. This is what I got when it locked up.


#5

I have the same issue on my Sangoma FreePBX 60…


(Tony Lewis) #6

Please contact support on this. The forums are mainly for FreePBX and this is a pretty big issue if your using our appliances with PBXact and a yum update has broken the box somot doesnt boot.


(David Aas) #7

Tony - I submitted a bug report and Andrew Negey canceled it and told me to go to the forums. That is why I posted it here.


(Tony Lewis) #8

Where did I say to open a bug report. Andrew works on the Dev team and issues.freepbx.org is for FreePBX. I said to open a support ticket, as this is a support issue and/or hardware issue it would appear.


(David Aas) #9

Support ticket has been opened. Ticket #806235


(Bryan Walters) #10

Hi David,
I went and looked at the bug report and Andrew was pointing out that the issue seems like a support request. While I understand the confusion in the 3 areas users may be able to get support as listed in our standard response, anytime it’s PBXact or Commercial module related, opening a ticket at support.sangoma.com is the best route. This ensures that we can better assist you by having our support team take a look. Sorry for the confusion and we will work on better communication in the future.


(David Aas) #11

Thanks. It is confusing where to go sometimes. I will get the hang of it.


(Bryan Walters) #12

David,
No worries, we are constantly listening to feedback to try to offer the best experience possible. One small example is based on yours and other community members feedback we have already made changes to our standard responses which I hope will make it easier to understand moving forward. Again my apologies about the confusion.


(Edrick Smith) #13

So was there ever a fix for you? I have two Sangoma 60 boxes we deployed and both crapped themselves after running a yum update out of the box. The only way I’ve gotten either of them to boot is manually selecting the second kernel option.


(Tony Lewis) #14

Can you tell us what version you are on and what kernel is not loading for you.


(Edrick Smith) #15

Sangoma Linux (3.10.0-862.9.1.el7.x86_64) 7 (Core)

Seems to be the default one that wont boot anymore and gets stuck at the Probing EDD

3.10.0-693.21.1.el7.x86_64

Is the one I’m booted into that is currently “working” that I manually have to select at boot the second option.

So I guess the question would be does it make sense to change the default boot to the newest one thats been working? If so is there a guide for changing the Sangoma 60 default boot?


(Tony Lewis) #16

But the one that is working is a older one. I suggest contacting support on this. They would know best.


(David Aas) #17

Yea, I had to put in a support request to get this resolved. I do not know what the solution was, but they remotely fixed it.

I still have a problem that I cannot do a remote restart on either of my PBXact 60 applicances. I have to manually to a power cycle to reset them. They will not do a successful reboot. They hang. Since they are in a live production environment, I am not real fired up about attempting to fix it.


(Tony Lewis) #18

Guys we had published a new sangoma-pbx RPM that blacklist a kernel module that is having issues for us. What version of sangoma-pbx RPM do you have. The version that fixes this issue is sangoma-pbx-1807-1.sng7.noarch

What is the output of
cat /etc/modprobe.d/audio-blacklist.conf


(Edrick Smith) #19

[root@freepbx ~]# cat /etc/modprobe.d/audio-blacklist.conf
blacklist snd-hdmi-lpe-audio
[root@freepbx ~]#


(Edrick Smith) #20

I’ve tried to open a support ticket, the box is activated and listed inside of the products tab in the sangoma portal. However the damn ticket system refuses to locate the deployment ID or name and wont let me submit a ticket.