Iotserver module, Cron and license

commercialmodules
Tags: #<Tag:0x00007f70284aecd8>

(Fbedia) #1

Since Tuesday, we have been receiving two emails from “Cron Daemon”:

Email 1:
Subject: Cron asterisk@asterisk /var/www/html/admin/modules/iotserver/bin/check_license.php
Body: This product is not licensed! Please purchase a license first.

Email 2:
Subject: Cron asterisk@asterisk /var/www/html/admin/modules/iotserver/bin/check_certificates.php
Body: This product is not licensed! Please purchase a license first.

I see that iotserver refers to the SmartOffice (https://wiki.freepbx.org/display/SMAR), commercial module, which we do not use or need

Yesterday I disabled the module from FreePBX module management, and today the email received was this:

Email 1:
Subject: Cron asterisk@asterisk /var/www/html/admin/modules/iotserver/bin/check_license.php
Body:
Exception: Unable to locate the FreePBX BMO Class 'Iotserver’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install iotserver 2) fwconsole ma enable iotserver in file /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 213 Stack trace:

  1. Exception->() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:213
  2. FreePBX\Self_Helper->loadObject() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:106
  3. FreePBX\Self_Helper->autoLoad() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:37
  4. FreePBX\Self_Helper->__get() /var/www/html/admin/libraries/BMO/FreePBX.class.php:105
  5. FreePBX->__callStatic() /var/www/html/admin/modules/iotserver/bin/check_license.php:12
  6. FreePBX->Iotserver() /var/www/html/admin/modules/iotserver/bin/check_license.php:12

Email 2:
Subject: Cron asterisk@asterisk /var/www/html/admin/modules/iotserver/bin/check_certificates.php
Body:
Exception: Unable to locate the FreePBX BMO Class 'Iotserver’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install iotserver 2) fwconsole ma enable iotserver in file /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 213 Stack trace:

  1. Exception->() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:213
  2. FreePBX\Self_Helper->loadObject() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:106
  3. FreePBX\Self_Helper->autoLoad() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:37
  4. FreePBX\Self_Helper->__get() /var/www/html/admin/libraries/BMO/FreePBX.class.php:105
  5. FreePBX->__callStatic() /var/www/html/admin/modules/iotserver/bin/check_certificates.php:5
  6. FreePBX->Iotserver() /var/www/html/admin/modules/iotserver/bin/check_certificates.php:5

What can I do to disable this module? or stop receiving these notifications from the cron every day?

Thanks


More Commercial Module Issues
(P Ramarajan) #2

@fbedia Try to uninstall the iot module with the below commands.

"fwconsole ma uninstall iotserver
fwconsole ma remove iotserver
"


(Tom Ray) #3

Still doesn’t solve the actual issue unless the resolution is that no one installs this module that has no plans on using it.


(Fbedia) #4

Done. I will wait until tomorrow to see if the Cron email arrives


(Fbedia) #5

I executed the commands:
fwconsole ma uninstall iotserver
fwconsole ma remove iotserver

And the message received tonight was as follows:

Subject: Cron asterisk@asterisk /var/www/html/admin/modules/iotserver/bin/check_certificates.php
Body: /bin/sh: /var/www/html/admin/modules/iotserver/bin/check_certificates.php: No such file or directory

Subject: Cron asterisk@asterisk /var/www/html/admin/modules/iotserver/bin/check_license.php
Body: /bin/sh: /var/www/html/admin/modules/iotserver/bin/check_license.php: No such file or directory

Maybe I should remove those checks from the Cron Daemon?
If so, can you tell me how? I do not know how to do it

Regards


(P Ramarajan) #6

Hi ,

Seems the cron entry not getting deleted after removing the module.

Edit the cron by using “crontab -e -u asterisk” and then delete the iotserver entries.


(Dave Burgess) #7

… and then submit a bug request. This is a new service and growing pains are to be expected.


(Fbedia) #8

Thank you all for your messages.

Despite having uninstalled the module, on Saturday it was automatically reinstalled.

On Saturday I received an email with the subject: “FreePBX (VoIP Server) Module Updates” and the following body:

" This is an automatic notification from your FreePBX (VoIP Server) server.

Installing missing modules: iotserver

Module iotserver successfully downloaded in 2 seconds Module iotserver installation completed in 39 seconds Done. All modules installed."

Finally I have chosen to edit the crontab, and remove the lines…
In this way at least I will not receive the email with the license error in iotserver every day …


(Fbedia) #9

Hello!

The Cron task was automatically added again … so I keep getting the emails.

I do not know what to do.

Uninstalling does not work, because it is reinstalled …

Editing the Cron does not work, because it reinstalls itself …

Any idea?
Am I the only one that this happens to?


(Itzik) #10

Disable automatic module updates.

If you chose not to, disable the module and try removing the cron job.


(Tom Ray) #11

While I’m not a fan of automatic updates this is a poor solution as Automatic Updates shouldn’t be playing the roll of “Automatic Installer”. The point behind this would be to keep your active modules updated automatically not for FreePBX to decide that it should ignore the module configs (Installed/Disabled/Not Installed) and just update/install everything it thinks it should.

Also, this whole thing with unlicensed/non-activated commercial modules just taking over the system with their crap installed is really, really a poor way to be handling things.


(Matthew Fredrickson) #12

I agree with this. I think we need to correct this behavior (or at least I need to do some research to better understand why it was originally built this way).

Matthew Fredrickson


(Robert Wooden) #13

I am having this same experience.
Therefore, I am watching this thread with interest.
Unfortunately, I have no solution as yet.


(Robert) #14

Disabling the Module, uninstaling it, editing cron all of this does not work because it just comes back on the next update. I don’t remember ever chosing to have this installed in the first place. This is getting pretty annoying especially if you manage many FreePBX and PBXact systems. (watching thread)


(Kapil Gupta) #15

We have https://issues.freepbx.org/browse/FREEPBX-21321 open so please add yourself as watcher to keep an eye for the progress update.

Thanks.


(Nenad Corbic) #16

Sorry for all the trouble this has caused.
This is not ok, and we will be fixing it as a top priority in the SmartOffice Team.
Thank you for your patience. As @kgupta1 indicated, we will be posting to the above ticket ASAP.


(Kapil Gupta) #17

Hi All

If we do not want FreePBX to install or upgrade any module due to auto-update or module admin->check online functionality then that module has to be “disable”.

If we uninstall the module then during auto -update or module admin -> “check online” will try to install that module again.

I request all of you to please disable the module instead of uninstalling the Iotserver module if you do not want to use iotserver module.

also on side note - Not removing cron jobs during un-installation of Iotserver module issue also has been fixed and available in v15.0.0.7 Or v14.0.2.8.

Thanks


(Fbedia) #18

Thanks for the replys

I will review the topic https://issues.freepbx.org/browse/FREEPBX-21321 for news

Today I saw this from the administration section, I have tried to disable it. I’ll see what happens …


(Kapil Gupta) #19

Hi @fbedia Module disable i mean you have follow below guide to disable iotserver module from module admin.

https://wiki.freepbx.org/display/FPG/Module+Admin+User+Guide#ModuleAdminUserGuide-Disable


(Fbedia) #20

Hi @kgupta1 thanks for reply,

I already tried to disable the module a long time ago, you can see it in my first message.

I did it again yesterday, but as on the other occasion, the same email is repeated:

Cron email:

Exception: Unable to locate the FreePBX BMO Class 'Iotserver’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install iotserver 2) fwconsole ma enable iotserver in file /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 213 Stack trace:

1. Exception->() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:213

2. FreePBX\Self_Helper->loadObject() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:106

3. FreePBX\Self_Helper->autoLoad() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:37

_4. FreePBX\Self_Helper->_get() /var/www/html/admin/libraries/BMO/FreePBX.class.php:105

_5. FreePBX->_callStatic() /var/www/html/admin/modules/iotserver/bin/check_certificates.php:5

6. FreePBX->Iotserver() /var/www/html/admin/modules/iotserver/bin/check_certificates.php:5