Iotserver module, Cron and license

commercialmodules
Tags: #<Tag:0x00007f702dda4888>

(PbxNoob) #21

Just to say I’m getting these annoying emails too. Two, daily, for the last month or so.


(D E) #22

@kgupta1 me too - any ideas how to disable?!


(Kapil Gupta) #23

Hi @dan_ce and All,

Just fyi - We are working on the solution and if our QA approves the fix then should be able to release by mid of next week.

thanks a lot

Regards
Kapil


(Kapil Gupta) #24

Hi All

We have released new framework module i.e. v14.0.13.30 and v15.0.16.51 which has fixes to avoid installing removed or uninstall module during auto updates.

Please refer to https://www.freepbx.org/framework-changes-related-to-module-auto-update-functionality/

Best Regards
Kapil


(United States) #25

What do I need to do to see this change? FreePBX doesn’t show any system updates or any module updates are available, but I’m still getting these two e-mails nightly.


(Kapil Gupta) #26

Are you using mentioned 14 and 15 framework releases i.e. v14.0.13.30 and v15.0.16.51 ? If not then you might be having old versions of framework.

You might have to delete the cron manually Edit the cron by using “crontab -e -u asterisk” and then delete the iotserver entries.


(United States) #27

I am on 14.0.13.28. How do I upgrade to .30?

I assumed the “updates” module kept everything up to date.


(P Ramarajan) #28

Hi @DSP55555
We have pushed the latest framework module to the stable track so now you can able to upgrade modules from the module admin.
Upgrade all the modules to the latest version, including the iotserver module, and after that uninstall the iotserver module. The corn entries will be erased after uninstalling the iotserver module so you will not get those E-mails further.


(United States) #29

I have updated the framework and disabled smart office. I don’t see iotserver in the list of modules. (I’m using the web interface.)


(Kapil Gupta) #30

IOT server is raw. name of Smart office module. So please upgrade smart office to latest available and then uninstall it to remove cron jobs entries.

Due to latest framework , Smart office will not automatically install again to your system

Thanks


(United States) #31

I’m not sure what I’m doing wrong, but I’m still receiving the e-mails.

I am on 14.0.13.30

image

Smart office is uninstalled


(United States) #32

I will try Removing it on top of Uninstalling it.


(United States) #33

I guess I will just ignore these e-mails. I cannot get them to stop.

Edit:
I had not edited the cron entries. I thought the updates would take care of that. The iot entries were still in there. I have now deleted them. I assume that was the step I was missing. Thanks


(Dave Burgess) #34

IIRC, there was a module update that fixed them, but you have to download and install the new version, then disable it to get the module to remove that. Removing them yourself would probably be simpler for you at this point.