IOT Server Cron Job Permission denied 20 emailsap

I keep getting emails Subject: Cron [email protected]

/var/www/html/admin/modules/iotserver/bin/check_system_settings.php 2>&1 >/dev/null
/bin/sh: /var/www/html/admin/modules/iotserver/bin/check_system_settings.php: Permission denied

FreePBX 15.0.23.11
so I followed the advice on this link
first I ran in the CLI
fwconsole ma uninstall iotserver
fwconsole ma remove iotserver
then I used WINscp
and I deleted the crown job line

  • 2 * * * /var/www/html/admin/modules/iotserver/bin/check_guest_users_status.php 2>&1 >/dev/null
    but I still get this email
    /var/www/html/admin/modules/iotserver/bin/check_system_settings.php 2>&1 >/dev/null
    Cc:
    Bcc:
    Date: Wed, 13 Jul 2022 14:01:01 -0400 (EDT)
    Subject: Cron [email protected] /var/www/html/admin/modules/iotserver/bin/check_system_settings.php 2>&1 >/dev/null
    /bin/sh: /var/www/html/admin/modules/iotserver/bin/check_system_settings.php: Permission denied

Are you using IOT server? If not, remove with

fwconsole ma disable iotserver

since I already uninstalled it
The following error(s) occured:

  • Specified module not found

[email protected]
I see what the problem is I don’t think I’m getting new emails about this issue Gmail is just saying that it can’t deliver the message since freepbx is trying to send it to a non-existent email [email protected]
I set up a different email in System Admin pro Notifications Settings so I have no clue why freepbx is trying to send to [email protected]

“FQDN fully qualified domain name of the PBX”

It isn’t FreePBX that is doing this, it is the OS. It will actually just be mailing it to the local user that owns the crontab, i.e. asterisk, and the system mail program is adding the domain name and trying to delivery using Gmail. On simple systems, it would have just ended up in /var/spool/mail/asterisk.

Getting FreePBX systems to send mail addressed to local users, to a completely different email address is discussed in: