WebRTC we are almost there [SOLVED]


(Claudio Pelosi) #1

WebRTC to activate …

I saw online that there is a way to enable a module to make phone calls via the PC on the FreePBX users panel
here is link

but I do not find in my version, which is recent, the functionality, does anyone know how to enable it?


(Claudio Pelosi) #2

Sorry I think I solved it myself
It was to be enabled in the “module admin” panel


(Claudio Pelosi) #3

No I have not solved!
I enabled the module but nothing …


(Claudio Pelosi) #4

I created a simple video to show you where the problem is …


(Lorne Gaetz) #5

For the UCP phone client, in addition to having UCP phone enabled in User Management, you must have TLS working and logged into UCP using https without errors:


(Claudio Pelosi) #6

Here … I guess my https is not certified …


(Claudio Pelosi) #7

But when to use any webrtc software I need https certificate …?


(Claudio Pelosi) #8

Well, I installed the certificate but the webrct phone does not appear …
Anyone have ideas to help I made another movie:


(Claudio Pelosi) #9

I’m also trying external open source profiles to lean on freepbx sockets, it seems to me that it uses port 8088, but how can I verify which port it uses?
I guess there is a configuration …


(Claudio Pelosi) #10

documenting myself I think I understand that the most correct string for the socket is:
wss://ast005.ergotel.eu:8088/ws

but still nothing
any indication would be invaluable, thank you


(Claudio Pelosi) #11

WebSocket connection to ‘wss://ast005.ergotel.eu:8088/wu’ failed: Error in connection establishment: net::ERR_SSL_PROTOCOL_ERROR

Here’s what I get by checking the debug …
It would seem that the certificates do not extend the socket!
And now I don’t know how to apply them to the socket …


(Claudio Pelosi) #12

this is what i need
https://wiki.asterisk.org/wiki/display/AST/Asterisk+WebRTC+Support
but where are the files to be edited?


(Itzik) #13

Did you set that new certificate as the default?

Also, you don’t need to log out from the Admin GUI to access UCP


(Lorne Gaetz) #14

The browser must have access to port 8089:
https://wiki.freepbx.org/display/PPS/Ports+used+on+your+PBX


(R K) #15

We purchased this module. It ended up not being used at all. Money wasted. It was the very reason that you all are here. You now know that it is very hard to configure now!


(Lorne Gaetz) #16

Webrtc module is free and open source.


(Claudio Pelosi) #17

I arrived right there, in fact so that I have to use the wss version that runs on door 8089 but it does not seem to be open the door 8089 only the 8088 seems open

How do I activate wss on port 8089?


(Claudio Pelosi) #18

are you referring to this?


(Claudio Pelosi) #19

see I configured so on port 8089 but nmap does not see it open and in fact does not seem to work, am I wrong or am I missing something?

nmap


(Claudio Pelosi) #20

it seems that by enabling “Enable TLS for the mini-HTTP Server” port 8089 is open now I will try it …