WebRTC we are almost there [SOLVED]

ok from “User Control Panel” starts working …
but it doesn’t seem to work

I’m also trying with other webrtc
is the string correct?

Now in the “ucp” panel the phone appears but the icon is red and does not seem able to do anything …
What a frustration

Checking the javascript console here is what you see:
VM1388: 39 WebSocket connection to ‘wss: //ast005.ergotel.eu:8089/ws’ failed: Error in connection establishment: net :: ERR_SSL_VERSION_OR_CIPHER_MISMATCH

maybe the certificate is not accepted …?

I’ll ask again. Did you set the new certificate as the default?

Also, if you are using an external address, you’ll need to forward these ports.

Thanks PitzKey
For safety I checked the accessibility of the doors and it is open.
While I don’t understand how to set the new certificate as default can you help me?
Thank you


Thanks for the indication.
I tried this feature this morning and it created problems for me.
I have restored some files by hand and now it appears as shown in the attached image.
Is there a manual way to configure websocket in wss on port 8089 with certificate?

but maybe I have to insert the certification in the certificate certification first …
Now I try!

I think I did everything correctly but nothing always the same problem:
WebSocket connection to ‘wss: //ast005.ergotel.eu: 8089 / wu’ failed: Error in connection establishment: net :: ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I attach images of what I configured on FreePBX

In your last screenshot you show that you did not select that cert1 as the default.

Read what it says there.

Hover over the ‘Default’ column and click to make a certificate the system default

Done but nothing, wait and read my next message …

Attention inserted in “Asterisk Builtin mini-HTTP server” the strings related to the certificates just successfully installed here is screen capture:

Well now the error message is no longer encryption error here is the new error …:
sip.min.js:39 WebSocket connection to ‘wss://ast005.ergotel.eu:8089/wu’ failed: Error in connection establishment: net::ERR_CONNECTION_RESET

It has trouble reaching port 8089 on your PBX.

I haven’t seen it referenced here yet, but there is a guide in the wiki about getting UCP WebRTC phone up and running: https://wiki.freepbx.org/display/FPG/WebRTC+Phone-UCP

1 Like

Here after the update the 8089 does not respond …
Now I see what happens!

I was going around the modules as the guide recommends and I have this error. How do you recommend me to proceed?

exit: 255
Unable to continue. Inbound Route 0192075897/ does not have a valid destination in /var/www/html/admin/modules/core/functions.inc.php on line 1410
#0 /var/www/html/admin/libraries/BMO/DialplanHooks.class.php(95): core_do_get_config(‘asterisk’)
#1 /var/lib/asterisk/bin/retrieve_conf(864): FreePBX\DialplanHooks->processHooks(‘asterisk’, Array)
#2 {main}

I was updating the core

I solved I remove the route that gave problems …

Let’s take stock
After updating as indicated in the guide:

Door 8089 no longer opens


I also attach the configurations:

I also attach the panel that does not work the phone remains red and does nothing:

Here is the current console error generated when trying to use webrtc:

WebSocket connection to ‘wss: //ast005.ergotel.eu: 8089 / ws’ failed: Error in connection establishment: net :: ERR_CONNECTION_REFUSED

Why should port 8089 not go?

Be careful removing strings

Location of the TLS HTTPS certificate

Location of the private key TLS HTTPS

Port 8089 is now functional

Now I do some tests…