WebRTC call button do nothing

Hi commu!

Sorry if i sound a bit newbie but i am.

I wanted to configure and test webRTC module but no luck with that.
i followed the wiki : WebRTC Phone-UCP - PBX GUI - Documentation
and i got this :

I got two extensions one connected to a softphone 3CX

The WebRTC module is installed

My Ports are like this…

The Letsencrypt certificate is created.

I enabled the webrtc option on the user management for the extension “45”

BUT ! When i’m trying to manage a call with my trunk or to my softphone “23” nothing happens when i’m pressing “call”

Thanks by advance for any help!

What do you see in the browser console?

You must enable HTTPS and login to the UCP using the LE fqfn and HTTPS.

Ty but no luck… i have the same result …

the call button do nothing

Same result with all port set to default

I tried so many port combinaison, and so many tutorial on google, but my call button refuse to work. Can someone who have a working webrtc, show me the configuration ???

I’m really lost right now

Bring up the Asterisk console (asterisk -r from your terminal) and set verbose (CLI> core set verbose 9). Then try to place a call with webrtc. See whether it tries, and whether any errors appear in the console.

Also try bringing up the Javascript developer console in your browser (in Chrome, it’s View - Developer - Javascript Console). You will see informational messages there as you attempt to place a call. Mine looks like this:

ok i got some news

The when i press “call” there is no report in the console when i’m trying to “originate call” i got this

The f12 console bring me that firefox can’t set a connection with wss://communication.jobphoning.com:8089/ws (my FQDN)

Certificate :

Https settings


My port 8089 seems closed, how do i open ports with the freePBXgui??

You need to open it on your router

My FreePBX server isnt in local, we can’t open one through the gui ?
Or i need to open with the centOS ?

That may not be a firewall issue. I believe it is due to your HTTPS settings in Advanced Settings. Why did you set those custom values for HTTPS TLS Certificate Location and HTTPS TLS Private Key? If your Let’s Encrypt certificate is set as default (and it appears to be), you should reset those to the defaults which will point at /etc/asterisk/keys/integration/…

I don’t remember well what default value was

If this seems good for you, i got the same result with the webRTC

Click the circling-arrows icon to return to the defaults.

HTTPS TLS Certificate Location (?) (@) <- the icon at the end

You will need to restart Asterisk too.

After you do, from the Asterisk CLI (asterisk -r), do

CLI> http show status

mine looks like this:

bell*CLI> http show status 
HTTP Server Status:
Server Enabled and Bound to

HTTPS Server Enabled and Bound to [::]:8089

Enabled URI's:
/httpstatus => Asterisk HTTP General Status
/static/... => Asterisk HTTP Static Delivery
/ws => Asterisk HTTP WebSocket

Enabled Redirects:

Done. But sadly even after a complete reboot no changes noticed

the “return to default” thing with 2 arrows leave the thing empty ? is that normal?

Go back to the certificate manager and again set your Letsencrypt certificate as default. It should fill in the fields. If not, the fields are “/etc/asterisk/keys/integration/certificate.pem” for the certificate and “/etc/asterisk/keys/integration/webserver.key” for the key.


the default settings are correctly back.

But no luck, same result

Oopsi for the password, i edited it just now.

You can test the WSS from your browser. Browse to https://yourname:8089/ws

You should see a message from Asterisk saying “Upgrade required” (it means you are supposed to connect with websocket and not HTTP, but it is useful for a test)

If you don’t see this, maybe your browser will show you a certificate error or if the connection times out altogether you still need to investigate your firewall further.

1 Like


How can i switch this process ? it does not speak to me very much