User Manager module clearing all linked extensions

In the User manager module if i edit a user and add a default linked extension it will erase every other users linked extensions. It will save just the one I added last and clear all the others.

Editing the extension from the extensions module and adding a user will work however. As will directly modifying the asterisk/userman_users table in mysql.

I’ve been fighting this brand new server… None of the phone apps would work after I setup all the extensions. Finally figured out all the linked users were missing from the extensions. The new extension created them. I can get them relinked. Switch to User Manager and see all the extensions properly linked there. Then at some random point…either a reboot, editing the inbound route, ring group or phone template in EPM… POOF blows all the linked accounts away.

Are all your modules updated as I can not recreate this.

1 Like


Just triggered it. Added a description to a user. Saved and Applied changes, blew all linked accounts away.

Pjsip or chansip?


Tested repeatedly with User Management 13.0.74 and cannot reproduce.

1 Like

Just swapped the drive, I’ll do another reload see if I can reproduce the same results.

Fresh load and updated all modules. straight to creating two new extensions. Switched to user management, Modify user details wipes out linked extension. As soon as user details are saved, the link on the modified user disappears. When you apply- it erases all the linked users.

Reloaded again w/ different distro.

Looks like its only on asterisk 11 installs where freepbx is installed at 12 and upgraded to 13. AsteriskNOW-6.12.65-26 and AsteriskNOW-6.12.65-32

Going straight to freepbx 13 w/ FreePBX-64bit-10.13.66.iso install doesn’t exhibit this behavior I’ve seen yet.

This is my exact use-case! I was also able to reproduce it by restoring a full backup to a fresh installed server.

I just signed into the forum to post that I was in the paid “Caller ID Management” module and went to add a new user today, and it deleted all the other 200+ users. We’re holding off on hitting the “apply config” button, obviously.

We are also on Asterisk 11 and FreePBX 13, we have upgraded everything to the newest system and modules since I started using FreePBX about 8 months back.

This has nothing to do with User Manager?

I noticed today I dont have to actually make any changes to a user within the user manager module. Just clicking edit will cause the loss of linked extensions.

All my modules are up to date. User Management is version Stable

It still has to do with adding a single entry via the GUI which causes all the other entries to vanish but the single new one added remains. One is in the GUI for User Manager and one is in the GUI for Caller ID Management, but I figured with timing of original post, and the similarity of our update paths, the two might be related.

I’ll revert to a previous backup and if we’re able to reproduce it I’ll just file a bug for CID Management module then, no worries.

If anyone needs logs or other info, I can do an easy drive swap to fire up the affected load. But it looks like I’m going to stay w/ the official freepbx distro I listed in my last post.

The zulu app is exactly what my users have been wanting for years. No clue why any of my previous searches (tapi, outlook connector, click to dial, etc) never listed that module. Might be some good keywords to add.

My only bitch so far is the “other” tab on new extension creation still does not save any of the endpoint configuration. It only saves it after the extension is created and you go back in to add the data…I’m assuming its a programming limitation?

Hey bflorin, you don’t use lastpass do you? My coworker got the bug again when adding a user this time (it cleared out all users and took out all the calls on the server too), but I restored from a backup and I tried and didn’t get it, so I’m thinking it’s a possibility that Lastpass was doing some behind-the-scenes autopopulating or something? I told him to disable lastpass for our freepbx domain so we’ll see if it happens again.

1 Like

I encounter this bug with and without lastpass, on chrome, firefox and vivaldi.

Are you using an Authentication Engine besides FreePBX Internal Directory? I ran into this issue using Microsoft Active Directory. I would link extensions to users and they’d seem to randomly unlink themselves. Turned out this was because I needed the numbers set up in Active Directory. Now they stay linked.

If you’re just using FreePBX Internal Directory, disregard this.

I’m only using the internal directory, can’t speak for others though.