Upgrade FreePBX systems


(Denic) #1

Hi! The company I started working for recently has three FreePBX systems. One Version 14 and two Version 13. These are very old computers that sometimes crash (overheating).

We have new hardware ready. My plan was to install a new FreePBX 15 distro and to backup the old systems and restore them on the 15.

Is that the correct way to do it?


#2

Theoretically its the right way, Practically it mostly works, In reality when it doesn’t we are still in the bug-fix arena. . . . . (have backups of everything)


(Denic) #3

Thanks dicko!

I have a new 15 install ready and fully updated. I have never used it for any phone calls and it has no trunks so far, but I hope that is okay.

I will try backing up and old system and restoring it here.


(John Jarrett) #4

One thing that I have found helpful is to make sure your backup and restore module for all your versions is the latest and probably best to be an Edge version. I’ve had pretty good luck but it has in the somewhat recent past miss some stuff from earlier versions.


(Denic) #5

Thanks, John! When I fírst tried, I got error messages. Now I updated to edge and they are gone.

However, I see that the ports, etc are not restored.

On the new distro, what do I have to set up before the restore?

Also, I see there is an Asterisk Manager Password and ARI Password that is now different on the new and old PBX. Do I have to change that?


(John Jarrett) #6

I have never paid any attention to the built in default passwords in FreePBX. Things always worked and I have no idea if those passwords have changed from version to version. I would somehow hope they would. On my new box I just make sure everything is fully updated and then restore to it and fix what’s broken or didn’t restore. It is getting better! Good luck and sorry for the delay.


(Denic) #7

No problem. I worked on this for almost 10 hours today. Got some things running.

The UCP does not work anymore. I get thousands of these messages:

image

What is that, and how do I fix it?


(John Jarrett) #8

Now your beyond my abilities. Start scouring through your logs. I am sorry!


(Dave Burgess) #9

The console log is stored in /var/log/asterisk/full. There should be some information in there about what the specific problem is.


(Denic) #10

I checked this and all other logfiles at that location and there is nothing specific to this problem.


(Matt Brooks) #11

I believe in this case, the console log is talking specifically about the Javascript console log. This should be found in your browser. In chrome, this can typically be found in the menu: View -> Developer -> Javascript Console


(Denic) #12

Using Edge. Edge console log:


(Matt Brooks) #13

Unfortunately, this maybe a bug. A 403 error typically has to do with authentication/authorization. I’ve also seen a few others complain about this issue, but I’ll need to research it more to understand what the problem is exactly.


GUI stopped opening
(Denic) #14

Thanks. Let me know if you need more information.

Might have something to do with the passwords? See above?


(Jared Busch) #15

Chromium based new Edge? Or craptastic original MS Edge?


(Denic) #16

Microsoft Edge 44.18362.449.0

Tested Chrome und FireFox, same problem.


(Denic) #17

Is there a way to turn on more logging in FreePBX to see what is going on?


(Denic) #18

Anybody? More logging possible?


(Dave Burgess) #19

The error this guy is seeing is the same one you are. Could you look through his thread and see if there are similarities?

@mbrooks since you’re on both of these, do you see any other similarities?


(Matt Brooks) #20

@cynjut Yes, I believe it is the same issue. I was planning on updating this forum thread once we had an issue in jira.