Update SNG7: RPM command errored, tried to run '/usr/bin/rpm -q --queryformat

When clicking the Updates tab on FreePBX GUI under Admin I am getting an error:


Does this get fixed if you manually run

yum update

at the command line?

Is this system an upgrade from FreePBX 13 or was it originally installed as FreePBX 14?

For some of us it fixed it, for others it did not…

Good luck and have a nice day!


That was a FPBX 14 install.
Yum update completed fine.
Error still showed but does no longer after a reboot.

I had the same problem too, this is what i did to recover
Try to run yum update --skip-broken and also upgrade all fourn FreePBX modules by running fwconsole ma upgradeall

check also the following thread

there are many threads related to this problem.

I ran yum update, FW console updateall. Error still showed. Then rebooted. Error was gone.


OK, thank you!

Until you rebooted the error message stayed there?

Have a nice day!


I believe --skip-broken (and the rest of the solution given for this ticket) was only for people who had upgraded from FreePBX 13 with the distro upgrader “script”.

The solution for people who originally installed as FreePBX 14 and did not upgrade was simply a yum update.

This is the reason why I asked if he had upgraded from FreePBX 13 or initially installed as FreePBX 14, I wanted to know what we were dealing with.

By the way, if you have a problem which requires you to use –skip-broken it is far more preferable to fix the problem instead of using –skip-brokens because the problem will come back to haunt you later (just like Halloween :wink:).

Chances are yum upgrade would have worked for you as adding –skip-broken only instructed yum to skip broken dependencies if it saw any

Have a nice day,