System updates gets exception even after reboot

tried to run a system update this morning and got the following. Rebooted and did same.

if you go back to HOME and then MODULE ADMIN then you still get this exception

Hi Leon:

There were substantial OS updates pushed yesterday that require framework to be current. You should be able to restore module admin wiith:

fwconsole ma --edge upgrade framework

edited to add --edge

Hi Lorne…ok will give it a shot thanks for the prompt reply.

leon

I did that and did an APPLY on the GUI and I still get the exception.

[[email protected] ~]# fwconsole ma upgrade framework
No repos specified, using: [standard] from last GUI settings

Downloading module 'framework’
Processing framework
Verifying local module download…Verified
Extracting…Done
Download completed in 4 seconds
Updating table admin…Done
Updating table ampusers…Done
Updating table cronmanager…Done
Updating table featurecodes…Done
Updating table freepbx_log…Done
Updating table freepbx_settings…Done
Updating table globals…Done
Updating table module_xml…Done
Updating table modules…Done
Updating table notifications…Done
installing files to /var/www/html…done
installing files to /var/lib/asterisk/bin…done
installing files to /var/lib/asterisk/agi-bin…done
Checking for upgrades…
No further upgrades necessary
framework file install done, removing packages from module
file/directory: /var/www/html/admin/modules/framework/amp_conf removed successfully
file/directory: /var/www/html/admin/modules/framework/upgrades removed successfully
file/directory: /var/www/html/admin/modules/framework/start_asterisk removed successfully
file/directory: /var/www/html/admin/modules/framework/install removed successfully
file/directory: /var/www/html/admin/modules/framework/installlib removed successfully
Generating CSS…Done
Module framework successfully installed
Updating Hooks…Done
Updating Hooks…Done
[[email protected] ~]#

Plan B, try running:

fwconsole ma upgradeall

trying now…I was able to get to module admin but as soon as I went to system admin and did a check it would go into an loop. doing a browser refresh gets the exception panel

DIVE DIVE ALARM — :slight_smile: Nope take 3?

I really dont want to have to reload yet again…I already reported that full backup fails and noone responded to that thread. :frowning:

I shouldn’t be having all these problems.

Thanks leon

The only thing I can think of at this point is to run the updates manually with:

yum update

then reboot

trying now thanks

Did you open a bug report as forums are not what the dev team watches for bugs.

I just realized you probably needed the edge version of Framework. I have updated my post above.

Lorne…that worked thanks.

Tony…no since I got chastized for not coming here first when I did that previously

Leon

I opened a bug report, same issue on 4 systems

https://issues.freepbx.org/browse/FREEPBX-15967

ok thanks chris

Having the same problem here. tried

fwconsole ma --edge upgrade framework

but that hasn’t made any difference. Next I tried:

yum update

but get the following errors after downloading 332 files:

Transaction Summary
======================================================================================================================================================================================================
Install    8 Packages (+9 Dependent packages)
Upgrade  315 Packages

Total size: 438 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /etc/fail2ban/filter.d/assp.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/filter.d/cyrus-imap.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/filter.d/exim-common.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/filter.d/exim.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/filter.d/mysqld-auth.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/filter.d/sendmail-reject.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/filter.d/sshd-ddos.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/filter.d/sshd.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/filter.d/suhosin.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /etc/fail2ban/jail.conf from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /usr/bin/fail2ban-client from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /usr/bin/fail2ban-regex from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /usr/bin/fail2ban-server from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /usr/lib/systemd/system/fail2ban.service from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /usr/share/man/man1/fail2ban-client.1.gz from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /usr/share/man/man1/fail2ban-regex.1.gz from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /usr/share/man/man1/fail2ban-server.1.gz from install of fail2ban-server-0.9.7-1.el7.noarch conflicts with file from package fail2ban-fpbx-0.8.14-11.sng7.noarch
  file /usr/lib/firmware/ql2400_fw.bin from install of linux-firmware-20170606-56.gitc990aae.el7.noarch conflicts with file from package ql2400-firmware-7.03.00-1.el6_5.noarch
  file /usr/lib/firmware/ql2500_fw.bin from install of linux-firmware-20170606-56.gitc990aae.el7.noarch conflicts with file from package ql2500-firmware-7.03.00-1.el6_5.noarch

Error Summary
-------------

[[email protected] xinetd.d]#

Any other pointers, please?

Worked for me ![quote=“lgaetz, post:3, topic:44597”]
Hi Leon:

There were substantial OS updates pushed yesterday that require framework to be current. You should be able to restore module admin wiith:

fwconsole ma --edge upgrade framework
[/quote]

I have the same problem.
In addition when I run:
yum upgrade

I receive this error:

  file /usr/lib/firmware/ql2400_fw.bin from install of linux-firmware-20170606-56.gitc990aae.el7.noarch conflicts with file from package ql2400-firmware-7.03.00-1.el6_5.noarch
  file /usr/lib/firmware/ql2500_fw.bin from install of linux-firmware-20170606-56.gitc990aae.el7.noarch conflicts with file from package ql2500-firmware-7.03.00-1.el6_5.noarch```

I've also run: `fwconsole ma --edge upgrade framework`

i ran the giant rpm -q command from the error that was spit out, and these were missing

package grub2-efi-x64.x86_64 is not installed
package grub2-tools-efi.x86_64 is not installed
package grub2-tools-extra.x86_64 is not installed
package grub2-tools-minimal.x86_64 is not installed
package python-gobject-base.x86_64 is not installed
package shim-x64.x86_64 is not installed

looks like some dependencies were changed, so i manually installed them

yum install grub2-tools
yum install grub2-tools-efi.x86_64
yum install python-gobject-base.x86_64
yum install shim-x64.x86_64

i could then run the GUI “updates” module to install 250+ packages.

At the end i ran this as I didn’t see this thread until later
fwconsole ma --edge upgrade framework

hopefully this helps someone

1 Like