Unable to Transfer Direct to Voicemail for a single extension

Asterisk is 13.9.1
FreePbx is 13.0.192.16

I have a single extension (119) who I am unable to transfer calls directly to voicemail using *119. All other extensions are working fine (101 - 120). When attempting to transfer using *119 I receive an invalid extension message.
I have checked to following.

  • Verified users mailbox was built/configured including having a password set.

  • Tested reaching users Voice mail via blind transfer (works) as well as UCP (works)

  • Reviewed voicemail.conf to make sure mailbox entry appeared correctly

  • Deleted Extension and Mail box and rebuilt.

  • Checked for possible enabled conflicting Feature Codes.

    Below is a copy of the Verbose output during the most recent test. During this example, the User at Extension 104 attempted to transfer me using *119, I received the invalid extension message and was prompted to enter the extension in manually, Which I did. And was then prompted for the Extension again.
    Assistance is appreciated.

– Executing [[email protected]:3] Wait(“Local/[email protected];2”, “1”) in new stack
– Channel SIP/104-000005dc left ‘simple_bridge’ basic-bridge <051df229-8ae0-4df1-8b2f-40b1246b5366>
== Extension Changed 104[ext-local] new state Idle for Notify User 101
== Extension Changed 104[ext-local] new state Idle for Notify User 115
== Extension Changed 104[ext-local] new state Idle for Notify User 109
== Extension Changed 104[ext-local] new state Idle for Notify User 113
== Extension Changed 104[ext-local] new state Idle for Notify User 108
== Extension Changed 104[ext-local] new state Idle for Notify User 117
== Extension Changed 104[ext-local] new state Idle for Notify User 106
== Extension Changed 104[ext-local] new state Idle for Notify User 116
== Extension Changed 104[ext-local] new state Idle for Notify User 105
== Extension Changed 104[ext-local] new state Idle for Notify User 102
PRI Span: 1 Ignored redirecting update because call in state Active(10).
== Extension Changed 104[ext-local] new state Idle for Notify User 111
== Extension Changed 104[ext-local] new state Idle for Notify User 123
== Extension Changed 104[ext-local] new state Idle for Notify User 103
== Extension Changed 104[ext-local] new state Idle for Notify User 122
== Extension Changed 104[ext-local] new state Idle for Notify User 114
== Extension Changed 104[ext-local] new state Idle for Notify User 112
== Extension Changed 104[ext-local] new state Idle for Notify User 120
== Extension Changed 104[ext-local] new state Idle for Notify User 121
== Extension Changed 104[ext-local] new state Idle for Notify User 107
== Extension Changed 104[ext-local] new state Idle for Notify User 119
== Extension Changed 104[ext-local] new state Idle for Notify User 110
– Executing [[email protected]:4] GotoIf(“Local/[email protected];2”, “0?s-FIXED,1”) in new stack
– Executing [[email protected]:5] Set(“Local/[email protected];2”, “AMPUSER=9”) in new stack
– Executing [[email protected]:6] GotoIf(“Local/[email protected];2”, “1?gotpass”) in new stack
– Goto (macro-user-logon,s,9)
– Executing [[email protected]:9] GotoIf(“Local/[email protected];2”, “1?s-NOUSER,1”) in new stack
– Goto (macro-user-logon,s-NOUSER,1)
– Executing [[email protected]:1] NoOp(“Local/[email protected];2”, “Invalid extension 9 entered”) in new stack
– Executing [[email protected]:2] Playback(“Local/[email protected];2”, “pbx-invalid”) in new stack
– <Local/[email protected];2> Playing ‘pbx-invalid.ulaw’ (language ‘en’)
– Executing [[email protected]:3] Goto(“Local/[email protected];2”, “s,playagain”) in new stack
– Goto (macro-user-logon,s,7)
– Executing [[email protected]:7] Read(“Local/[email protected];2”, “AMPUSER,please-enter-your-extension-then-press-pound,4”) in new stack
– <Local/[email protected];2> Playing ‘please-enter-your-extension-then-press-pound.slin’ (language ‘en’)
– User entered ‘119’
– Executing [[email protected]:8] GotoIf(“Local/[email protected];2”, “0?s-MAXATTEMPTS,1”) in new stack
– Executing [[email protected]:9] GotoIf(“Local/[email protected];2”, “0?s-NOUSER,1”) in new stack
– Executing [[email protected]:10] Set(“Local/[email protected];2”, “AMPUSERPASS=”) in new stack
– Executing [[email protected]:11] GotoIf(“Local/[email protected];2”, “1?s-NOPASSWORD,1”) in new stack
– Goto (macro-user-logon,s-NOPASSWORD,1)
– Executing [[email protected]:1] NoOp(“Local/[email protected];2”, “This extension does not exist or no password is set”) in new stack
– Executing [[email protected]:2] Playback(“Local/[email protected];2”, “pbx-invalid”) in new stack
– <Local/[email protected];2> Playing ‘pbx-invalid.ulaw’ (language ‘en’)
– Executing [[email protected]:3] Goto(“Local/[email protected];2”, “s,playagain”) in new stack
– Goto (macro-user-logon,s,7)
– Executing [[email protected]:7] Read(“Local/[email protected];2”, “AMPUSER,please-enter-your-extension-then-press-pound,4”) in new stack
– <Local/[email protected];2> Playing ‘please-enter-your-extension-then-press-pound.slin’ (language ‘en’)

Your “*11” is getting stripped. Check your Feature Code list and see if “*11” is set to something.

on our new deployment we are having the SAME exact issue. I just haven’t had time to investigate. I totally forgot we had the same issue last year when we deployed. My company just refuses to change extension scheme. HAHA. Thanks

I do believe its this one:

*10 may also play a role in that which is Contact Speed Dial.

The issue is with the Login/Logout feature codes. By default, they are not displayed so first browse to Advanced Settings and set “Expose All Feature Codes” to yes. Then browse to Feature Code Admin and disable the Logon and Logoff feature codes which you don’t need anyway.

So would all of those actually interfere? *1, *11 and *10 or just *11. and if only *11 why?

*1 is an in-call feature so it won’t interfere. All others are potential conflicts, and depend on the load order for which will govern. In practice, I’m not aware of a case that wasn’t logon/off.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.