Unable to dial out internationally


(Honor's Haven It) #101

image

I just tried to dial both, the london number goes out fine, the other doesn’t get anywhere near the PBX, and just stalls at 5 digits in…


(Honor's Haven It) #102

I’ve made a bit of progress when dialing out, but the one issue that’s been persisting is getting the system to even dial out. I’ve tried everything to get past the first 5 digits, but consistently, at least one international number gets stuck there and the system fires back the same error of ‘your call can not be completed as dials, please check the number and dial again’ with the “REORDER” error on the phone itself. I’ve looked in the PBX, the trunk, the Adtran units, I’m running out of areas to check here. If anyone here needs additional data, I can try and get it, but right now, I’m beyond lost…


(Greg Kujawa) #103

It could be something coming into play like digit timeouts? I know for long, different sorts of numbers to dial that can happen. Where the IP-PBX assumes your done and tries to interpret just the first handful of digits you’ve dialed.


(Honor's Haven It) #104

It turns out the only place I can call internationally is London, no other number gets past the “reorder” error.


(Honor's Haven It) #105

Where would I find the place to remove the digit timeout? I’ve tried everything but I haven’t found anything like that…


(Honor's Haven It) #106

image

I’ve been looking around online to see if anyone else has an issue like this one, and it’s odd that one sugguestion was codec errors. I don’t think it’s this, as I was previously able to dial out to the UAE, but now I can’t. I don’t know what this system’s deal is, but not touching the trunk or international calling data and it randomly changes is beyond odd. It could be a possible thing with someone on staff touching data when I’m not here, but I can’t confirm or deny that.


(Honor's Haven It) #107

image

Maybe something in here could work?


(Honor's Haven It) #108

So attempting to dial out parts of the number of 011971, it ALWAYS cuts off at the 7, same with 8 [01198], but 01199,01196-01190 work without issue, so this feels like someone has black listed those digits in particular, which is odd. Any Ideas?


(Itzik) #109

With 108 posts here and we still don’t have a successful or failed call log placed via a softphone.

Can you please do that so we can figure out whats up?


(Honor's Haven It) #110

The Softphone doesn’t work. all I get is “connection timeout” and before that, I got “Wrong Password”. It’s never worked so I dropped using it since it was going nowhere and this appeared to be another such thing I wasn’t making progress on.

image


(Honor's Haven It) #111

image

Whenever I set the SIP server to 10.80.10.2 (The Elaxtix PBX server’s IP) No matter what I use for the username and password, it returns an ‘incorrect’ password. I’ve tried the secret password for my phones extension, to the login for the server itself, nothing works.


#112

your login needs to be the extension not ‘admin’


#113

First, get MicroSIP working correctly.
Account Name, SIP Server and Username are fine as you have them.
Set Domain to 10.80.10.2
Login should either be blank (recommended) or 3178 (match Username).
Password must match the value of Secret for 3178 in Elastix. Use a simple password consisting of no more than 12 letters and digits.

If it still doesn’t show online or you can’t call, please post details.

Once you get the softphone and international calling working, temporarily set your international outbound route to use only the first of the three trunks. Confirm that it works, then test with only the second, then the third. Once you know that all three are properly set up, put them back in the order desired. UAE is quite expensive on many providers, so you might check rates and put the least expensive trunk first. I did a test on the number you gave for Abu Dhabi McDonalds and got through ok, but note that there is no IVR and they close at 23:00 GST, which is 14:00 EST.

Next, you need to find out why the Cisco phones aren’t letting the complete number through. I looked at the dialplan.xml you posted and see no reason why 01197 would be blocked. I’m guessing that the phones are loading different files, or possibly the config mechanism is broken and they are using a dial plan set a long time ago. Do you see any activity in /var/log/messages when a phone is rebooted? If not, run tcpdump on the PBX and see if any TFTP requests are coming in. The screenshot you posted for the phone with MAC ending AA7E02 does show 10.80.10.2 (your PBX) for TFTP server, so it seems pretty likely that it tries to pull config from there.


(Greg Kujawa) #114

Yeah, without log/debug details it’s tough to see what’s going on. Ultimately these sorts of issues need to be assessed at each potential fail-point, one at a time at each component that hands the call off:

  1. Any dial plan defined on the desk phone.
  2. Any dial plan defined in the IP-PBX.
  3. Any dial plan defined in the Adtran that hands off the call (assuming via PRI) to the PSTN.
  4. Any potential dialing restrictions that the PSTN access provider might have in place.

Simplifying things by looking at one desk phone, one particular Adtran, that series of test International numbers you have been using, etc. will help. Get it working on one desk phone, out one specific Adtran, and confirming your PSTN access provider isn’t blocking anything. Once that works then mimic the configuration on other desk phones, other Adtrans, etc.


(Honor's Haven It) #115

image

The issue is still on going with the soft phone; it states incorrect password, regaurdless of whatever password I use.


(Honor's Haven It) #116

Looking through the log file of the phone booting back up from the PBX shows nothing other than the system stating it went offline, and then came back online. Nothing else about it pulling data from the server.


(Honor's Haven It) #117

So I removed the SIP Server settings, so it only has the 10.80.10.2 as the domain, and it doesn’t give me an incorrect password error, it just say “Idle” Attempting to dial out, gives me a green phone icon for a frame, then it goes grey again, and says this error. am I making any progress here?

image


(Greg Kujawa) #118

This thread is getting so long, I’ve lost track of some of your environmental specifics. I think that MicroSIP is a PJSIP softphone. Is your IP-PBX utilizing PJSIP or Chan SIP for your clients?


(Honor's Haven It) #119

I don’t know.


#120

With SIP Server blank, it does not attempt to register. You should still be able to make a call (Asterisk uses registration only for incoming), but in your case there was apparently an authentication error.

Possibly, one end or the other doesn’t handle the ! in your password properly. Please try removing it from both Elastix and MicroSIP. In Elastix, make sure that you Submit and Apply Config, then restart MicroSIP.