Trouble using Sangoma 6 to 7 upgrade tool

I’m working on upgrading to FreePBX 14 using the upgrade tool at https://wiki.freepbx.org/display/PPS/Upgrading+from+Distro+6

I’m getting error because my machine needs some updates

[[email protected] ~]# distro-upgrade
┏━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┓
┃ ┃
┃ Sangoma 6 to 7 Upgrade Tool ┃
┃ ┃
┃ Distro Upgrade - Version 1707-17.sng7 ┃
┃ Build Date: 2017-08-23 ┃
┃ ┃
┗━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┛

Checking prerequsites…
Checking bitsize of machine [ :heavy_check_mark: ] - x86_64
Checking available disk space [ :heavy_check_mark: ] - 745G Available
Checking for outdated system [ ✘ ]
This machine has pending yum updates. This machine must be up to date before
the upgrade tool is run. To resolve this issue please run ‘yum update’. The
output of ‘yum check-update’ is below.

Loaded plugins: fastestmirror, kmod
Cleaning repos: base extras pbx schmooze-commercial updates
18 metadata files removed
5 sqlite files removed
0 metadata files removed
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile

freepbx.noarch 13.0.192.16-1.shmz65.1.57 pbx

Running ‘yum update’ gives me another error:

[[email protected] ~]# yum update
Loaded plugins: fastestmirror, kmod
Setting up Update Process
Loading mirror speeds from cached hostfile
Resolving Dependencies
–> Running transaction check
—> Package freepbx.noarch 0:12.0.45-1.shmz65.1.19 will be updated
—> Package freepbx.noarch 0:13.0.192.16-1.shmz65.1.57 will be an update
–> Processing Dependency: php-soap for package: freepbx-13.0.192.16-1.shmz65.1.57.noarch
–> Processing Dependency: php-intl for package: freepbx-13.0.192.16-1.shmz65.1.57.noarch
–> Processing Dependency: mongodb-server for package: freepbx-13.0.192.16-1.shmz65.1.57.noarch
–> Running transaction check
—> Package mongodb-server.x86_64 0:2.4.14-4.el6 will be installed
–> Processing Dependency: libtcmalloc.so.4()(64bit) for package: mongodb-server-2.4.14-4.el6.x86_64
–> Processing Dependency: libsnappy.so.1()(64bit) for package: mongodb-server-2.4.14-4.el6.x86_64
–> Processing Dependency: libboost_thread-mt.so.5()(64bit) for package: mongodb-server-2.4.14-4.el6.x86_64
–> Processing Dependency: libboost_system-mt.so.5()(64bit) for package: mongodb-server-2.4.14-4.el6.x86_64
–> Processing Dependency: libboost_program_options-mt.so.5()(64bit) for package: mongodb-server-2.4.14-4.el6.x86_64
–> Processing Dependency: libboost_iostreams-mt.so.5()(64bit) for package: mongodb-server-2.4.14-4.el6.x86_64
–> Processing Dependency: libboost_filesystem-mt.so.5()(64bit) for package: mongodb-server-2.4.14-4.el6.x86_64
—> Package php-intl.x86_64 0:5.3.28-3.shmz65.4.125 will be installed
—> Package php-soap.x86_64 0:5.3.28-3.shmz65.4.125 will be installed
–> Running transaction check
—> Package boost-filesystem.x86_64 0:1.41.0-25.el6.centos will be installed
—> Package boost-iostreams.x86_64 0:1.41.0-25.el6.centos will be installed
—> Package boost-program-options.x86_64 0:1.41.0-25.el6.centos will be installed
—> Package boost-system.x86_64 0:1.41.0-25.el6.centos will be installed
—> Package boost-thread.x86_64 0:1.41.0-25.el6.centos will be installed
—> Package gperftools-libs.x86_64 0:2.0-11.el6.3 will be installed
–> Processing Dependency: libunwind.so.8()(64bit) for package: gperftools-libs-2.0-11.el6.3.x86_64
—> Package snappy.x86_64 0:1.1.0-1.el6 will be installed
–> Running transaction check
—> Package libunwind.x86_64 0:1.1-2.el6 will be installed
–> Processing Conflict: mongodb-org-3.4.4-1.el6.x86_64 conflicts mongodb-server
–> Processing Conflict: mongodb-org-mongos-3.4.4-1.el6.x86_64 conflicts mongodb-server
–> Processing Conflict: mongodb-org-server-3.4.4-1.el6.x86_64 conflicts mongodb-server
–> Processing Conflict: mongodb-org-shell-3.4.4-1.el6.x86_64 conflicts mongodb-server
–> Processing Conflict: mongodb-org-tools-3.4.4-1.el6.x86_64 conflicts mongodb-server
–> Finished Dependency Resolution
Error: mongodb-org-tools conflicts with mongodb-server-2.4.14-4.el6.x86_64
Error: mongodb-org-mongos conflicts with mongodb-server-2.4.14-4.el6.x86_64
Error: mongodb-org-server conflicts with mongodb-server-2.4.14-4.el6.x86_64
Error: mongodb-org conflicts with mongodb-server-2.4.14-4.el6.x86_64
Error: mongodb-org-shell conflicts with mongodb-server-2.4.14-4.el6.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I ran 'yum update --skip-broken and got most updates done, but can’t seem to get this last error fixed. Any ideas how to resolve this?

Hi!

What dependencies are there on the mongodb-org* packages?

Only themselves or other packages?

You must end up with mongodb-server so if removing the mongodb-org* packages doesn’t remove critical packages I would remove them

ie

yum remove mongodb-org*

and then issue a

yum install mongodb-server

Good luck and have a nice day!

Nick

Thanks! That appeared to correct it. I have the 6 to 7 upgrade going!

Hi!

I take it it didn’t want to remove other packages when you tried it (or at least something important like some packages want to when you want to remove them).

Please keep us posted!

If it does seem to work, please check to see if CDR/CEL is working, this is one of them problem you could have and when the rest is working is one of the last to be noticed…

Good luck and have a nice day!

Nick

Mongo org comes from a third party repository which should have been removed before continuing.

Hi Andrew!

You meant the package or the repo? It sounds like you meant the repo and I didn’t think removing a repo removed the packages that came from it (and that package was already installed).

Just to be sure as to what you are saying there, was that third party repo added by @Bradbpw or did it used to be there for the FreePBX 13 distro?

Would it be possible for the distro upgrade “script” to detect when someone had added repos, tell them to preferably remove them and tell them which package should preferably be removed because they came from it?

Obviously this problem is not caused by the distro upgrade “script”, it would have been present even before trying to run it but when it’s the distro upgrade “script” which recommends doing a yum update could it possibly check for things like that?

I know the scripts remove the old distro repos and replaces them with Sangoma 7 ones but what does it do when there are other repos which were not distributed with the distro?

I know @nsumner had problems with mongodb back when I upgraded my home server…

re:

but that was during actual upgrade and not during an update and that problem was more than likely fixed by later scripts (it was the first one publicly made available…).

I hope @Bradbpw will have good news for us tomorrow…

Have a nice day!

Nick

Unfortunately, I don’t have great news. I got past the Mongo packages obstacle, but now I’m having the same issue as tim007 had in this post


I had to leave it for the night and plan to pick it back up again tomorrow. @Marbled, I see you were helping Tim007 with this problem. Based on the thread, it doesn’t look like a solution was found. Do you know of a fix to this to keep the update moving?

Hi!

In his case it sounds like it was a DNS problem for his network connectivity problem.

re: Upgrade to v14 error > Network

This is the problem you have currently?

For others the network connectivity problem seemed to be related to the use of a VM or some DAHDI cards (like the Sangoma A200).

Are you using either?

We recently identified a problem with that (which might very well be present during upgrade) so if you tell me you have one there are a few things I would like you to do…

But first, please tell me if you are using a VM or a DAHDI card…

Good luck and have a nice day!

Nick

To the best of my knowledge (I’m a novice) I am not using a DAHDI or VM (virtual machine). My PBX is basically an old desktop computer with that I turned into a PBX. My internet connection is direct into my motherboard.

I attempted to look at my resolv.conf file to check DNS entries like tim007 did, but I can’t get a command line. I’m stuck at this screen below. I’ve tried ctrl+c and several other potential keys to get a command line. I even ran my hands over the keyboard in frustration, but can’t get a command line. Is there a trick to get a command line?

Hi!

Try ALT-F2…

That should give you another terminal…

Good luck and have a nice day!

Nick

PS: Sorrrrrry for the delayed reply, quite a few things going on here…

Hi!

Can you do

ifconfig

and post the results here?

Is the interface up?

If it is not, please issue a

ifup eth0

(or whatever your Ethernet interface registers as…)

And post the results here?

Good luck and have a nice day!

Nick

No worries on the slow reply. I am just grateful that you are helping me so much!

Here is my output on the two commands.

If it matters, here’s the contents of my resolv.conf file. The fourth entry is the internal address of my router.

Yikes…

You have no network interface at all!!!

Can you issue a

lspci

?

Can you give more information on that PC so that we can figure out what kind of network card is supposed to be there?

Good luck and have a nice day!

Nick

Here is my output.

The computer is just an old desktop that we stuck in a server chassis. We plug right into the motherboard. I’ve been using it as our primary PBX with FreePBX for 4+ years.

OK…

Your network card is a NVIDIA CORPORATION MCP73 (rev a2).

It is handled by the forcedeth driver which has been disabled in Centos kernels…

re: https://lists.centos.org/pipermail/centos/2014-July/144190.html and quite a few others…

Since Sangoma 7 is a Centos derivative it is most likely disabled there as well…

There is a chance that adding kmod-forcedeth from the http://elrepo.org repos might work but if you have a spare supported network card you could put in that system it would be a lot simpler and far less prone to causing more problems in the future…

Since you have no network connectivity it will also be a pain to get the driver there…

Is there any chance of adding a discrete network card?

Good luck and have a nice day!

Nick

Pardon my ignorance on this, but if I just bought a new networking card like this is that my best bet? Would it likely be plug-and-play?

Hi!

I cannot say it with absolute certainty but I think that if you disable the onboard one in the BIOS it might…

As for the card, I am not particularly fan of Realtek (they are the ones who make the main chip on that network card) but you should be OK with it…

This card is PCI by the way so I guess your motherboard has no PCIe slots or at least no empty PCIe slots.

Good luck and have a nice day!

Nick

Thanks, Nick. I do have a PCIe slot open. I’m going to order this other card and try it out.

I am unable to identify the chipset from the pictures but some people are complaining about lack of compatibility with quite a few OSes, including some version of Windows (which is surprising)…

Good luck and have a nice day!

Nick