Transfer to VM REST-API does not accept direct extension entry


(Alex Fassas) #1

We are finishing our setup and testing before taking our FreePBX and Sangoma S505 & S705 phone PBX live. This is our first FreePBX installation. Currently the FreePBX is processing and handling all of our calls inbound and outbound, but handing the calls to our legacy analog PBX via FXS gateway extensions. We are finishing configuration to replace the legacy PBX and it’s keysets with Sangoma S505 and S705 phones, when we ran into our issue.

The Issue:
We cannot get the “Transfer to VM” phone app to work as advertised on our Sangoma phones. When we press the phone button marked “Transfer to VM”, with a live call on the device extension, we are presented with the “Dial Extension” prompt. The phone will not accept or show any digits keyed in. There is a softkey labeled “Change”. We have to press “Change” and then enter the extension number. Then several more button presses, (from memory) “Done”, then “Select”. Then the Transfer to VM occurs.

The above description is not what is shown in the Wiki for the Transfer to VM phone app. And those steps are certainly not user friendly. We have only tried this phone app at the current system software revision levels shown below.

Our installation is:
FreePBX distro firmware: 12.7.5-1902-3.sng7
Service pack: 1.0.0.0
Installed on a VMWare esxi 5.1 virtual machine.
FreePBX 14.0.5.25 on Asterisk 13.22.0
All “yum update” current as of February 16, 2019
All Module Updates current on Stable track as of February 16, 2019
using Endpoint Manager 14.0.2.188
using Phone Apps 13.0.92.30
Sangoma firmware pkg 1.51, S505 & S705 3.0.4.57

Thank you to the community in advance for your help,
Alex


How is the Transfer to VM Phone App supposed to work? conflicting information so far
(Dave Burgess) #2

Since all of the parts are Sangoma, have you tried submitting a ticket to see what settings could be messing with your call flow?


(Alex Fassas) #3

Dave,
My troubleshooting flow usually goes along this path:

  1. Search Wiki for answers.
  2. Search Community Forum and other search platforms for answers.
  3. Ask Community Forum for answers.
  4. Submit ticket.

Up until now, I have never had to go past step #3. I will give the community the balance of Monday to chime in. If no help, then I will submit a ticket.

Thanks for the reply,
Alex


(Lorne Gaetz) #4

Please submit a ticket, I am seeing similar on my own phone, but unable to chase further right now:
https://support.sangoma.com


(Alex Fassas) #5

I have submitted a support ticket on this issue. Ticket ID #875451.

Thank you to the community and also to Dave and Lorne.
Alex


(Dave Burgess) #6

We appreciate your self-help ethic. The only thing is that, with the fact that all of your pieces are proprietary Sangoma, even if we (as the user community) did have an answer, this particular issue should be tracked in the Bug Tracker as well. Like I said, it’s not that we can’t or won’t help - you have paid for support from Sangoma on this issue and it’s important that, if there’s a problem with their product that the people that can fix it get the info they need.


(Brian Ladd) #7

Did you ever get a resolution on this? I am still seeing the behavior on S505’s with latest firmware in August 2019.


(Alex Fassas) #8

No, my issue ticket was put in and no real priority to get this corrected. The deficiency was acknowledged though. Many others have come up with various workarounds to get an easy “Transfer to VM”.

I came up with a workaround that is easy. We are using Sangoma phones, and the Endpoint Manager.

We are using the short & long BLF press. In a rather small office, we will setup each extension as a BLF on the phone. A short press will do a transfer (either blind or attended, depending on your other FreePBX settings), a long press will do a Transfer to VM (*+ext).

To set the long press behavior do the following: From FreePBX navigate to Settings -> Endpoint Manager -> Brands, Sangoma -> Options Tab. In the Options look for “BLF Long Press Idle State” (this is the state of the associated BLF extension). Put an “*” in this field. Click Apply. Be sure to then Save & Rebuild Configurations in Extension Mapping. Send Config to extension or allow it to pick it up on its own.

I hope that this helps. If you are still looking for a solution not using a BLF key, then there are several forum threads that suggest programming a phone key as a DTMF key, with the appropriate Transfer to VM activation with a “+” following, etc.

I also discussed both solutions, gathered from others in this thread:

In regards to wiki references for the BLF button programming, look here:
https://wiki.freepbx.org/display/PHON/BLF+Key+Presses

Good luck!


(Lorne Gaetz) #9

When you press the Transfer to VM button, the first thing you must do is press the ‘change’ button at the bottom. This will allow you to enter a full extension number or a partial number to get a list of matches to choose from.

I need to update the wiki to reflect this.


(Brian Ladd) #10

I am using the same workaround-- it’s just weird that they’d provide a feature that essentially doesn’t work. I would never show a non-techie end user that app.


(Aaron) #11

I just change my direct VM prefix from * to 0, and then tell people if you want to XFER to VM, just put the 0 in front of the extension. Easy enough. With phones like yealink you can also set a VMXFER prefix BLF button. So they hit XFerVM which prefixes a 0 then enter the extension, or press the blf key.

I use 0 instead of * because * interfers with too many other possible feature codes.


(Brian Ladd) #12

Long/short BLF presses on the Sangoma works fine. Again, I think the greater point of this thread is that a Phone App they preload in the Sangoma template doesn’t really work.


(Lorne Gaetz) #13

Did not see my post above, it does work. Furthermore, if you believe it doesn’t, then posting here will not get it fixed for you, you would open a support ticket.


(system) closed #14

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.