FreePBX | Register | Issues | Wiki | Portal | Support

System Updates tags 255 RPMs available for upgrade...but fails


(Matthew B) #1

System with Admin Module Pro reports: 255 RPMs available for upgrade

However, when I use the System Updates feature, it reports this information back and does not update.

Tried: yum clean metadata but that didn’t help.

Suggestions?

–> Finished Dependency Resolution
Error: Package: sangoma-pbx-1904-1.sng7.noarch (sng-pkgs)
Requires: kmod-via-rhine
Removing: kmod-via-rhine-1.5.2-1.sng7.x86_64 (@anaconda/1707)
kmod-via-rhine = 1.5.2-1.sng7
Available: kmod-via-rhine-1.5.1-4.sng7.x86_64 (sng-pkgs)
kmod-via-rhine = 1.5.1-4.sng7
Available: kmod-via-rhine-1.5.1-5.sng7.x86_64 (sng-pkgs)
kmod-via-rhine = 1.5.1-5.sng7
Available: kmod-via-rhine-1.5.1-6.sng7.x86_64 (sng-pkgs)
kmod-via-rhine = 1.5.1-6.sng7
Error: Package: sangoma-pbx-1904-1.sng7.noarch (sng-pkgs)
Requires: kmod-via-velocity
Removing: kmod-via-velocity-1.16-1.sng7.x86_64 (@anaconda/1707)
kmod-via-velocity = 1.16-1.sng7
Available: kmod-via-velocity-1.15-2.sng7.x86_64 (sng-pkgs)
kmod-via-velocity = 1.15-2.sng7
Available: kmod-via-velocity-1.15-3.sng7.x86_64 (sng-pkgs)
kmod-via-velocity = 1.15-3.sng7
Available: kmod-via-velocity-1.15-4.sng7.x86_64 (sng-pkgs)
kmod-via-velocity = 1.15-4.sng7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
You can now close this window


(Corey W) #2

You might be the lucky one. My system ran the 250-ish upgrades just fine, rebooted, and now it’s not activated. The portal also isn’t letting me deactivate the deployment, so I’m stuck without Admin Pro and EPM until that gets resolved. I opened a support ticket, but suspect I may be stuck undoing all the upgrades - yuck. That’ll teach me to try to stay up to date!


(Andrew Nagy) #3

Undoing system upgrades could cause an unstable system and wouldn’t resolve your issue at all. Be advised.


(Andrew Nagy) #4

If you do a search you’ll see this was answered before.


(Matthew B) #5

No, this was not answered before. But thank you for thinking it was.

Here was my solution that worked:

yum downgrade kmod-via-rhine
yum downgrade kmod-via-velocity
yum clean all
yum upgrade -y
yum reinstall kernel

I hope this helps!

Thanks.


(Andrew Nagy) #6

What you posted is what I posted in several other threads here’s one of them

Here’s another


(Matthew B) #7

1st one “Operating System Updates” did not work additionally there was no mention of downgrading kmod.
2nd one, “Repo Issues” I missed because I was using query “System Updates” to find other posts.

Through much trial and error after your 1st response, I figured it out after about 30 minutes.

Thanks for your guidance and so sorry for my searching skills not finding the other post. It sure would of helped.


(Rudi Salm) #8

Hello fellow sufferers :slight_smile: ,

this did the trick for me:

rpm --nodeps -e kmod-via-velocity-1.16-1.sng7.x86_64

Close your eyes and ENTER.

After that try

yum -y update

The project should think about removing such horrible kmods such as kmod-via-velocity, kmod-forcedeth, kmod-cciss, kmod-via-rhine etc. This are all ancient chipsets and mostly in the museum.

For example: the freepbx needs about 15 Minutes to update kmod-forcedeth!

It makes no sense to ride a dead horse. :wink:

Kind regards
Rudi


(Dan Corwin) #9

I’ve run into similar issues but not 15+ mins. Fresh install and running yum -y update these kmods do take forever in comparison to finish. Something weird is going on with them.


(Tony Guadagno) #10

Correct me if I am wrong, but kmods require a kernel recompile…so it is not surprising that they take a while…right?


(Andrew Nagy) #11

You aren’t wrong. That is why they take forever. This is pretty normal.


(Dan Corwin) #12

Learning something new every day.


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.