Sound Languages list shows nothing

I’m having this exact same issue. I’ve tried reinstalling soundlang, fwconsole restart, etc. and still the sound languages page is not showing any languages. I confirmed there are .wav files in /var/lib/asterisk/sounds.

This is fresh FreePBX 14 distro install on a fresh VPS.

Any help in resolving this is appreciated.

Thanks!

Either your mirror url is wrong or you aren’t allowed to connect to our mirror servers.

I’m a little confused - I have all the audio files on my server - where does the mirror server url being wrong (I haven’t changed anything from the default FreePBX distro install) and/or not being allowed to connect to the mirror servers come into play?

Thanks for any insight you can offer!

Sound lanaguges doesn’t detect your files that you placed. It only shows what’s been downloaded.

The title of the original thread is sound languages won’t install. Meaning. From the mirror server. Look at the first post.

OK, so if I go to Admin -> Sound Recordings, I get the following:

" You have no sound packages installed in the Sound Languages module. Please install at least one language to use System Recordings"

So I then go to Admin -> Sound Languages and there is nowhere to “install” a language. It doesn’t list any available languages to install. I’ve gone through all three sub-menus - Language Packs, Custom Languages, and Settings, and there’s nowhere to “install” a language so I can use System Recordings.

What am I missing?

Thanks!

You are not able to access the mirror server. As I said previously. It is on your end.

What are the current mirror servers? mirror1.freepbx.org appears to be outdated and mirror2 is unreachable from multiple locations.

Thanks!

How does mirror1 appear to be outdated?

It appears outdated, because the files have old time stamps.

Anyway, I can reach the mirror server just fine:

[[email protected] ~]# wget http://mirror.freepbx.org/modules-2.4.xml 
--2019-01-16 17:25:09--  http://mirror.freepbx.org/modules-2.4.xml
Resolving mirror.freepbx.org (mirror.freepbx.org)... 199.102.239.8
Connecting to mirror.freepbx.org (mirror.freepbx.org)|199.102.239.8|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 72684 (71K) [text/xml]
Saving to: ‘modules-2.4.xml’

100%[===================================================================================>] 72,684      --.-K/s   in 0.05s   

2019-01-16 17:25:09 (1.48 MB/s) - ‘modules-2.4.xml’ saved [72684/72684]

[[email protected] ~]# wget http://mirror1.freepbx.org/modules-2.4.xml 
--2019-01-16 17:25:23--  http://mirror1.freepbx.org/modules-2.4.xml
Resolving mirror1.freepbx.org (mirror1.freepbx.org)... 199.102.239.170
Connecting to mirror1.freepbx.org (mirror1.freepbx.org)|199.102.239.170|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 72684 (71K) [text/xml]
Saving to: ‘modules-2.4.xml.1’

100%[===================================================================================>] 72,684      --.-K/s   in 0.04s   

2019-01-16 17:25:23 (1.56 MB/s) - ‘modules-2.4.xml.1’ saved [72684/72684]

Not sure how it can be on “my end” if it’s a fresh install of the FreePBX distro and I can reach the mirror server and download from it. If you could point me to where I should be looking for problems on “my end”, I would appreciate it.

Thank you.

So a little more investigation. It appears my server is hitting 199.102.239.170 when I go to the Sound Languages page:

21:48:28.307278 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [S], seq 1425142950, win 29200, options [mss 1460,sackOK,TS val 57426999 ecr 0,nop,wscale 7], length 0
21:48:28.329414 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [S.], seq 3449157361, ack 1425142951, win 28960, options [mss 1380,sackOK,TS val 3164328841 ecr 57426999,nop,wscale 7], length 0
21:48:28.329484 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], ack 1, win 229, options [nop,nop,TS val 57427021 ecr 3164328841], length 0
21:48:28.329665 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [P.], seq 1:169, ack 1, win 229, options [nop,nop,TS val 57427022 ecr 3164328841], length 168: HTTP: POST /sounds-14.0.xml HTTP/1.1
21:48:28.351768 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [.], ack 169, win 235, options [nop,nop,TS val 3164328864 ecr 57427022], length 0
21:48:28.354078 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [P.], seq 1:26, ack 169, win 235, options [nop,nop,TS val 3164328866 ecr 57427022], length 25: HTTP: HTTP/1.1 100 Continue
21:48:28.354100 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], ack 26, win 229, options [nop,nop,TS val 57427046 ecr 3164328866], length 0
21:48:28.354372 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], seq 169:2905, ack 26, win 229, options [nop,nop,TS val 57427046 ecr 3164328866], length 2736: HTTP
21:48:28.354388 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], seq 2905:5641, ack 26, win 229, options [nop,nop,TS val 57427046 ecr 3164328866], length 2736: HTTP
21:48:28.354393 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], seq 5641:8377, ack 26, win 229, options [nop,nop,TS val 57427046 ecr 3164328866], length 2736: HTTP
21:48:28.354398 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], seq 8377:11113, ack 26, win 229, options [nop,nop,TS val 57427046 ecr 3164328866], length 2736: HTTP
21:48:28.354403 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], seq 11113:13849, ack 26, win 229, options [nop,nop,TS val 57427046 ecr 3164328866], length 2736: HTTP
21:48:28.377801 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [.], ack 2905, win 280, options [nop,nop,TS val 3164328889 ecr 57427046], length 0
21:48:28.377847 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], seq 13849:16585, ack 26, win 229, options [nop,nop,TS val 57427070 ecr 3164328889], length 2736: HTTP
21:48:28.377866 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [P.], seq 16585:18799, ack 26, win 229, options [nop,nop,TS val 57427070 ecr 3164328889], length 2214: HTTP
21:48:28.377870 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [.], ack 5641, win 326, options [nop,nop,TS val 3164328889 ecr 57427046], length 0
21:48:28.377877 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [.], ack 8377, win 371, options [nop,nop,TS val 3164328889 ecr 57427046], length 0
21:48:28.377881 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [.], ack 11113, win 416, options [nop,nop,TS val 3164328889 ecr 57427046], length 0
21:48:28.377885 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [.], ack 13849, win 461, options [nop,nop,TS val 3164328889 ecr 57427046], length 0
21:48:28.400031 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [.], ack 16585, win 507, options [nop,nop,TS val 3164328912 ecr 57427070], length 0
21:48:28.400056 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [.], ack 18799, win 551, options [nop,nop,TS val 3164328912 ecr 57427070], length 0
21:48:28.531216 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [P.], seq 26:229, ack 18799, win 551, options [nop,nop,TS val 3164329043 ecr 57427070], length 203: HTTP: HTTP/1.1 200 OK
21:48:28.531583 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [F.], seq 18799, ack 229, win 237, options [nop,nop,TS val 57427224 ecr 3164329043], length 0
21:48:28.553680 IP 199.102.239.170.http > bell.k2ram.com.com-bardac-dw: Flags [F.], seq 229, ack 18800, win 551, options [nop,nop,TS val 3164329066 ecr 57427224], length 0
21:48:28.553733 IP bell.k2ram.com.com-bardac-dw > 199.102.239.170.http: Flags [.], ack 230, win 237, options [nop,nop,TS val 57427246 ecr 3164329066], length 0

I confirmed I can download a file from there with curl:

# curl -v http://199.102.239.170/modules/branches/2.11/test
* About to connect() to 199.102.239.170 port 80 (#0)
*   Trying 199.102.239.170...
* Connected to 199.102.239.170 (199.102.239.170) port 80 (#0)
> GET /modules/branches/2.11/test HTTP/1.1
> User-Agent: curl/7.29.0
> Host: 199.102.239.170
> Accept: */*
> 
< HTTP/1.1 200 OK
< Date: Wed, 16 Jan 2019 21:51:08 GMT
< Server: Apache/2.4.6 (Sangoma) PHP/5.6.36
< Last-Modified: Sat, 07 Sep 2013 21:16:20 GMT
< ETag: "0-4e5d1aa9a3100"
< Accept-Ranges: bytes
< Content-Length: 0
< Content-Type: text/plain; charset=UTF-8
< 
* Connection #0 to host 199.102.239.170 left intact

So it appears I can reach the mirror server, but something else is going wrong.

Sure because you are downloading the xml file for FreePBX 2.4 and FreePBX 2.4 was released over 10 years ago. Do you know what you are doing? Why did you randomly decide to download modules-2.4.xml

Again you are just making up directories. Where are you finding these?

I have reviewed the code and everything is working.

Stop searching google and finding old urls and telling us that version 2.4 is “outdated”. Of course it is.

Here is what a working system looks like, which uses the same mirror urls that you are having problems with:

Instead of searching Google to find xml files from 10 years ago and telling us that the files are outdated. Try running

fwconsole sounds --list

It should return a list of Languages for you.

I in fact do know what I am doing - thanks for trying to insult me. I’ve been running a FreePBX server since 2010 and have been using Unix based systems since 1985, starting with System III and BSD 2.9. Further, I was a full time system admin for over 20 years, and an IP engineer for a global IP transit provider for 10 years. So, I know a thing or two about *nix based systems and IP networking.

Because going to http://mirror1.freebsd.org doesn’t return a directory listing or anything useful - just a blank page. So I had to find a url that contained a small file for testing.

Again, because going to http://mirror1.freebsd.org doesn’t return a directory listing or anything useful - just a blank page. So I had to find a url that contained a small file for testing.

Well, I’m telling you it isn’t working on my particular distro install.

It would be helpful if you were not being so obtuse. I understand that this “support” is free and I’m getting exactly what I’m paying for. But, I had hoped someone, in the spirit of open source, would provide some useful tips for troubleshooting this problem, rather than snipe from the sidelines and imply people are stupid.

Well, that is not what my freshly installed distro system looks like. There is no listing of languages.

Thank you for an potentially helpful suggestion! Here is what my system (FreePBX 14.0.5.25) returns:

[[email protected] ~]# fwconsole sounds --list
                                       
  The "--list" option does not exist.  
                                       
sounds [<args>]...

I’m assuming that you actually wanted me to try this:

[[email protected] ~]# fwconsole sounds list
                                      
  The helper "table" is not defined.  
                                      
sounds [<args>]...

So eliminating any perceived insults or your." inconveniently unanswered requests for information ", what version of FreePBX on what OS are you actually using?

As I posted earlier - FreePBX 14.0.5.25 distribution. I appears to be based on CentOS 6. It was installed from the distribution ISO.

I don’t think your using our distrbution. We only use CentOS 7 fork with FreePBX 14. You sure you are using our Distro and not something else.

Then the remaining question would be (and this is not pertinent to how clever or experienced you are)

"how exactly did you install your system? And “what have you personalised ?”

I misspoke earlier. I installed from the FreePBX 14.0.1.1 64-bit ISO. Here’s /etc/os-release:

[[email protected] ~]# cat /etc/os-release .
NAME="Sangoma Linux"
VERSION="7 (Core)"
ID="sangoma"
ID_LIKE="centos rhel fedora"
VERSION_ID="7"
PRETTY_NAME="Sangoma Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:sangoma:sng:7::server:utf8"
HOME_URL="https://distro.sangoma.net/"
BUG_REPORT_URL="https://issues.sangoma.net/"

CENTOS_MANTISBT_PROJECT="Sangoma-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="sangoma"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

I booted from the ISO and followed the instructions. I have not done any personalization - no extensions, trunks, routes, etc. I only updated the system and the modules to the current version. I did remove the commercial modules that I have not purchased, but the result was the same before and after. I even re-installed the system again. Same result.

Thanks!

I read that you had tried from multiple addresses, but perhaps from a newer IP block, as the solution to my original post explains? They had to allow my new IP block on their server side before it started working.

Thank you, that’s why I responded to this thread instead of starting a new one.