Sound Languages Won't Install

Hello,

On FreePBX 13.0.190.11 with Asterisk 13.13.1

A month or so back, I essentially “transferred” everything from an older server to this one, by using the instructions here for Warm Spare Setup http://wiki.freepbx.org/display/FPG/Warm+Spare+Setup . For the record, both servers were at the same versions when I did the transfer.

Everything on the “new” server works great, but I can’t add any new system recording. This is because Under Admin->Sound Languages->Settings, there is no Global Language defined (and nothing to select in the drop down).

Well on the main Sound Languages page, if I try to download/install “English (en)” for example, the License Agreement pops up, and just says “Loading…” . If I go ahead and click Accept License Agreement I get a red ! pop up in the top right of FreePBX, and it doesn’t install.

This is an issue because we badly need to make some new system recordings for announcements and whatnot.

open up the developer console
F12, Ctrl + Shift + I OR Cmd + Opt + I

Look for things in red… maybe a 500 error

This is what the red pop up says in FreePBX when I click “Accept License Agreement”

Exception
Error 0 returned from remote servers [“http://mirror1.freepbx.org”,“http://mirror2.freepbx.org”], Error 0 returned from remote servers [“http://mirror1.freepbx.org”,“http://mirror2.freepbx.org”]
File:/var/www/html/admin/modules/soundlang/Soundlang.class.php:1227

Also, I just tried:
fwconsole ma uninstall soundlang --force
followed by:
fwconsole ma install soundlang

and I got this in the cli:

[[email protected] ~]# fwconsole ma install soundlang
New install, downloading default english language set…
Installing core-sounds-g722…

[Exception]
Error 0 returned from remote servers [“http://mirror1.freepbx.org”,“http://mirror2.freepbx.org”], Error 0 returned from remote servers [“http://mirror1.freepbx.org”,“http://mirror2.freepbx.org”]

So the above fwconsole command worked when I disabled the FreePBX firewall, but still the same issue where I can’t install the “en” language, and therefore cannot manage system recordings.

Though, clearly the en language is there, as all the normal asterisk recordings play on our system.

Related… http://issues.freepbx.org/browse/FREEPBX-14401

Thanks. Will post there.

Well you probably shouldn’t because its not reproducible at this time. My best advice for you is to actually try to hit the server so we can get some logs.

I am waiting for someone to hit the sounds server that has this error. Until that time this issue will remain unresolved.

Can you explain the procedure so I can get you the logs?

There are no logs for you to get me. Please try to download languages.

Gotcha, meaning, you’re not seeing us hit it. Very strange, as this box is directly facing the net with nothing in between. Is there a way to “fully” disable the FreePBX firewall? As maybe it is causing this?

Steven,

I never said that. Please download languages right now. I am about to log off of this server. I haven been tailing the error_log waiting for you to hit it.

Okay, just did just now. Got this in the GUI:

Exception
Error 0 returned from remote servers [“http://mirror1.freepbx.org”,“http://mirror2.freepbx.org”], Error 0 returned from remote servers [“http://mirror1.freepbx.org”,“http://mirror2.freepbx.org”]
File:/var/www/html/admin/modules/soundlang/Soundlang.class.php:1227

Is this your IP? 200.174.219.xx

If not please let me know what your IP is (through PM)

Uh oh…Resolved.

So over the past hour or so, I upgraded from 10.13.66-17 to 10.13.66-19 as explained here: http://wiki.freepbx.org/display/PPS/FreePBX-Distro-10.13.66

I figured that would update anything buggy, as well as reset everything. I then rebooted.

Still the same issue.

Just tried: fwconsole restart

Was able to install en language after.

Please try again

None of my servers want to open that page now (System Languages).

EDIT: Okay…was very very very slow to. now.

And yes, I can now dl languages.

Was it the fwconsole restart or something else on the server side?

A modification we had to make server side. Your IP address is “new” in the last year.

Ya, fresh /24 from ARIN. Thanks.