[Resolved] AsteriskNow 1.7 and CDR/Reports ... you must install addons

On the standard 1.7 ISO is it expected that CDR and MySQL will automatically install?
To the point that you can use Freepbx/Reports and see the Call Detail?
So far I’m not able to get it to report Call details.

I see enough noise that makes me wonder if I have to install add-ons etc.

What I’ve done:
Fresh standard AsteriskNow 1.7 ISO install … then one SIP extension, one SIP trunk, one incoming route and outbound route define. Able to make calls inbound and outbound. Go to Report and hit search and it says “No data found” the summary page says CDR install and mysql is running.

Plz can any 1 show step by step to solve this problem…

When attempting:
yum install asterisk-addons-mysql
or
yum install asterisk-addons
this error message comes up.
Error: asterisk14-core conflicts with asterisk16-core
Any thoughts?

What is the output of:
grep session.save_path /etc/php.ini

In my case it is:
session.save_path = “/var/lib/php/session”

What are the rights of this directory (/var/lib/php/session)?
Change (chown) it to asterisk (user/group).

freepbx/reports or Call Monitor show no call

Did as you suggest … same output … /var/lib/php/session
was set to root … changed to asterisk/asterisk

drwxrwxrwx 3 asterisk asterisk 4096 Jul 16 07:02 php
drwxrwxrwx 2 asterisk asterisk 4096 Jul 20 04:42 session

No change … freepbx/reports or Call Monitor show no call details

eMbeejay, you’re not alone. I have the same issue and have gone through every tip/trick to get it running that I found in these forums. I’m running AsteriskNow 1.7 out of the “cd” and the call reports do not work.

When I ran trixbox ce, the call reports worked, but it didn’t like my T1 span card.

Change (chown -R asterisk.asterisk) the contents of session.

See below … still no change

-rwxrwxrwx 1 asterisk asterisk 2297 Jul 16 12:52 sess_0i6mt6900fsetbka162u5k3sh0
-rwxrwxrwx 1 asterisk asterisk 563 Jul 18 11:19 sess_5gp13r397v3uj30bn8eklgq9r6
-rwxrwxrwx 1 asterisk asterisk 520 Jul 16 13:57 sess_6qt7iq1nkerrijdmjom0k9vph3
-rw------- 1 asterisk asterisk 2162 Jul 20 05:01 sess_afbigtbq11g2k1877uh2jfi4m5
-rwxrwxrwx 1 asterisk asterisk 2162 Jul 19 13:44 sess_dpc13ejc4994657m8s4qt74cn2
-rwxrwxrwx 1 asterisk asterisk 507 Jul 19 14:08 sess_gohe6q530agc48okpitrc04t03
-rwxrwxrwx 1 asterisk asterisk 502 Jul 20 05:40 sess_jt55ngs8a8jl1kttd7j4h2dod4
-rwxrwxrwx 1 asterisk asterisk 1610 Jul 18 11:18 sess_ke9nva13dik76u73m69e4ngc46
-rwxrwxrwx 1 asterisk asterisk 2162 Jul 18 10:29 sess_kv3ss56mn6so6sijuavheqdr86
-rwxrwxrwx 1 asterisk asterisk 581 Jul 18 10:28 sess_r1g6hp330v4hqr7lf05k6djqd0
-rwxrwxrwx 1 asterisk asterisk 379 Jul 16 14:02 sess_reofqt8efm221crram70hactk7
-rwxrwxrwx 1 asterisk asterisk 507 Jul 19 13:46 sess_s9j2ptgj34ltajs1nptg8tcvg0
-rwxrwxrwx 1 asterisk asterisk 563 Jul 18 16:02 sess_u1j9s45a5hjsn45fnduftu9n04

I believe my CDR DB is empty …

mysql> DESCRIBE cdr;
±------------±-------------±-----±----±--------------------±------+
| Field | Type | Null | Key | Default | Extra |
±------------±-------------±-----±----±--------------------±------+
| calldate | datetime | NO | | 0000-00-00 00:00:00 | |
| clid | varchar(80) | NO | | | |
| src | varchar(80) | NO | | | |
| dst | varchar(80) | NO | | | |
| dcontext | varchar(80) | NO | | | |
| channel | varchar(80) | NO | | | |
| dstchannel | varchar(80) | NO | | | |
| lastapp | varchar(80) | NO | | | |
| lastdata | varchar(80) | NO | | | |
| duration | int(11) | NO | | 0 | |
| billsec | int(11) | NO | | 0 | |
| disposition | varchar(45) | NO | | | |
| amaflags | int(11) | NO | | 0 | |
| accountcode | varchar(20) | NO | | | |
| uniqueid | varchar(32) | NO | | | |
| userfield | varchar(255) | NO | | | |
±------------±-------------±-----±----±--------------------±------+
16 rows in set (0.00 sec)
mysql> select * from cdr;
Empty set (0.00 sec)

This is likely because

*CLI> module show like sql
Module Description Use Count
0 modules loaded

Therefore I understand that cdr_addon_mysql.so, res_config_mysql.so and app_addon_sql_mysql.so. are NOT there

a) how does this happen off of the standard ISO

b) more importantly how to fix??

Do a “yum install asterisk16-addons”

yep that is what I going to say. And if that doesn’t work since yum kept complaining to me, just download the asterisk and asterisk-addons from http://www.asterisk.org/downloads.

Unpack each.
run ./configure to make sure you have all the dependencies
make clean
make
make install

After I did that, the CDR worked!

Can you please post “idiot proof” instructions on the fix.
I have issues with yum. I managed to download the addons file
but I have no clue where it should sit and how the linux commands
work.

I installed from the 1.7 ISO and I have two issues one is the CDR/Call recording stuff and the other is a name resolving problem. My trunks are all configured using the ITSP’s IP addresses instead of the usual format.

I look forward to hearing from you.

Regards

John

I tried again to do the yum install for the addons.

Every time YUM failed I noted the host addresses for each of the update sources that yum was unable to reach and pinged them for their respective IP addresses.

I then placed this detail in the hosts file. Once I has got past all errors and put all relevant IP addresses in the hosts file, yum was able to complete the update procedure.

I did the same for a straight “yum update” and rebooted.

CDR’s are now appearing and recorded calls are now seen in the call monitor in the voicemail GUI for the respective extension.

This procedure really was only a cheat and I need to get the name resolution issue fixed. If anyone has any ideas please let me know.

This is the way the system loaded from the AsteriskNOW 1.7 ISO I downloaded
from the Asterisk site.

Hi,

I have the same problem, can you do a mini tutorial with the steps you follow to solve this problem?

Thanks in advance

In Putty I ran yum install mysql-devel, yum install asterisk-addons-mysql and yum install asterisk-addons, this activated the CDR Mysql database. Do an amportal restart when you have completed the yum updates just to be sure everything is running normally.

When attempting:
yum install asterisk-addons-mysql
or
yum install asterisk-addons
this error message comes up.
Error: asterisk14-core conflicts with asterisk16-core
Any thoughts?

Do a “yum list asterisk*” and see what you have installed.

Then from the list it should be fairly obvious as to which addons to install.

Built from the same ISO, I had to [yum] install asterisk16-addons-mysql-1.6.2.1-1_centos5

The reason it’s not included in the ISO was due, if I recall correctly, to licensing.

[code][[email protected] ~]# yum -y install asterisk16-addons-mysql-1.6.2.1-1_centos5
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile

  • addons: mirror.team-cymru.org
  • base: mirror.sanctuaryhost.com
  • epel: mirrors.xmission.com
  • extras: styx.biochem.wfubmc.edu
  • updates: mirror.team-cymru.org
    Setting up Install Process
    Resolving Dependencies
    –> Running transaction check
    —> Package asterisk16-addons-mysql.x86_64 0:1.6.2.1-1_centos5 set to be updated
    –> Processing Dependency: asterisk16-addons-core = 1.6.2.1-1_centos5 for package: asterisk16-addons-mysql
    –> Running transaction check
    —> Package asterisk16-addons-core.x86_64 0:1.6.2.1-1_centos5 set to be updated
    –> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size

Installing:
asterisk16-addons-mysql x86_64 1.6.2.1-1_centos5 asterisk-current 47 k
Installing for dependencies:
asterisk16-addons-core x86_64 1.6.2.1-1_centos5 asterisk-current 32 k

Transaction Summary

Install 2 Package(s)
Upgrade 0 Package(s)

Total download size: 80 k
Downloading Packages:
(1/2): asterisk16-addons-core-1.6.2.1-1_centos5.x86_64.r | 32 kB 00:00
(2/2): asterisk16-addons-mysql-1.6.2.1-1_centos5.x86_64. | 47 kB 00:00

Total 85 kB/s | 80 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : asterisk16-addons-core 1/2
Installing : asterisk16-addons-mysql 2/2

Installed:
asterisk16-addons-mysql.x86_64 0:1.6.2.1-1_centos5

Dependency Installed:
asterisk16-addons-core.x86_64 0:1.6.2.1-1_centos5

Complete!
[[email protected] ~]#
[/code]

It should be just that easy.

it worked great…

Be sure to install exactly asterisk16-addons-mysql-1.6.2.1-1_centos5 on AsteriskNow 1.7.0. More recent versions (1.6.2.3) do NOT work.
If you have 1.6.2.1-1, no chmod or chowns to /var/lib/php/session directory are necessary to have CDR up and running.

Francesco

When I first did the install of the addons with yum, Asterisk failed to start. I found that it was necessary to modify the /etc/asterisk/res_mysql.conf. The configuarion file seems to be in the old format containing:

dbuser=asteriskuser
dbpass=amp109

Changing it to :

[asteriskuser]
dbpass=the-right-pwd

resolves the issue for me.

Just for reference this was for the AsteriskNow 1.7 CD, Asterisk 1.6 and FreePBX 2.8.

M