Repository and Problem Updating Self

Why am I getting this, see below?

“One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:”

“Cannot find a valid baseurl for repo: sng-base/7-8.2003.5.el7.sangoma/x86_64”

I could never under stand why sometime Linux system doesn’t know how or the path to update self…I installed version 16 with Asterisk 17.

After installing Freepbx 16 with Asterisk 17 and registering the license, it updated…after that the only change made was adding a Let’s Encrypted certificate…did that changed the OS significantly to cause a change in the repository that it cannot remember how to call home? Isn’t that finicky? So, it seems that installing any version of Asterisk other than 16 is guaranteed problems; if so, why give that option in the installer?

Looks as if it’s DNS issue.

This file shows the following nameserver yet I still cannot update, get timeout: etc/resolv.conf
# Configuration automatically generated via Sysadmin RPM
# MODIFICATIONS TO THIS FILE WILL BE OVERWRITTEN.
# Generated at: Sun, 27 Feb 2022 02:26:55 +0000
nameserver 127.0.0.1
nameserver 192.168.1.1
nameserver 208.67.220.220

This seems to suggest that the problem is else where (repositories).

Then saw this and followed: FreePBX Distro Fails to Yum Update - #9 by mbignotti
Here’s the results:
[[email protected] /]# wget -O - “http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=os&dist=%24dist 18”
[1] 21727
[2] 21728
[3] 21729
-bash: 18”: command not found
[2]- Done arch=x86_64
[3]+ Done repo=os
[[email protected] /]# “http://mirrorlist.sangoma.net/?release=7: Scheme missing.
^C
[1]+ Exit 1 wget -O - “http://mirrorlist.sangoma.net/?release=7
[[email protected] /]#
[[email protected] /]#
[[email protected] /]# host mirrorlist.sangoma.net 7
…/…/…/…/lib/isc/unix/socket.c:2171: internal_send: 0.0.0.7#53: Invalid argument
…/…/…/…/lib/isc/unix/socket.c:2171: internal_send: 0.0.0.7#53: Invalid argument
;; connection timed out; no servers could be reached
[[email protected] /]# ping mirrorlist.sangoma.net 7 -c 5
^C
[[email protected] /]# ping mirrorlist.sangoma.net 7 -c 5
^C
[[email protected] /]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 nollivoipserver.nollicomm.net
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
[[email protected] /]# netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
0.0.0.0 10.8.27.1 0.0.0.0 UG 0 0 0 eth0
10.8.27.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
[[email protected] /]#

I am unable to ping google though. According to here: Repo Issues - April 19th 2019

Tried this command: yum-config-manager --save --setopt=sng-updates.skip_if_unavailable=true

Then tried to update again resulted in the same.