Repo Issues - April 19th 2019

Before people start flooding about the issue, there is a problem with one of the repos and you’ll end up with this:

http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 403 - Forbidden

There is already an issue open in the tracker for it: https://issues.freepbx.org/browse/FREEPBX-19832

I found using this option allows the updates to complete and function while skipping the bad repo after checking if it is available.

yum-config-manager --save --setopt=sng-updates.skip_if_unavailable=true

2 Likes

Thanks for the post, seeing that this morning as well.

Hi All,
Im trying to switch asterisk Version from 13 to 16 And im getting this error

asterisk-version-switch
Pick the Asterisk Version you would like to change to.
Press 1 and the Enter key for Asterisk 13 (LTS) (With Opus and G729 codecs)
Press 2 and the Enter key for Asterisk 15 (With Opus and G729 codecs)
Press 3 and the Enter key for Asterisk 16 (LTS) (With Opus and G729 codecs)
Press 9 and the Enter key to exit and not change your Asterisk Version
3

You picked asterisk16

Clearing yum cache
Loaded plugins: fastestmirror, versionlock
Cleaning repos: sng-base sng-epel sng-extras sng-pkgs sng-updates
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos
Cleaning up list of fastest mirrors

Switching to Asterisk 16

Loaded plugins: fastestmirror, versionlock

Determining fastest mirrors
sng-base | 3.6 kB 00:00:00
sng-epel | 3.2 kB 00:00:00
sng-extras | 3.4 kB 00:00:00
sng-pkgs | 3.4 kB 00:00:00
http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.freepbx.org/display/PPS/YUM+Errors

If above article doesn’t help to resolve this issue please use https://issues.freepbx.org/

One of the configured repositories failed (Sangoma-7 - Updates),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=sng-updates ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable sng-updates
    or
        subscription-manager repos --disable=sng-updates

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=sng-updates.skip_if_unavailable=true

failure: repodata/repomd.xml from sng-updates: [Errno 256] No more mirrors to try.
http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

asterisk16 had an issue being installed and did not complete
Review the console logs and resolve the RPM conflict first
and rerun this script to try again.

I have tried to yum clean all same thing my PBXact Version 12.7.5-1902-3.sng7

We are aware of the issue and will have a fix shortly

2 Likes

Thank you Sir

Did you not read the very first post of this thread which said this is an issue and there is a ticket opened for it? You didn’t need to post all that stuff.

1 Like

I have system admin pro installed. When trying to run System Update, it returns an error saying "Unable to run ‘YUM CHECK-UPDATES’. When I log in to the console, and try ‘yum update’ I get:

~# yum update
Loaded plugins: fastestmirror, langpacks, versionlock
Loading mirror speeds from cached hostfile
Webmin                                                                                                                                     | 2.9 kB  00:00:00
home_netsroth                                                                                                                              | 1.3 kB  00:00:00
sng-base                                                                                                                                   | 3.6 kB  00:00:00
sng-epel                                                                                                                                   | 3.2 kB  00:00:00
sng-extras                                                                                                                                 | 3.4 kB  00:00:00
sng-pkgs                                                                                                                                   | 3.4 kB  00:00:00
http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.freepbx.org/display/PPS/YUM+Errors

If above article doesn't help to resolve this issue please use https://issues.freepbx.org/

 One of the configured repositories failed (Sangoma-7 - Updates),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=sng-updates ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable sng-updates
    or
        subscription-manager repos --disable=sng-updates

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=sng-updates.skip_if_unavailable=true

failure: repodata/repomd.xml from sng-updates: [Errno 256] No more mirrors to try.
http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

I have tried the steps in the article to no avail. I can get yum to work with other repos using:

yum --disablerepo=sng-base --disablerepo=sng-updates <command>

I cannot reach http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml in a browser and the result of curl is:

~# curl http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /os/7.5/updates/x86_64/repodata/repomd.xml was not found on this server.</p>
</body></html>

This issue is 7 hours old. I was first alerted to it by an automatic email which said:

-----Original Message-----
From: [email protected] &lt;[email protected]&gt;
Sent: 19 April 2019 07:49
To: xxxxxxxxxxxxxx
Subject: FreePBX (xxxxxxx VoIP Server) System Updates
Importance: Low

This is an automatic notification from your FreePBX (xxxxxxxxx VoIP Server) server.

http://sng7.com/os/7.5/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error

403 - Forbidden

Trying other mirror.

To address this issue please refer to the below wiki article

https://wiki.freepbx.org/display/PPS/YUM+Errors

If above article doesn't help to resolve this issue please use https://issues.freepbx.org/

 One of the configured repositories failed (Sangoma-7 - Base), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work &quot;fix&quot; this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working upstream. This is most often useful if you are using a newer distribution release than is supported by the repository (and the packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled yum --disablerepo=sng-base ...

 4. Disable the repository permanently, so yum won't use it by default. Yum will then just ignore the repository until you permanently enable it again or use --enablerepo for temporary usage:

 yum-config-manager --disable sng-base

 or

 subscription-manager repos --disable=sng-base

 5. Configure the failing repository to be skipped, if it is unavailable.

 Note that yum will try to contact the repo. when it runs most commands, so will have to try and fail each time (and thus. yum will be be much slower). If it is a very temporary problem though, this is often a nice

 compromise:

 yum-config-manager --save --setopt=sng-base.skip_if_unavailable=true

failure: repodata/repomd.xml from sng-base: [Errno 256] No more mirrors to try.

http://sng7.com/os/7.5/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error

403 - Forbidden

Any advice on how to get around this?

Regards

Again. We are working on this issue and will update when we have more details. Please sit tight. Thanks.

Andy. This is not true. It only broke about 7 hours ago. Your email clearly shows April 19th. Which is today. Thanks.

I’m attempting to install system updates. I’ve tried through the GUI and command line but they keep failing. I’m getting this error

[[email protected] ~]# yum update
Loaded plugins: fastestmirror, versionlock
Determining fastest mirrors
sng-base                                                                                                                                                                                                       | 3.6 kB  00:00:00     
sng-epel                                                                                                                                                                                                       | 3.2 kB  00:00:00     
sng-extras                                                                                                                                                                                                     | 3.4 kB  00:00:00     
sng-pkgs                                                                                                                                                                                                       | 3.4 kB  00:00:00     
http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article 

https://wiki.freepbx.org/display/PPS/YUM+Errors

If above article doesn't help to resolve this issue please use https://issues.freepbx.org/



 One of the configured repositories failed (Sangoma-7 - Updates),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=sng-updates ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable sng-updates
        or
            subscription-manager repos --disable=sng-updates

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=sng-updates.skip_if_unavailable=true

failure: repodata/repomd.xml from sng-updates: [Errno 256] No more mirrors to try.
http://sng7.com/os/7.5/updates/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

I’ve looked at the yum errors wiki and performed those troubleshooting tasks but it didn’t work. I have two PBX machines (primary and warm spare) and am having this issue on both.

Any idea how to fix this?

Oops… shows how long I was banging away at this. Sorry. Yes it was today.

Again. We are working on this issue. Thanks for your understanding

I didn’t see till Tony merged my posting with this but thank you.

Seems to be working already. Thanks Tony. (I didnt see this thread before I posted either)

We are still working through yum issues but most things outside of a blanket yum update should work, including Asterisk version switching

(also my name’s not Tony)

1 Like

I have no excuse as we share the same name. Too many late nights!

This is now resolved

@tm1000 Andrew is this relevant or a totally different issue?

at line 3 it hesitated for about seven minutes.

–> Finished Dependency Resolution
–> Running transaction check
—> Package kernel.x86_64 0:3.10.0-693.21.1.el7 will be erased
–> Processing Dependency: kernel(napi_complete_done) = 0x905307be for package: kmod-via-rhine-1.5.2-1.sng7.x86_64
–> Processing Dependency: kernel(napi_complete_done) = 0x905307be for package: kmod-via-velocity-1.16-1.sng7.x86_64
–> Running transaction check
—> Package kmod-via-rhine.x86_64 0:1.5.2-1.sng7 will be erased
–> Processing Dependency: kmod-via-rhine for package: sangoma-pbx-1902-3.sng7.noarch
—> Package kmod-via-velocity.x86_64 0:1.16-1.sng7 will be erased
–> Running transaction check
—> Package sangoma-pbx.noarch 0:1902-3.sng7 will be erased
–> Finished Dependency Resolution
Error: Trying to remove “sangoma-pbx”, which is protected
[[email protected] ~]#

That’s normal for kernel mods. About a year ago Rob accidentally published some kmods he didn’t mean to publish so we just have to get you off of those.

Each one of these commands will take several minutes to complete.

Here’s how to fix it (yes twice):

yum downgrade kmod-via-rhine
yum downgrade kmod-via-rhine

Then

yum upgrade

Thank you Andrew. Alas, I still get;

Error: Trying to remove “sangoma-pbx”, which is protected…

Package kernel.x86_64 0:3.10.0-693.21.1.el7 will be erased
–> Processing Dependency: kernel(napi_complete_done) = 0x905307be for package: kmod-via-velocity-1.16-1.sng7.x86_64
–> Running transaction check
—> Package kmod-via-velocity.x86_64 0:1.16-1.sng7 will be erased
–> Processing Dependency: kmod-via-velocity for package: sangoma-pbx-1902-3.sng7.noarch
–> Running transaction check
—> Package sangoma-pbx.noarch 0:1902-3.sng7 will be erased
–> Finished Dependency Resolution
Error: Trying to remove “sangoma-pbx”, which is protected