YUM issues


(Barbedwireman) #1

I am new to Linux and FreePBX. I have several systems I have inherited to maintain:
Current PBX Version: 14.0.13.4
PBX Firmware: 12.7.4-1804-2.sng7
PBX Service pack: 1.0.0.0

I have tried running updates via the updates module and get:

Last Online Check Status:
3 hours ago (Yum Error)
Last System Update:
Unknown (System updates not run since last reboot)
Updates Available:
Unable to run ‘yum check-updates’, can’t check for updates

I have tried running yum update in the CLI and get:

yum update

Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
sng-extras | 4.6 kB 00:00:00
hxxp://sng7.com/os/7.8/extras/x86_64/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for sng-extras: Damaged repomd.xml file
Trying other mirror.

One of the configured repositories failed (Sangoma-7 - Extras),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=sng-extras ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable sng-extras
    or
        subscription-manager repos --disable=sng-extras

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=sng-extras.skip_if_unavailable=true

failure: repodata/repomd.xml from sng-extras: [Errno 256] No more mirrors to try.
hxxp://sng7.com/os/7.8/extras/x86_64/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for sng-extras: Damaged repomd.xml file

I have tried yum clean all and pretty much every command I could find in research to correct this issue and had no luck. Is there someone who can guide me into success so I can get my systems updating again? Thanks in advance!


Cant yum update
#2

I am having same issue. It appears their repo is down.


(Barbedwireman) #3

This has been going on for a few weeks.


#4

I wonder if @qwell also handles this repo


(Matthew Fredrickson) #5

The yum repos are separate from the FreePBX module repos. I just ping’d @llang to see if he was aware of anything going on with them.


(Barbedwireman) #6

This issue turned out to be my web filter blocking yum traffic


(system) closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.