Sangoma Completes Acquisition of Digium: Sangoma Press Release. Community FAQ: Sangoma and Digium Join Together FAQ
FreePBX | Register | Issues | Wiki | Portal | Support

Problem outbound and inbound :


#1

HY Ladies and Gentlemen :stuck_out_tongue:

After 1 week of battle, I managed to run my Asterisk server (with Freepbx) and my 3102 spa as a gateway.
The trunk seems to work because the 3102 spa says it is well registered.

But i don’t manage to call outside ou receive calls.
Here the pstn line status of the spa 3102


#2

And here the configuration of the spa 3102 about pstn line


#3

following of the configuration of the spa 3102 about pstn line


#4

again lol


#5

and here configuration in freepbx :
inbound


#6

and here outbound


#7

dial plan of the outbound


#8

sorry for the numerous replies but i can’t put all the pictures in one replie :slight_smile:


#9

and for the trunk, i do a pjsip trunk like here :

https://wiki.freepbx.org/pages/viewpage.action?pageId=55476525

General :

Trunk Name = SPA3102 “User ID:” value

Outbound CallerID = SPA3102 “Dial Plan 2:” DID value

PJSIP Settings:

General :

Username : same as “Trunk Name” = SPA3102 “User ID:” value

Secret : SPA3102 “Password:” value

Authentication : “Outbound”

Registration : “Receive”

Advanced

Contact User : same as “Trunk Name” = SPA3102 “User ID:” value

Codecs

depends on your settings in the SPA3102 “Preferred Codec:”, by default it will be ulaw (G711u)


#10

On the SPA, Line Voltage shows as zero – the phone line is likely not connected properly. Depending on the source, voltage should be between 22 and 54 volts. Guessing from the Last VoIP Caller, you have an Orange Livebox; is that correct? If not, describe in detail what kind of line you have and how you are connecting it.

Make sure that the line is working by temporarily substituting an analog phone for the Line jack of the SPA, or check for the presence of voltage using a suitable meter. The line must connect to pins 3 and 4 on the SPA’s RJ11 jack. On the Livebox end, if the green jack is an RJ45, the line is on pins 4 and 5.


#11

Several Nights spending to try finding solves and you in 1 minutes you manage… :slight_smile:

Thank you
I have plug the wrong port on my Livebox, dsl instead phone
Shame on meeeeee :slight_smile:


#12

Hy again :slight_smile:

I have a new problem.

My outbound call works well.
But not ma inbound call

Here what i have with asterisk -rvvvvvv

Here configuration in my spa3102 about ptsn line


And about the trunk pjsip :slight_smile:



#13

There are subtle issues with FXO devices and pjsip. Simplified, on an incoming call the FXO device puts the caller ID in the From header, where pjsip normally expects to find a user ID to match the trunk.

One solution is to use a chan_sip trunk instead.

Depending on your Asterisk and FreePBX module versions, you may be able to fix the pjsip match priority from the GUI, or you may need to edit the config file manually. For the gory details, read these threads: Can’t get FreePBX to fully work with ht503 and No incoming calls .


(Avayax) #14

@Stewart1, you can use pjsip, but under pjsip settings/advanced, you need to set the Match Inbound Authentication field to Auth Username.
Inbound calls into pjsip registration receive trunks fail if that field is set to default, cause the trunk will try to match the incoming call on the user portion in the from header, which is always different depending on the number dialed.

This is a setting that was just recently exposed in the GUI after a bug report. However if you leave it at default all inbound calls into pjsip registration receive trunks will continue to fail, which is just gonna confuse people who will think pjsip is broken.
The default should be changed to Auth Username, at least for inbound registration trunks.
https://issues.freepbx.org/browse/FREEPBX-18179


#15

Hy everybody.
Thank you for your answers.
I Will try this afternoon.
I Will add another trunk and i ask myself if the register(reçeive,send,none) Will become send To notify ip address of the spa?


#16

Again me :slight_smile:

If i dont manage with your information,
Which version of freepbx ans asterisk do you advise me?
Thank you


#17

Registration ‘Send’ means that the PBX sends register requests to the device. That is used with most retail SIP providers but won’t work with the SPA, which is not a SIP registrar.

With Registration Receive, the SPA sends register requests to the PBX. If you were using a cloud PBX, you would use this method so the PBX could learn the public IP address of the SPA. It will also work with your local setup.

For Registration None, you manually configure the SPA’s IP address and port in the trunk settings. On the SPA, set Register to no.


#18

thank you for your explciation :slight_smile:


#19

Hy again,
i don’t have match inbound authentication in my trunk pjsip but i have this ( in the pics ) :


(Avayax) #20

What’s your Freepbx version?
This setting is available in:
core version 14.0.18.1
core version 13.0.122.21

You can check what core version you have in module admin.