FreePBX | Register | Issues | Wiki | Portal | Support

OSS Endpoint manager SQLSTATE error


(Chris Wilson) #1

Hello Everyone,

I am running FreePBX 14 and i’m receiving the following error when trying to add/edit extensions in the OSS Endpoint manager:

SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘asterisk.sysadmin_options’ doesn’t exist

Does anyone know if there is a workaround for this?

Thanks!

Chris W.


#2

Have you tried re-installing OSS EM module?


(Chris Wilson) #3

Yes, I have tried both uninstalling and re-enabling it and removing it completely and installing it again.


(Chris Wilson) #4

Looks like it is happening now when I try to edit an extension I have already added…


(Chris Wilson) #5

Just an update, I reinstalled and found that once I add an extension with endpoint manager this error starts happening.

I can edit extensions just fine up until the point I add the extension in OSS endpoint manager. Once I do that I can no longer edit extensions or mappings.


#6

I think you need to have Sysadmin Module installed. Maybe i will fix this in a future release.


#7

I am running FreePBX 14

I get the same error

i do all my setups from scratch using debian (Iknow I know you do not support)
I can load the zenguard loader configure for my php restart apache2 and even install incron to satisfy the sysadmin module (far more then I could do 2-3 years ago) on debian 9

although it just hangs on the install of sysadmin module install!

Downloading and Installing sysadmin
Downloading sysadmin
Installing sysadmin
Untarring..Done

thats it it never finishes so if I hit the x its not installed… not sure where to look for errors to try to find a workaround. ?! anyone?

If this is the case then i guess freepbx 14 will not work with Debian. This is bad this error pops up all the time editing ext and now OSS Endpoint manager


#8

There is nothing in Debian 9 that would preclude FreePBX from working with the major proviso that you need to provide an alternate older version of php than is distributed with Stretch
for FreePBX and perhaps other third party thingies (IWFM :wink: ) , I believe 5.6 would be the sweet spot.

https://wiki.debian.org/PHP

otherwise use jessie and wait for FreePBX 15 which catches up with php 7 . . .

(but as as an after thought because you seem confused, forget trying to install Sysadmin on anything but the Sangoma Distro.)


#9

oh I am not confused. I load many asterisk / freepbx setups a year… this is my most recent with 14 I always load php 5.6 due to that sort being what is nessary.

My issue is when I load the modules I want , one of them being OSS Endpoint manager. when I start adding mac address on the odd phone i get this

Exception
SQLSTATE[42S02]: Base table or view not found: 1146 Table 'asterisk.sysadmin_options' doesn't exist

and things like editing a ext crashes with the same error. do you want more of the error?

root@debianAsterisk:/var/log# dpkg -l |grep -i "php"
ii  libapache2-mod-php5.6                     5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        server-side, HTML-embedded scripting language (Apache 2 module)
ii  php-common                           1:62+0~20180820043235.3+stretch~1.gbp62811c                        all          Common files for PHP packages
ii  php-pear                             1:1.10.5+submodules+notgz-1+0~20170904061717.3+stretch~1.gbpe356ca all          PEAR Base System
ii  php5.6                               5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    all          server-side, HTML-embedded scripting language (metapackage)
ii  php5.6-cgi                           5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        server-side, HTML-embedded scripting language (CGI binary)
ii  php5.6-cli                           5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        command-line interpreter for the PHP scripting language
ii  php5.6-common                        5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        documentation, examples and common module for PHP
ii  php5.6-curl                          5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        CURL module for PHP
ii  php5.6-fpm                           5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
ii  php5.6-gd                            5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        GD module for PHP
ii  php5.6-json                          5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        JSON module for PHP
ii  php5.6-mbstring                      5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        MBSTRING module for PHP
ii  php5.6-mysql                         5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        MySQL module for PHP
ii  php5.6-odbc                          5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        ODBC module for PHP
ii  php5.6-opcache                       5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        Zend OpCache module for PHP
ii  php5.6-readline                      5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        readline module for PHP
ii  php5.6-xml                           5.6.37-1+0~20180725093819.2+stretch~1.gbp606419                    amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
root@debianAsterisk:/var/log#

When i read mitterhuemer “I think you need to have Sysadmin Module installed.”

i went to the http://www.zend.com/en/products/loader/downloads#Linux
grabbed the latest … copied the files to
cp ZendGuardLoader.so /usr/lib/php/

nano /etc/php/5.6/apache2/php.ini
[Zend]
zend_extension=/usr/lib/php/ZendGuardLoader.so

then checked it was loaded after a apache2 reload with php -m
then installed apt-get install incron

then i went to the freepbx modules and installed the sysadmin and well as mentioned above…

I uninstalled the OSS Endpoint manager
reinstalled it Have not tried to add some phones yet will do so and let you know


#10

Again, You can’t successfully install sysadmin on debian of any flavor.


#11

I am aware of that.

Maybe I should of typed out that i know debian is not supported and that i know it does not work instead of . “debian (Iknow I know you do not support)”

I might not of been clear enough. when i stated
"sysadmin module (far more then I could do 2-3 years ago) "
i should of stated that i have tried in the past to get it to load because its a shame you have a limited distro (redhat 6 and simular) I work with redhat all the time but still prefer to have it work in a tight load only what I need debian setup.

The fact that I got to the point where the module felt that it had all that it needed in order to install was sort of a gitty feeling meaning will this work… but I was disappointed when it just hung there… so I posted this (see above)

hopeing that maybe its possible now and all someone has to do is write some code.

But more over disappointed it did not load and that it was suggested that the error I am receiving that I possibly need to install “I think you need to have Sysadmin Module installed” mitterhuemer

and above i note my frustration
"If this is the case then i guess freepbx 14 will not work with Debian. This is bad " because maybe no one is aware that if this is the case
then OSS Endpoint manager will not run with out this error. crippling all Debian type and none redhat 6ish installs… (again why so limited!)

And after uninstalling and reinstalling the OSS Endpoint Manager and resetting up and adding in the polycom snom and some yealink phones

and trying to add a 550 polycom … i again get the same error

Exception

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'asterisk.sysadmin_options' doesn't exist

so unless I am confused and I am missing something the only response at this point is to fix this is to load the sysadmin module … that is not possible to load in Debian.

am I wrong ? "There is nothing in Debian 9 that would preclude FreePBX from working with the major proviso that you need " dicko seems like there is something stopping me from getting the proviso that I need


#12

All the open source FreePBX code works fine on Jessie, if you move to Stretch, you need to provide an environment including PHP that is compliant with all the software you are running, that means downgrading, maybe the open source end point manager is even more picky.

It all works for me and I never use any commercially licensed software.


#13

"if you move to Stretch, you need to provide an environment including PHP that is compliant "

i am running PHP5.6 no problems there… Everything runs fine… The module OSS Endpoint Manager requires sysadmin!

what makes the Debian 8 not require sysadmin … is the OSS Endpoint Manager module not in need of of the sysadmin?

root@debianAsterisk:/var/www/html/admin/modules/endpointman# grep -alir "Sysadmin"
includes/functions.inc
module.xml
i18n/ru_RU/LC_MESSAGES/endpointman.po
i18n/fr_FR/LC_MESSAGES/endpointman.po
i18n/zh_CN/LC_MESSAGES/endpointman.po
i18n/de_DE/LC_MESSAGES/endpointman.po
i18n/es_ES/LC_MESSAGES/endpointman.po
i18n/bg_BG/LC_MESSAGES/endpointman.po
i18n/ja_JP/LC_MESSAGES/endpointman.po
i18n/he_IL/LC_MESSAGES/endpointman.po
i18n/endpointman.pot
page.epm_placeholders.php
root@debianAsterisk:/var/www/html/admin/modules/endpointman# 
root@debianAsterisk:/var/www/html/admin/modules/endpointman# grep -alir "getSysadminSettings"
includes/functions.inc

Seems it mentions sysadmin?

root@debianAsterisk:/var/log# cat /var/www/html/admin/modules/endpointman/includes/functions.inc |grep -i "sysadmin"          
	 //SYSADMIN Settings
	public function getSysadminSettings(){
		$sql = "SELECT * FROM sysadmin_options";
                $this->error['sysadmin_options'] = "Error with SQL Statement";
			$getSysadminSettings=$this->getSysadminSettings();
	$getSysadminSettings=$this->getSysadminSettings();
					'provisuser' => $getSysadminSettings[provisuser][value],
					'provispass' => $getSysadminSettings[provispass][value],
					'sslhpro' => $getSysadminSettings[sslhpro][value],
					'hpro' => $getSysadminSettings[hpro][value]
					$provisioner_lib->settings['provisuser'] = $getSysadminSettings[provisuser][value];
					$provisioner_lib->settings['provispass'] = $getSysadminSettings[provispass][value];
					$provisioner_lib->settings['sslhpro'] = $getSysadminSettings[sslhpro][value];
					$provisioner_lib->settings['hpro'] = $getSysadminSettings[hpro][value];
root@debianAsterisk:/var/log#

#14

I can assure you that none of the open source FreePBX modules rely on sysadmin, which is just as well because it is not installable on debian, and I exclusively use debian .


#15

I do not know what to tell you maybe someone uncommented something that requires it. I just loaded it a day or two ago and it had a update today…

I have versions of it running on debian 8 and older setups I am pretty much all debian

OSS Endpoint Manager

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'asterisk.sysadmin_options' doesn't exist

after I add aphone say a olycom 550 and it gives this error it does show me the phone in the list when I hit the back button… but if I try to rebuild config for that phone same error… i dunno… I guess I need to comment out all refrence to this table maybe?


#16

Sorry, I have never seen that so I won’t comment further.


#18

Try to install this verison, it should fix your Problem with the missing sysadmin module.

	*14.0.2* Fixed a Problem if Sysadmin is not installed. Sysadmin is a commercial module and should not be forced to be installed to use OSS EPM.
	*14.0.1.9* Device Manager does not Group Lines by Device anymore. The MAC gets auto deleted if you remove the last line in the list	/ Fields in Device Manager are now sortable

https://github.com/matthias1232/mihuendpoint/archive/endpointman-14.0.2.zip

Pull Requests are made and need to be approved by Sangoma @tm1000


#19

I installed it. Thank you for keeping OSS Endpoint Manager available.
I would buy at least 5 licenses right now if someone made the paid commercial modules zenguard loader and all work for Debian based heck more neutral to distros

now I get this when I add a phone
(this time a polycom 430)

Whoops \ Exception \ ErrorException (E_WARNING)

copy(): The first argument to copy() function cannot be a directory

#20

I did not use Polycom anytime before. But i also made some updates on the provisioner package in the past:
You can also try to use our Package Server and update your Packages. But as is said: We never used Polycom anytime.:
https://provisioning.powerpro.at/greenepm/v3/


#21

What i still remember is sometimes you need to run “fwconsole chown” to fix some permission issues on oss epm. Maybe this solves your problem