No Audio on external call forward?

I face a strange issue, I’d like to describe with 2 inbound DDIs (+49 xxxx xxxx-21, -22).
They are routed to the corresponding extension (-21, -22).
Each extension has several endpoints (desktop Phone, Softphone, etc.)
I use “FindMe/FollowMe” to make a parallel call to a mobile.

All this works fine on extension -21:
Calls are signaled on all phones, including the mobile.

Now, extension -22 is set-up exactly in the same way.
All works fine, except external calls been received on my mobile.
Here I have no audio. Neither in or out.
Again: calling -22 from internel, audio works. Only comming vom PSTN I have no audio.
I use the same mobile number for -21 and -22. On -21 ist works great, but -22 fails on audio.

Any iderars? - I already deleted the inbound rule and the extension. No success.


P.S: I had a look on “No audio on externally forwarded calls, but follow-me is fine”. But this is not the same issue. I have 2 identical extensions. one is working the other is not.

Do a test by setting Confirm Calls to Yes in Follow Me for extension 22, Submit changes, Apply Config.

Have someone call in from outside. When you answer the mobile, do you hear the “You have an incoming call …” message? If so, when you press 1, does the announcement stop? If so, can you hear the external caller? Can he hear you?

If all of these are true, check that you have forwarded (in your router / firewall) the UDP ports corresponding to RTP Port Ranges (default is 10000-20000).

Spooky :slight_smile:
When I turn on “Confirm Calls” it works.
I’ll try to find out what my Firewall does and come back.

But - how can it be I have this only at the one extension and no general issue :-?

OK, update.
I turned off “confirm calls” but added an announcement.
Then it works fine.

Now I checked the other extension. There was also an announcement present.
So this is the smoking gun. - But does the replay of a sound file solve the issue?
I’ll now try to see what happens on the router firewall.

It’s not a “replay” it’s just play and it is due to the PBX starting the audio stream when the call is answered instead of waiting for inbound audio. So there is something that is not handling NAT/audio right if you don’t send audio immediately.

We would need to see a complete debug of a call that is having this problem. So turn off the announcement to replicate the issue and make a test call while having either:

asterisk -r
sip set debug on OR pjsip set logger on depending on the type of trunk you are using.

Copy the whole call from the start and paste the results here or pastebin and link that.

Opened UDP 10000 - 20000 on filewall and it works now :+1: :slight_smile:

thanks !!!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.