FreePBX | Register | Issues | Wiki | Portal | Support

No audio on externally forwarded calls, but follow-me is fine


#1

FreePBX 12.0.76.6
6.12.65.26 (old, I know)

Scenario 1: an external call comes in, the receptionist tries to forward it to an external cell phone number, the cell rings but no audio

Scenario 2: an external call comes in, rings on an extension that has follow-me configured with a cell phone number, the cell phone rings and audio is fine.

I’ve tried to add the following settings in the Chan SIP settings (found a few threads on the subject) but no luck:
progressinband=yes
prematuremedia=no

Also added rtpkeepalive=1, still not working

Any other clue on what I should try ? I guess that updating the system would probably be a good thing…


No Audio on external call forward?
(Dave Burgess) #2

One-way audio is almost always a NAT issue, and this doesn’t sound like it’s violates that rule. The wrinkle is that the FMFM part is strange. Do you have /var/log/asterisk/full logs for a failed call that we can look at?


#3

Thanks for the reply
It’s not a one way issue, there is no audio at all.
I will try to get some logs.


(Lorne Gaetz) #4

Do you have the RTP media port range forwarded to the PBX at your router?


#5

No. I manage a lot of other systems and they all work fine without any port forwarding. This one is the oldest though.


(Lorne Gaetz) #6

As Dave said this is almost certainly a NAT issue, and port forwarding of the RTP range eliminates a point of possible failure. I would try it.


(Lee Mason) #7

Potentially this might also be a SIP ALG issue. If your router supports SIP ALG (sometimes called SIP Helper) and have a setting to disable it then do that. With more firewalls it causes nothing but problems and they can be very random in nature. I have had problems in the last whereby transfers will not work at all if extensions are behind a SIP ALG enabled firewall (using a remote PBX), but everything else works OK.


#8

I upgraded the system of the customer to FreePBX 14 and now everything is fine. I guess we’ll never know what was wrong :wink:


(system) #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.