FreePBX | Register | Issues | Wiki | Portal | Support

LinkedChannel=null


(Lior Me) #15

i have some update
i’ve tested the phonebridge on an older asterisk, and it works right away, perfectly
on the new one, it doesn’t
zoho’s developer insists that the new version does not send channel information and it’s not a problem with the adapter itself
please help?


(Dave Burgess) #16

Sounds like it’s time for an Issues ticket. If the old version worked and the new one doesn’t, I consider it a bug.


(Tony Lewis) #17

It’s cause astsrisk changed things around and the bridge from zoho hasn’t been updated by them. You will need to have them figure out what changed and how to adapt their bridge for newer asterisk versions.


(Lior Me) #18

yeah. i think so too
but they wont cooperate
they insist it’s a problem with my system
i even installed a fresh asterisk out of the box with 1 test ext and still the same problem
anywhere i can modify the settings that will send them those settings: ?
dialedChannel=null,dialingChannel=null,linkedChannel=null
instead of null, information will appear


(Dave Burgess) #19

When I was helping Joel with this, it wasn’t that it was “our” system that was the problem, it was because the Java interface was developed (but not maintained) by someone else. They are still using the Asterisk 1.4 interface for this, and Asterisk has moved on since 2005.


(Lior Me) #20

yeah. i tested it on 1.8 as well, also working
but with the new one it wont
i even tried to install an older java version on the asterisk 13 but same problem
is there no hope? :slight_smile:


(Tony Lewis) #21

The person who built this connector needs to update it for modern asterisk. Only they can fix this.


(Dave Burgess) #22

There is hope, you just won’t find it here.

There were significant changes to the system with the introduction PJ-SIP. That (it appears to me) is the bellwether event that caused the problem. Before that, the 1.4 Asterisk interface was close enough to get working - after that, not so much.

Zoho is out of their depth on this issue (you can tell them I said so) and they refuse to admit it. It’s as if their marketing department is in charge, or that they aren’t really interested in supporting anything but 12-year-old installations. To defend their position for a second, there doesn’t seem to be a clamor amongst the Zoho users to intergrate this without “third party” support - there are people out there that claim they can get it working.


(Lior Me) #23

do you know such people? i’m willing to pay top dollar :slight_smile:


(Dave Burgess) #24

Emphasis added. The guy we hired got over $1000 and never got it working.


(Tony Lewis) #25

Why would you not use the CRM module we have which supports Zoho CRM.


(Lior Me) #26

you mean sangoma’s module? the crm module?
i’ve tested that. he only does part of the job. he records the calls into the customer cards, but no live action. no call pop-up, no click to call (with pop-up to start noting the call) and such


(Tony Lewis) #27

It does all of that if you have Zulu as it needs something on the desktop to be able to work with the browser.


(Lior Me) #28

really? how does it work?
i’ve added the chrome plugin, but whats next?


(Lior Me) #29

bare in mind that i mean the built-in capabilities of zoho, not a third party app
for example : in a working mode, zoho will popup a window that start recording/counting call duration/making notes of the call, all that on the fly, built into the zoho’s web interface. can zulu do that? isn’t it just a desktop app for clicktocall and such?


(Phonesupport1) #30

Hey Sajit,

I’m having the same Linked channel=null issue with the Zoho PhoneBridge. Would you be will to send me the update .jar files you received from Zoho and mention above (Zoho/ztiadapter/teleadapters/elastix16/lib/ZTIElastix16Impl.jar &
Zoho/ztiadapter/lib/ZohoTeleAdapter.jar)?

Thanks!


(Sajit) #31

Can you attach ur current log which u have attached it shows of 2015


(Sajit) #32

Please attached the log i need to check


(Phonesupport1) #33

Thanks for following up! Link to ztilog.txt is below. Do you need any other logs?

https://drive.google.com/file/d/1LyHDxJwxJXk0oSwqSZqd2b_DTuP7-692/view?usp=sharing


(Phonesupport1) #34

Following up to see if anyone has a fix here? Trying to integrate FreePBX 14.0.3.2 VoIP Server running Asterisk 13.19.1 with the official Zoho PhoneBridge and 100% of the features functioning.

As liorme indicated above, we are more than willing to pay $$$ for a solution.