Install FPBX-64bit-1707-1 distro

I need help for a fresh install. Downlodaded the latest distro. Boot from DVD and select VGA installation. Installation starts, but after some time by screen is black and remains black. Grafik is a onboard VGA. I’ve been reading about “nomodeset” in Grub. But where and whan can I access it?

Best regards, Ginne

What is your platform

Kontron KTGM45/ATXE industrial board:

Intel® GM45 + ICH9M-E Embedded Chipset,
Intel® Core™2 Duo mobile
Intel® GMA 4500 MHD graphics with PCI-Express 16x
3x Intel® Gigabit Ethernet, one with Intel® AMT 4.0 support
4x SATA300 w. RAID 0/1, HD Audio, 12x USB 2.0



The only time I’ve ever seen this happen was with a machine that had a bad hard drive. The HD would lock up and freeze the system.

At what point is your screen going blank? What was the last thing you saw?

I’m having the exact problem with the installation on my hardware. I have an:

  • embedded Intel® Atom™ D2550 1.86GHz Dual Core
  • Intel® NM10 Express Chipset
  • 4GB memory
  • 160GB SATA HDD
  • Intel video (onchip)

During the installation, the screen goes blank after unpacking to initramfs. I think the installation “kickstart” is launched but the video/monitor not compatible with the hardware. While the screen is blank, I can still see the cdrom LED continue to blink I thnk the installation did launch. But the video/monitor is not compatible with the driver. That would be why the screen went blank. FYI, FreePBX-32bit-10.13.66 installed successfully!

Now that you mention it, I did have a problem with one installation where the monitor wouldn’t display the “standard” video from the FreePBX system once it switched over to “X”… I ended up having to find a better monitor to finish that install. I did get an “out of sync” error on the monitor, but not all monitors do that when you overdrive them.

I don’t believe the monitor is the problem with my case. I have a fairly new monitor on the system. It’s can handle 1920x1080. I think the problem is with the video drivers.

I checkt the Harddrive (Intel SSD) it works perfect. The last thing I see is short after it says Sagoma Linux is loaded a Menue with a green bar and that it. I used an other Monitor, same thing. By the way if the screen gors blank the installation continues, I see HDD and DVD-drive working. So the system is not locked up.


I’m also quite sure it is the video driver!

STABLE (LEGACY) 10.13.66-64bit installs without any issues!

Generally you should interrupt the grub loader ( press esc) and then press “e” then add nomodeset to your kernel parameters, that way your video will be a basic BIOS derived driver and no HDMI or extended VGA ,would be enabled. Pretty well every monitor should abide by that decision, but on an HDMI monitor you might need to f*%& with the ‘overscan/aspect ratio (use 4x3)’ in the monitors settings menu to actually see it all

1 Like

Sorry for the question. When exactly I have to press exc?

CentOS 7 is more strict with older hardware. This processor is over 5 years old.

As soon as you see the grub boot screen! GRUB will then pass such restriction to the kernel loaded, which effectively restricts any attempt to load a higher level driver.

1 Like

sorry again, I boot with the DVD, the immediat I see the menu what to install, after the selection installation starts, no way to interrupt …

you waited too long, the GRUB/BIOS screen should come up before the boot screen, as you boot, “sit on” the esc key

then I get “boot:” and it wants me to enter the kernel image

Then your boot image is corrupt. Start over with an image that agrees with md5sum against the mdsum file in the same place that you got the iso from, then do the same check against your burnt dvd before using it.

But at least your video driver is working now :slight_smile:

checked DVD with md5sum and it matches with md5sum from freepbx site! What do you mean “video driver is working”??