HT813 FXO Port Trunk and Intercom System


#41

Sorry, but this is way too hard to read. In Wireshark, please right-click on a syslog packet and select Follow->UDP Stream. A new window should open will all the syslog entries as plain test. Paste that and post the link.


(Canada) #42

Unfortunately, for some reason, I do not see any syslog packets, in any new captures anymore…even though all the syslog settings are there…


#43

If you saved the old capture, open it and do the Follow->UDP Stream.

Try rebooting the HT, open its web page and check that syslog is still set up. Confirm that the device running Wireshark still has the same IP address and that’s what the HT is pointing to.

If you really can’t fix this, I’ll attempt to wrestle with that awful log.


(Canada) #44

Okay, here it is:
https://pastebin.freepbx.org/view/11d9a8f8


#45

So absolutely nothing logged for the attempted call? What did the phone show when you tried?


(Canada) #46

rings once, and says no response…I have a new one for you…probably same result though…


(Canada) #47

Here is the updated capture, I wired right into the switch:
https://pastebin.freepbx.org/view/47827f0d


(Canada) #48

Okay, it says 486 busy now, let me recapture and see what the heck is up…new syslog shortly.


(Canada) #49

Okay!!! I have syslog Call DATA now!!! woo hoo!!
it’s coming right now!!


(Canada) #50

https://pastebin.freepbx.org/view/55c4958e
there it is!! Much better!! Still not working but we have DATA!!


#51
  1. HT813 [00:0b:82:e9:e6:4d] [1.0.9.1]Nuvoton::getFxoLineStatus, Ch(1) Line Voltage is . V, Line current is 0 mA
  2. HT813 [00:0b:82:e9:e6:4d] [1.0.9.1]Nuvoton::isFxoPortAvailable, FXO Port Busy
    I’m very confused. This is as if it doesn’t see voltage across the FXO loop, but the Status page shows it as idle, which is not consistent. When you unplug the cord between FXS and FXO, does the FXO status now show disconnected (as it should)?

This is starting to smell like firmware corruption. Is newer firmware available on Grandstream site? If not, perhaps try reloading the current one. Or, try factory reset and setting it up again? Do you have a multimeter to check voltage on the loop? How did you get this unit and is it still in warranty?


(Canada) #52

Okay, the plot thickens, I put a Viking voltage booster on it:

And now it works…but only once, then I have to reboot the HT813 for it to work again…which isn’t helpful…So one-page/intercomm call works, but then after that, I can’t make any more page calls. When I reboot, I can make ONE again.


(Canada) #53

By the way, I already reloaded the newest firmware today, and I’ve already reset to factory settings :frowning:


(Canada) #54

I can however take another syslog to see why I cannot consistently make calls.


(Canada) #55

I ordered this unit from CDW…


#56

Please do. If possible, post both the successful and failing calls.


(Canada) #57

Okay, I will indeed, give me about 5 minutes and I’ll post Successful and Failed :slight_smile:


(Canada) #58

Okay, here is the pastebin for the successful Page, and then the failed ones after
https://pastebin.freepbx.org/view/dd805fe7

This line looks interesting, on the second call to the intercomm system that is rejected:
LIBGSDSP: CSS: 260920198, p_suppressFxoTone:175 Warning:: new SIG_ON received before timer for previous SIG_ON has expired

…But then again, I’ll look to your experience :slight_smile:


#59

You may be correct, but I unfortunately have not been able to determine what that means. Possibly, Grandstream support, with the aid of these logs, may be able to tell you what went wrong.

The failed call looks like it got connected, but I suspect that one or more of the DTMF tones were not sent or not ‘heard’ so the page didn’t work. If nothing was sent, you would presumably hear dial tone from the intercom device. Possibly, slowing things down may help. Try setting DTMF Digit Length to 200, DTMF Dial Pause to 200 and Min Delay Before Dial PSTN Number to 2000.

Do you have a way to listen to the FXO port as the call is being dialed (butt set, capacitor in series with earphone, etc.)?


(Canada) #60

Okay, I do have an ongoing ticket I started with Grandstream…that being said, I have found to date, that it’s best to work through these issues with a mix of the FreepBX forums, and Grandstream support, since both sides seem to compliment each other…to be honest, the best diagnostic info has come from seasoned people in this forum, with the gaps being filled in by grandstream for their product. With that said…sadly I do not have a “butt set, capacitor in series with earphone, etc.”, Can you point me in the right direction…and can I get one affordably? I will also test the settings for the DTMF tones you provided. As you have probably guessed by now, I work in a rural setting among mid sized cities, and sometimes it takes me a little time to get back to the site…that being said…I’m really trying to solve this one…so I’ll try to get to those settings sooner. If I solve this the trunk setup you gave me will work as well.