HT813 FXO Port Trunk and Intercom System


(Canada) #1

Okay, I really need some help on this one. I have an HT813, with an FXO port that is required for my intercom system. I can hook up an analog phone to the TIP and RING on the Intercomm system board, dial the intercom extension, and I am able to make an announcement to the whole school. However, when I hook up the HT813, program the ethernet voip line, and hook the TIP and RING up to the FXO port on the HT813, I am unsure how to trigger the FXO port extension from the VOIP side. It seems like it would be easy for this device to do, but I am unsure on how to do it. I am told that we may need a trunk on our FreePBX to do the forward, but have no idea how to to that. Can anyone give me a config example for the freepbx, or if this is all possible from the HT813, can someone let me know how to do that too?

Thanks for all your help in advance.


(Dave Burgess) #2

Rather than point you at the four other times we’ve talked about this in the last year, may I recommend using the Forum Search function and searching for “ht813 intercom”. In those articles and discussion threads, you should find at least one approach that will work for you.

From a quick re-read of the threads, it looks like there are at least two different approaches that work, so you should be able to hit upon a solution that works. If you’re still having trouble after reviewing those and have specific questions, we’re here for you.


(Canada) #3

Yes, I did see those Dave, and I have been unable to get those examples to work to date. I am taking another kick at the can tomorrow, to see if I have success. I will report back any errors, and the settings I have, and maybe someone will be able to direct me as to where I am going wrong. I have no problem experimenting. I did have a thread started earlier this year, unfortunately it closed before I had a chance to get to it again.


(Canada) #4

Okay so I used these instructions here:
https://wiki.freepbx.org/pages/viewpage.action?pageId=33293313

But I have some questions about Step 1 and Step 2.

In my mind with previous attempts, I thought Step 1 should be enough, IE: Setup an extension on the HT813 against the FXO port. But as stated above when the Call the already tested Board, from the FXO port using the extension, I get one ring and a busy signal. Maybe I need to Dial the extension and have it pass *01 (The intercom feature code trigger), but I am unsure how to do that.

I also moved onto step 2 just in case, and setup a trunk and a route. I am hoping when I go to the school and dial 9, I get a dial tone to the FXO port, and hopefully I can dial *01. If that doesn’t work, I’m stuck and hoping for some help. I can also pass my settings if need be.

I am going to head over to the school today and then report back, if I stumble again…I think I’m getting closer.


(Canada) #5

Okay everyone, I found this post here:


The issue I have, is the exact one in this post above, which has no resolution…

I Believe my board is the one listed below, but I will also take a picture of it an verify it.
101F542 Telapex Telephone Interface Card

I did set up the trunk as well for testing.


(Canada) #6

Okay, I’m back at the school, and I have tried configuring the HT813, every possible manner I can from all of the forums posts I have tried setting up and extension and forwarding it to the HT813 FXO port, I have tried a trunk, to date, I cannot get a dial-tone. I know I have some connectivity, because when I dial the extension I get ONE ring and then a busy signal. I also see the fxo port as active and idle, when it is not, I get no service, when it is registered, I get the ONE ring and a BUSY tone. So there is connectivety:

But as stated, if I try dialing the extension, ONE ring and then Busy. I’ve tried this as well:
Current Disconnect: OFF
Reverse Polarity: OFF
Tone Disconnect: ON

I’ve also tried several other settings suggestions from forums, but the same result always, One ring and then busy instead of it forwarding to a PSTN tone for the FXS card on the intercom system, from my FXO port.

The lights on the HT813 all seem correct too:

Does anyone have any ideas or suggestions? I fell like I’m close and just missing something small.


(Canada) #7

Okay, the plot thickens, I put a Voltmeter on the TIP and RING of the MCS350’s 101F542 Telapex Telephone Interface Card and I only get 15V off of this FXS card. Is that a problem for the HT813, is that why I am getting a BUSY signal, instead of a dial tone?


#8

A standard ‘battery’ would be -48v , many pbi only do 24v, , many hardware have a setting specifically for PBI low battery , but if the molex connector (13V or so on yellow) is not being augmented, you might well see what you are seeing.

( 2.5 x 5 (red) v 2.5x 12 (yellow) makes me wonder if the molex is connected ?)


(Canada) #9

Hi dicko, here is a picture of the 101F542 Telapex Telephone Interface Card Dukane terms it a, “Modular add on card” here is a picture of it:


The only power to the card, as far as I can tell is on the bottom 6 wires here (mixed in with other functions)

It’s all proprietary. I don’t think there’s any Molex power to this card, unless it’s hiding, But I didn’t see any…mind you, it’s hard to pull this card out any further for fear of ripping out other wires but I believe that’s the only power going to the card based on how they are daisy-chained together.

PS - I put the multimeter probes on the FXS TIP and RING right above that, where you see the Phone pair attached to TIP and RING.


#10

https://www.google.com/search?q=101F542&sxsrf=ALeKk018nK7jKkPn6DEHVTKKdIWJiWFimA:1598929198368&tbm=isch&source=iu&ictx=1&fir=p62HJ6uiDlfFM%252CTToQIRfrObVyRM%252C&vet=1&usg=AI4_-kT8XVr8Fa64PqIka2C1eLLOuSgbhA&sa=X&ved=2ahUKEwjMuI63-8brAhUzHDQIHYwcASIQ9QF6BAgKEA0#imgrc=_p62HJ6uiDlfFM

Claims it should be 24v, maybe it’s broken?.

Grandstream devices consider anything less than about 20v as being ‘busy’ but something like

https://phoneman.com/loop-current-booster-plus.html

might help.


(Canada) #11

Hmm, it could be somewhat broken…except that when I hook up the old Analog phone from it’s FXO port, to the 101F542 Telapex Telephone Interface Card I can page with *01, however maybe the analog phone is more forgiving, and doesn’t mind that it’s 15V. And if the HT513, doesn’t like anything less than 20V…Then that makes sense…I was wondering if this would work:

https://phoneman.com/loop-current-booster-plus.html

Do you think it’s worth a try for $100?


#12

My edit beat found the same device (and beat you to it by seconds)


(Canada) #13

ha ha ha. Have you every tried one? So as you can see on my card, I have TIP and RING wired, and then I have that going to an RJ11 male end, I imagine that would plug into phone, and then from there I would go from LINE to the FXO port on the HT513, and hopefully this would boost the signal enough for it to answer?


#14

if an old analog phone pulls dialtone, odds are you wouldn’t waste $100 maybe a 9/12v battery in series would be a cheaper mcgyver solution to add enough bias to fool the GS


(Canada) #15

Do you have any schematics for how that would work, would I literally just look up any series wiring and use the positive and negative phone line with that?

Here’s one from viking as well, around same price…
https://www.telcom-data.com/accessories/vik-tbb-1


#16

IMO it’s very unlikely that you have a voltage problem – HT813 screenshot you posted shows the FXO status as Idle; if voltage were insufficient it would be In Use or Busy. You can confirm this by unplugging the cord and refreshing the Status page.

IMO your desire to ‘hear dial tone’ from the intercom is making your problem far more difficult. In normal use of the HT when connected to an analog line, the user dials e.g. 2345678, Asterisk sends “INVITE sip:2345678 …” to the HT, the HT takes the FXO off hook, waits one second and sends 2345678 as DTMF. The analog line plays dial tone during that one second wait, but the user doesn’t hear it. For the user to hear the analog dial tone, the HT has to be tricked into sending no digits at all. Don’t go down that path.

Please try the following setup: Delete any extensions associated with the HT. Create a chan_sip trunk named HT813 with these settings:
Trunk Name: HT813
Peer Details:
host=dynamic
username=HT813
secret=1234
type=friend
qualify=yes
context=from-trunk
User Context: (leave blank)
User Details: (leave blank)
Register String (leave blank)

Create an Outbound Route pointing to this trunk with Dial Pattern:
prepend: *
prefix: 99
match pattern: XX

Set up the HT FXO page (settings not mentioned left as default):
Account Active: Yes
Primary SIP Server: 192.168.1.123:5160 (replace 192.168.1.123 with the PBX IP and replace 5160 with your chan_sip Bind Port if you changed it from the default of 5160).
SIP User ID: HT813
Authenticate ID: HT813
Authenticate Password: 1234
Name: HT813
Dial Plan: {*x+|x+}
Wait for Dial Tone: No
Stage Method: 1

Reboot the HT, wait 60 seconds, check status page for registration. If it failed, report what, if anything, appears in the Asterisk log on registration attempts.

If it’s registered, test by dialing 9901 which should send *01 to the intercom. If it fails, at the Asterisk command prompt, type
sip set debug on
make a test call, post the relevant section of the Asterisk log at pastebin.freepbx.org and post the link here.


#17

the tip is a positive ground , the ring -batt, attatch the positive of the battery to device ring and the negative of the battery to the GS ring , (GS tip to device tip), I think the GS is floating and polarity neutral though, it swings both ways as to tip and ring

I havent tried this in years though but its worth a try,.

You might need a 10mictofarad tantalum (non electrolytic) capacitor across the battery if the audio sounds clipped


(Canada) #18

@Stewart1 this looks Really promising!! I will try this tomorrow morning, I have to drive out to the school again. I will test this config and report back to you. I’m in CAD mountain time.


(Canada) #19

@Stewart1, I Configured the Trunk, Outbound route. and the FXO as you suggested. It DOES register, but when 9901 is called, it just gives a busy Signal. I have turned on debugging, and logged it, here is the paste bin. You can Look at 3847, and 9901 (3847) is the phone I used to call 9901.

https://pastebin.freepbx.org/view/02856e5d

Any help is greatly appreciated,


#20

Although I don’t understand why the SIP debug is present for the calling extension but not the HT, I believe that the HT did send the 486 Busy Here, which likely means that it thought the line was in use, even though the Status page showed Idle.

I’m guessing that when it went off hook to start dialing, the loop current was low enough that it (falsely) detected that another phone on the line had been picked up.

Do you have another FXS device (or analog phone line) to connect in place of the intercom to see whether behavior is different? If not, you could configure the FXS side of the HT as an extension. If you set the Dial Plan same as the FXO, it should accept *01 (test with an analog phone) and (by default) you should hear “The speed dial entry you’ve accessed is empty.” Then, plug the FXS and FXO ports together and dial 9901 to test.

Alternatively, you could set up syslog on the HT at Extra Debug level and with luck it will tell why it gave the busy response.

If this is indeed a voltage or loop current issue, we can discuss various workarounds.