HT813 FXO Port Trunk and Intercom System


(Canada) #21

Two questions what does connecting the ports together do (connecting FXO and FXS together) and dialing 9901? I could indeed set up syslog on the ht813 to see what’s happening. I will report back…it’s really starting to feel like a voltage issue given the voltage meter measurement. But I will test this as well just in case.


#22

If you set up the FXS port as an extension, then it can emulate the MCS350 (but supplying plenty of voltage), as a test for whether the present problem is indeed caused by insufficient loop voltage and/or current.

First, plug an analog phone into the FXS port and confirm that you can call out. Dialing *01 should play the speed dial empty message. Then, connect FXS and FXO together. If the FXO is configured and working correctly, dialing 9901 from an IP phone should also play the speed dial empty message. If that gives a busy signal, something is likely misconfigured in the HT.

If you get that far, connecting a 9V battery as @dicko described may get it working with the MCS350.


(Canada) #23

Okay, sounds good, I will go to the site, and try all of these suggestions. I will get back to you with the results, and we can move forward based on that. I just need to drive out to the school again, talk to you soon.


(Canada) #24

I still have to get to the school, but I need this thread to stay open so I can work with @Stewart1. Thanks.


(Canada) #25

@Stewart1, this is still on my radar. I want to keep this thread alive. I still have to try your two suggestions. I am also waiting for a Talk Battery, voltage booster to try with your suggestions. I think I may need to pass you another log as well. After I test.


(Canada) #26

Still need to go to school. Need thread alive. Bump.


(Canada) #27

I’m hooking up a Viking voltage booster today, and I will report back results and logs. I’m hoping it works. I am also trying the suggestions to see the results, IE misconfiguration vs voltage boost.


(Canada) #28

@Stewart1 are you by any chance still following this thread?


#29

Yes but haven’t seen any new results so haven’t posted anything.


(Canada) #30

Thank-you for responding, I should have better results today or tomorrow. It’s school start-up, so it’s taking me a bit longer, but I will have some new results soon. Thank you for sticking with me while I work through this.


(Canada) #31

Bump. I have some new information from grandstream now too to try as well.


(Canada) #32

Testing peer to peer settings from grandstream now.


(Canada) #33

@Stewart1, I’m back at the high school now, and as a test, I set up a peer to peer connection IE: http://www.grandstream.com/sites/default/files/Resources/peering_phones_with_HT813.pdf, and the same result…a half ring, and then stright to busy…so maddening.

Okay, as well, I programmed the FXS port, and hooked up an analog phone, and registered it with my FreePBX server. I made the extension 3847. I called the FXS port extension from another analog phone IE: 3847, and as it should, the analog phone rang at that extension. After that, as you suggested, I called *01 from the Analog phone connected to the FXS port, and I did indeed get the message, “The speed dial entry is empty.”

I then connected the FXS and FXO ports together…I then called *01 from an IP phone (Since I now had it set up as peer to peer), and it gave that half ring, and then rang busy…so all configurations to date have produced the busy signal…I’m at a loss…I have followed all configurations that have been provided to a T so I really do not think it’s a mis-configuration issue, plus the peer-to-peer test is REALLY straight forward, and that produced the half ring, and then a busy signal, so I’m really thinking it’s voltage unless you can suggest anything else…I’m hoping you can…


#34

I believe you have shown that it’s not a voltage issue. The FXS port is working and presumably outputs ~48V, so something else is amiss. Please post your present FXO settings and maybe I can spot something. If not, I hope that syslog on the HT will give a clue.


(Canada) #35

Okay, have a look at that peer 2 peer document I gave the link for. It produces the exact same result, as the initial settings you gave me for my FreePBX and HT813 for dialing 9901, I just wanted to see if a peer to peer-produced the same result…and it did. Anyways, my FXO settings are exactly as in that document, however, I will provide screenshots as well:

(As per peer to peer document)
http://www.grandstream.com/sites/default/files/Resources/peering_phones_with_HT813.pdf

IP Phone Settings (As per peer to peer document):

I am setting up the syslog server as we speak. I will have results for you soon.


#36

Great. Be sure to turn on Extra Debug and Send SIP Log in the HT. If the log is big, paste it at pastebin.freepbx.org and post the link here.


#37

Also, confirm that the Status page shows Idle for the FXO, not disconnected.


(Canada) #38

It does show idle right now. :slight_smile: I am capturing, you will have results soon.


(Canada) #39

Is there a way I can send you a PCAP privately, I have the HT813, send the syslog data to Wirelshark.


(Canada) #40

Never mind here is the Syslog Data:
https://pastebin.freepbx.org/view/490782a4