How to set up fop2 credentials

There are three extensions listed on the left side. set up one extension to log in with and was successful. I can now start to configure this.

Is this all documented in one place? I was unable to find a recipe for setting this up

Thank you for all your help

Pretty well all in the README file of the fop2 installation directory.

I was only looking on the web. Even this readme file doesn’t cover all the steps you put me through.

One last question :smile:

There is a button on the FreePBX admin/config.php page called Operator Panel. What is that supposed to be fore?

I believe that is used for iSymphony if you have it set up.

There is another tab along the top row for isymphony

It is a pointer to what you set up in “Advanced” , set the operator panel directory to ../fop2

If you want to reduce your exposure perhaps create

/var/www/html/index_custom.php

with the content of:-

<?php
	$basename = pathinfo($_SERVER['PHP_SELF'],PATHINFO_DIRNAME);
	$uri = (!empty($basename) && $basename != '/') ? $basename . '/fop2' : '/fop2';
	header('Location: '.$uri);

to admin the site goto

http://your.site/admin

(same goes to replacing fop2 with ucp if you so desire.)

Not getting what you mean by “Advanced” here. Is that a menu option somewhere?

perhaps I should have better said “advanced settings” which is conveniently under the “settings” tab at the top of your logged in admin screen. Come on dude, get inquisitive ! -:slight_smile: you might need to allow the readonly options at the top of that screen.

I did check there but I didn’t allow the read-only options. I changed the setting from “cxpanel” to “fop2” then the Operator Panel setting disappears from the startup screen mysite/admin/config.php. Then I found this:

I changed it to /fop2 but same result. Operator Panel disappears from from the startup screen.

Still working on it.

I guess you need to pay a little more attention, did i say ../fop2 or /fop2 ?

That you did but the other post I read said just /fop2

Did it work ?

More or less. The main site is set up with a letsencrypt certificate. fop2 won’t start but the URL is generally okay. I’ll have to fiddle with settings for apache.

BTW, I am in Cambodia. It is now about 11AM here. Time to get some other work done

In the README you didn’t read, their is help as to how to set up your ssl certificate locations be they letsencrypt or self generated (the self generated ones just wont work in any modern browser) , Please RTFM

Yes. I know that is there. I’m just commenting that is something I have to do after I finish some other work.

Thanks again

The instructions are here: http://www.fop2.com/docs/#HTTPSandSSL

I guess the problem here is that you are asking for help for fop2, maybe take that to fop2 fora because for me it all works as described, but I really did RTFM, all of them :wink:

I got it all working. Once I found the right doco to read… I just had to change fop2.cfg to point to the letsencrypt files.

SSLCertificateFile /etc/httpd/pki/webserver.crt
SSLCertificateKeyFile /etc/httpd/pki/webserver.key

The syntax is a bit different here. I had to change it to

ssl_certificate_file=/etc/httpd/pki/webserver.crt
ssl_certificate_key_file=etc/httpd/pki/webserver.key

Not so obvious but now it works.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.