FreePBX | Register | Issues | Wiki | Portal | Support

How-To Guide for Google Voice with Freepbx 14 & asterisk gvsip, Ubuntu 18.04

asterisk
pjsip
freepbx
Tags: #<Tag:0x00007fdf98b0b9e8> #<Tag:0x00007fdf98b0b880> #<Tag:0x00007fdf98b0b740>

(Tom Ray) #256

What source are you using for Superfecta? If you are getting generic CallerID (Houston, TX vs John Smith) that means either 1) They do not have proper CNAM setup and GV (whoever) is doing real time CNAM dips 2) They are not honoring the presented CallerID or 3) They are not doing real CallerID lookups.


(Dolfin) #257

Did I miss a step during setup? I’m getting errors when trying to save an IVR.

SQLSTATE[HY000]: General error: 1366 Incorrect integer value: ‘’ for column ‘ivr_ret’ at row 1::

Here’s screen shots and text dump of the error https://justpaste.it/6gsqs


(Rob Thomas) #258

Your MySQL version is too high. I’m pretty sure this is fixed in 14.

Edit: Nope, it looks like it’s not. Can you open a ticket please?


#259

NO! I actually seen this bug myself and meant to report it, here how to work around it.
(I think maybe its only an issue with the Open Source install, but if you follow my instructions it should setup just fine.)

First goto Admin -> System Recordings
create a simple system recording, dont matter what it is, you can delete it later if you want.
This is the recording I used it is a WAV file, that simply says (please leave a message, after download you will need to extract/uncompress the .WAV file)

plsmsg.tgz (146.6 KB)

Next goto IVR, and set it up Exactly like this (using your extension number), hit submit apply.

After the initial creation of the IVR, you can then edit things and it should edit just fine,

EDIT, The first thing you must do to every new entry is immediately set it to Return “YES” otherwise you will get Errors and it won’t work. (Return “No” is broken.)


#260

I will xrobau, I just hadn’t gotten to it yet, thanks.


#261

@nickm19371 this is resolved, modify your context line in the custom file to this:

context=from-pstn-e164-us

Then your CID will be 10 digit format and CID Superfecta and blocklist should behave normally.


(Dolfin) #262

I created the initial IVR without any digits pressed and it saved, went back in and added a another entry. Added 1 to the previous entry and destination ring group and got the same SQLSTATE error.


#263

ah, you might have luck monkeyin around with the order of adding entries, I know I got through everything with the way I did it, I will fire up a blank install incase I am forgetting a step.

I am currently filling this bug right now on the tracker.

@xrobau filled it here: https://issues.freepbx.org/browse/FREEPBX-17916 feel free to edit it, if I missed anything, first time reporting a bug here.


(Dolfin) #264

I did, they asked for a lot of stuff which I really don’t know how to get. Mostly a noob to all this.


(Dolfin) #265

Mine is #17908 in case it can be combined or something. Yours probably has all the info they need though. :slight_smile:


#266

@dolfin I was pretty sure you needed the second blank entry when adding options/menus, however after talking with a friend (we worked through this the other day)

I had figured out adding the system recording and setting the initial IVR, and my friend figured out setting the return to “YES”

What you have to try is every time you add an entry, you must set the Return to YES, Only then will the entry save without breaking.

This might not be desirable for your setup, but try it out for me and let me know if it then saves for you.


(United States) #267

@xekon I really appreciate all your hard work.
I followed the guide and managed to get FreePBX running as it should. However registration won’t go through.
I’m getting a “WARNING[1139]: pjproject:0 <?>: SSL 6 [SSL_ERROR_ZERO_RETURN]” in asterisk logs. And I only see one way traffic in wireshark.
Do I need to forward ports on the router for this setup to work? (I’m behind two routers. double nat?!)

Thanks again.


#268

Did you set the Stun address, chances are with double NAT you will need it.

Settings -> Asterisk SIP Settings
 "General SIP Settings"-Tab
   NAT Settings, External Address, click detect network settings
   Stun Server Address: stun.l.google.com:19302   (Optional, usually)

Then try a reboot or two and test it out.

If that dont work you can goto Settings -> Asterisk Sip Settings, then PJSIP tab, and at the bottom, these settings could help possibly, but I have not tried them:

Forwarding something might also fix it, but I have not yet tried setting this up behind a double NAT, good luck, hope you get your google voice working :slight_smile:


Firewall Questions
(United States) #269

@xekon Thanks for your swift reply. It did not resolve the issue so far. Will have to play with forwarding ports. Will report on success.


(Dolfin) #270

This worked and I got my IVR set up. Now I can block those pesky scam calls.

Another question, my CDR report is blank. Where do I begin fixing this?


Strike that, reverse it… I followed the Configure ODBC in the wiki and got it up and running.
https://wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+Ubuntu+Server+14.04.2+LTS#InstallingFreePBX13onUbuntuServer14.04.2LTS-ConfigureODBC

time to run a backup. :slight_smile:


#271

cool, glad that worked for you, and yeah the ODBC is required for the CDR, glad you got that squared away too.


#272

Good, glad you got your caller ID working, The Google voice Trunk DOES provide Names when they are available, so make sure to use it as a Data Source in your CID Superfecta, atleast it has been in my testing.

Also for frequently contacted people you can go to Admin -> Asterisk Phonebook
and enter your important contacts, family, friends etc, and use the Phonebook as a lookup source, like I do.

The Location data such as (Houston, TX), comes from the Telco Data lookup source, you would want to make that the last lookup source in your CID superfecta, First match wins, here is how mine is currently setup:

Admin -> CID Superfecta:


#273

@AronEinhorn are you able to test this on a different machine that is not behind a double NAT, that way you could rule out other possible issues being the culprit.

Then once you have that setup, you could try the double NAT again, and if it does not work then you can be fairly confident that the double NAT is the reason for it not working.


(United States) #274

@xekon Will test it later, and report findings. Thanks again.


(Jimbolaya) #275

I went through How-To Guide for Creating Oauth credentials for Google Voice gvsip to get the Oauth tokens and got them into my conf file.

I’m not sure if this is the right place to ask, but I’m getting Fatal response '403' when asterisk tries to register:

From: <sip:gv7777777777@obihai.sip.google.com>;tag=********-****-****-************
To: <sip:gv7777777777@obihai.sip.google.com>
Call-ID: ********-****-****-****-************
CSeq: 33131 REGISTER
Authorization: Bearer token="****.*****************l-************************_******************************************-******************-*********_**_*****", username="gv7777777777", realm=""
Contact: <sip:7777777777@192.168.64.92:5161;transport=TLS;line=bywksbx>;obn=gvsiptest
Expires: 3600
Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER
Supported: path, outbound
Max-Forwards: 70
User-Agent: FPBX-14.0.3.6(15)
Content-Length:  0


[2018-07-25 14:13:21] VERBOSE[831] res_pjsip_logger.c: <--- Received SIP response (392 bytes) from TLS:64.9.243.172:5061 --->
SIP/2.0 403 Forbidden
Via: SIP/2.0/TLS 192.168.64.92:5161;rport=34779;branch=*****************7-****-****-****-********f68;received=164.23.22.17;alias
To: <sip:gv7777777777@obihai.sip.google.com>;tag=05073732
From: <sip:gv7777777777@obihai.sip.google.com>;tag=********-****-****-************
Call-ID: ********-****-****-****-************
CSeq: 33131 REGISTER
Content-Length: 0


[2018-07-25 14:13:21] WARNING[832] res_pjsip_outbound_registration.c: Fatal response '403' received from 'sip:obihai.sip.google.com' on registration attempt to 'sip:gv7777777777@obihai.sip.google.com', stopping outbound registration
[2018-07-25 14:13:21] WARNING[831] pjproject:                      SSL 6 [SSL_ERROR_ZERO_RETURN] (Read) ret: 0 len: 32000

I’ve gone through the pjsip_custom_post.conf file several times and re-aquired the refresh token. I’m somewhat at a loss as to where to look next. I feel like I’m missing something obvious.