FreePBX | Register | Issues | Wiki | Portal | Support

How-To Guide for Google Voice with Freepbx 14 & asterisk gvsip, Ubuntu 18.04

asterisk
pjsip
freepbx
Tags: #<Tag:0x00007fdf94516640> #<Tag:0x00007fdf945164b0> #<Tag:0x00007fdf94516348>

#236

oh, OK, well you might want to put some numbers on the end of that

then like I said to nick M, make sure all 3 match

client_uri=sip:dolphin48237273@obihai.sip.google.com

contact_additional_params=obn=dolphin48237273

username=dolphin48237273

you dont wanna use a usernamed that somebody somewhere might already be using, or you will get a rejected message like that, adding numbers to the end ensures its unique.


(Dolfin) #237

Actually I don’t know why. I used ‘dolfin’ in a lot of places.


#238
[2018-07-22 22:43:22] ERROR[979] chan_phone.c: Unable to load config phone.conf
[2018-07-22 22:43:22] ERROR[979] pbx_dundi.c: Unable to load config dundi.conf
[2018-07-22 22:43:22] ERROR[979] chan_unistim.c: Unable to load config unistim.conf
[2018-07-22 22:43:23] ERROR[979] app_amd.c: Configuration file amd.conf missing.

Only errors that show up after a reboot.


#239

@Lutiana Nothing out of the ordinary there, it kinda sounds like part of the pjsip_custom_post.conf is missing.

Maybe try deleting everything in that file, then copy and paste the example from here again and fill in the blanks, it might be a formatting error that is making the file truncate or something else odd.

EDIT: make sure you have your client id, secret, and token saved someplace.


(Dolfin) #240

HAH! That was it!

Placed a test call successfully to an ANI and got my number back.

Now to figure out how to configure my Grandstream GXP2160


#241

No problem, happy you got your FreePBX google voice setup working.


#242

So my pjsip_custom_post.conf is actually empty, however all the setting above are in the pjsip_custom.conf.


#243

hmmmm, it might work either way, but to be safe I would just delete everything in pjsip_custom.conf

and start a NEW copy paste into pjsip_custom_post.conf, and then just fill in the 7 fields that normally need changed.


#244

So you’re saying to move everything out of pjsip_custom.conf? It should be blank?


#245

Yes, correct! mine is empty, so if you followed this guide, then yours would be too :slight_smile:

@billsimon actually said that for these 2 lines to work:

debug=true
keep_alive_interval=90 

they need to be in the pjsip_custom_post.conf file, that is what gets them into the FreePBX [global] section


#246

Well the reason I added the stuff to the “wrong” file was because the post one was empty when I started, and there was stuff in the other one, so I figured that was the place to add it.

This is RasPBX if that makes any difference.


#247

OH! your modifying the guide to fit RASpi

Dont empty that file then, only remove all the stuff that you added to it, the other existing entries that were there before you edited it should be fine.

But yes, you should use the pjsip_custom_post.conf file

EDIT: if that does not work then you can put only these two lines into pjsip_custom_post.conf file

debug=true
keep_alive_interval=90

and put the rest into pjsip_custom.conf file


#248

Got it!

That is exactly what I did, removed the added stuff, and copied the stuff from the guide into the post file with the various changes needed for my account.


#249

Hope you can get this going, I have not tried it on a RasPI yet myself.


#250

sigh no change. Still getting:

ERROR[1042]: chan_pjsip.c:2225 request: Unable to create PJSIP channel - endpoint 'gvsip1' was not found

#251

I might need to get help from some other FreePBX people to figure this one out… let me think about it for a bit.

The reason I thought there was a problem with your _custom file is because the endpoint itself is declared in that file with this block:

[gvsip1]
type=endpoint
context=from-pstn-e164-us
disallow=all
allow=ulaw
allow=opus
outbound_auth=gvsip1
outbound_proxy=sip:obihai.telephony.goog:5061\;transport=tls\;lr\;hide
aors=gvsip1
direct_media=no
ice_support=yes
rtcp_mux=yes
media_use_received_transport=yes
outbound_registration=gvsip1

and so in the trunk creation in the FreePBX GUI you set the Custom Dial String (which points to that block/endpoint)

Custom Dial String: PJSIP/$OUTNUM$@gvsip1

So to me it seems you setup the trunk, and its looking for gvsip1 but its not seeing it anywhere, so to me it seems like your _custom file is not loading or is broken.

Hopefully somebody else comes along that can help, and if I think of anything I will let you know…


#252

Try this put these 2 lines into pjsip_custom_post.conf (the only 2 lines in that file)

debug=true
keep_alive_interval=90

Then put the remaining blocks into pjsip_custom.conf

but honestly this should not matter… just one more thing I can think of to try.


#253

Yeah, I kind of guessed that relationship, which is why I checked my spelling about 30 times. The declaration is definitely there, and it definitely matches your guide word for word and in the same case. As does the custom dial string.

I am fairly sure the oauth is working too, as the first go around I mistyped the clientID and the secret and got a ton of errors in the log at startup. They all went away when I fixed these.

I did try moving the stuff around again in the two conf files to no success. Still getting the same error about the gvsip1 endpoint not found.


Please help me work out what would cause an endpoint in pjsip_custom.conf to not be found
#254

I would start another thread, because I think you are right. (about the Oauth working properly)

I would label it something like “Help, what would cause endpoint declared in pjsip_custom.conf to not load”

because I am not even sure where to look. I am pretty Tech Saavy, but I actually have very limited experience with FreePBX compared to somebody that is a Developer for it all day every day, in fact this problem may go beyond FreePBX and is actually an asterisk issue, but the people that work on these things day in and day out might spot your problem better than I can.

and you can point to this thread as being what your trying to setup too.


(Nick M.) #255

One thing that I have noticed that seems to be different from GVGW is the caller ID. For example if I would get a call from one of my reps at Apple, the caller ID would read Apple Inc.; however, now it just displays the number for both the name and the number (this only seems to happen with 800 #'s). Local numbers are a bit different, as I used to get the name of the caller (Smith, John) now I only seem to get the city and state (Houston, TX).

Is there a way to fix this, or is there a service (preferably free or relatively inexpensive) that would allow me to regain the name of the person calling me?

I have already updated the context line to fix the CID Superfecta and that seemed to fix the issue with not having caller ID at all, but I would really like to get the names back–if possible. If it’s not, I can learn to live with it-- after all, Google Voice has saved me at least $70/month for the last 2 years. :grin: