High CPU usage from schedtc.php

Good Afternoon, I am running FreePBX with about 20 CHAN_SIP clients and one IAX trunk.

I just discovered an issue while diagnosing some call quality reports. For about a month now, CPU usage has been pinned above 100 percent. According to the dashboard charts, it happened all of the sudden, with the CPU never going above 30% previous to this date.

I ran ‘top’, and found this:

22646 asterisk 20 0 405040 30240 10744 R 100.0 0.8 68221:46 php

I then ran ‘ps aux|grep php’

asterisk 22646 99.9 0.7 405040 30240 ? R 2018 68222:12 php /var/lib/asterisk/bin/schedtc.php

I am now pretty stuck. I tried restarting asterisk, but that didn’t do any good. At the time of testing, there are currently no active calls.

Does anyone have any ideas on how I can further diagnose (and resolve) this issue?

Thank you in advance.

Run that file manually and see what it outputs

It did not appear to output anything, though I may not be running it correctly. I just typed /var/lib/asterisk/bin/schedtc.php into the command line.

did it complete? if so then see if its using 100% CPU

Yes, still using 99.8% CPU

You ran the command. Did it complete? If it did complete and is finished how is it using 100% cpu.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.