Audio Drops with multiple VMs

Hi guys,

A while ago I decided to run more VMs of FreePBX. I’m running on 27 VMs right now, and now I’ve got some small audio drops. And that is really annonying me. When I run only 1 VM on lower specs, there is nothing going on with the audio. But then I’m running 27 VM’s (27x the specs of 1VM) and it suddenly gives audiodrops.

I’m getting sick of the bs in the following post, because everyone is just saying something. No one is actually coming with a solution. Only workarounds? But this is a bug. And a serious one. Take us serious, and don’t ignore it because you guys are getting commercial.

Reffering to posts:



Exactly the same problems. 1VM, no problem. If I run 27 (with 27x the specs) I’m getting audio drops with high cpu.

I want to report this as a commercial-module bug.

Greetings,
Mark

I don’t think it’s safe to assume a linear scaling relationship. I would definitely look into resource exhaustion on your VM platform.

We are going to ask the same thing we’ve asked in those threads and as you can see in those we having gotten direct answers. So please break the cycle and provide the requested information.

Describe the host resources, describe the individual VM resources. If they are all a clone of the original then they’ll all have the same. How many users are on them? What else is being done on them, commercial modules, recording, etc?

Just keep in mind that this is not a commercial bug. The fact that someone decides to spin up a VM host and load a bunch of FreePBX instances isn’t something that is covered by commercial support. Now if you are selling and/or marketing FreePBX hosting and services then I would look at the Partner Program as that provides higher level support due to the agreements in place.

If you feel that it’s an issue then you can bring it up with commercial support. If you read (i’m sure you did but maybe you just skimmed it) the thread you will see we have limited resources to deal with third party cloud provider systems that are not our own, who are not our partners or don’t pay for support. Sorry but there is only so much I can do for free on community forums and I’ve exhausted my own ability to brain asking for data that isn’t even provided in this fork of three other threads.

You have the strange desire/obsession to start a new thread with zero. Nothing. No. Information. Do you know what happens when our own support team passes issues on to my team with no information? We tell support, “I can’t work on this?! there’s no data points”. Support then goes “oh man I am sorry here’s the data”. They don’t go out and open another ticket to say “you aren’t listening to me in the original ticket!!”. Yet here we are, where you reference threads where I ask for and point out information that helps me and my team debug this…But wait. I’m not the only one asking for this information!!! Two other community members ask for the same information. Yet you open his thread and provide nothing! This is borderline trolling and it’s absurd.

What even makes you think this is related to commercial modules? It doesn’t matter because you don’t want to provide information. You know what? On second thought. This thread really is trolling and here’s why

  1. You opened an account today to post this single message

  2. You start a new thread to complain about how three other threads are being treated, the newest one is still active and people are still waiting on information

  3. You call “waiting on information” BS

  4. Then you open THIS thread and provide none of the information that the other three reference, you just tell us you are running 27 vms. Are you running them on a pickle? a sandwich? a dog? I have no idea! I’ll tell you what. If I put 27 vms on my dog he’d be pretty annoyed with me and they’d probably all have terrible audio quality issues (along with random whines!)

  5. Finally you add “I want to report this as a commercial bug” without any evidence to say it is commercial, because you provided NO evidence to begin with! Did you read the newest thread you linked to? Did you? Did you REALLY?? Did you notice the user has issues with one script that is NOT COMMERCIAL (tcsched). That’s as far as we got because people got upset that I would say that Sangoma (a $100 million dollar publicly traded company) cares about it’s own cloud infrastructure first… how dare us?

Thanks for participating in the forums. If you want to report a “commercial module bug” about a random module that you won’t say what it is causing high cpu then you are free to use our support ticketing system. It’s free for commercial modules as long as you are in a renewal period. Since you have one (I assume?) it’s free for you. If you don’t have one you can buy support blocks and we will gladly help you with running your cloud infrastructure. I sure hope you provide them with information though!

3 Likes