Graphql; Requested URL not found on this server

Hi everyone! I am looking for maybe some tips or places I can look to try and solve this issue I am having. I am trying to utilize graphql with freepbx. I want to leverage it to make some sweet dynamic phone tree diagrams for documentation.
I have created a machine to machine app. I am not using CURL to make the request for a token, for testing. I am using Powershell with “Invoke-webrequest”. The problem I am running into is I am getting a 404 not found for the token URL…well any of the URL’s return a 404. I have tried using insomnia to test as well and same problem, a 404 error.
I followed this post Not Found The requested URL was not found on this server. -FREEPBX
I enabled the webenabled=yes in manager.conf. Maybe this was a dumb thing and I don’t understand what its for :stuck_out_tongue:
Any help is totally appreciated!

I think I got this working actually. Not sure I understand why, but when I use the URL “” I get the 404.
but replacing the port number with “443” instead finds the proper resource and I can generate my tokens just fine.

Hmmm. It’s not what we expected.

The goal is to distinct admin URL of the API URL

I created a JIRA ticket for that.

1 Like

Let me know if you had any questions, or anything I can provide.

Ok I will do.
But I think I’ve got all information to fix it. Thanks.
I know where the issue come from. It’s a good start :slight_smile:

not gonna lie - not sure if the graphql supports https…

HTTP://{{server}}/admin/api/api/gql has always worked for me.

also, dont you want the Token URL (oauth2) and not Authorize?

That works now.
I fixed it today.
Just wait the next sysadmin version on EDGE with this fixe.

That works on both.
If you decide to don’t give any access to admin GUI on this URL, then user API URL dedicated for that with API port.
This port doesn’t allow admin GUI.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.