Not Found The requested URL was not found on this server. -FREEPBX

Hey Folks .
have freepbx 12
asterisk 13
##########
enabled http and AMI
i can login using AMI over telnet .
but not over http

htttp:.x.x.x:8088/asterisk/rawman?action=Login&username=admin&secret=secret5
always give me :
Not Found

The requested URL was not found on this server.

Asterisk Server

#############################
vps1460851189*CLI> http show status 
HTTP Server Status:
Prefix: /asterisk
Server Enabled and Bound to 0.0.0.0:8088

Enabled URI's:
/asterisk/httpstatus => Asterisk HTTP General Status
/asterisk/phoneprov/... => Asterisk HTTP Phone Provisioning Tool
/asterisk/static/... => Asterisk HTTP Static Delivery
/asterisk/ws => Asterisk HTTP WebSocket

Enabled Redirects:
  None.
vps1460851189*CLI> 
####################################
[[email protected] ~]# cat /etc/asterisk/manager_additional.conf 
;--------------------------------------------------------------------------------;
;          Do NOT edit this file as it is auto-generated by FreePBX.             ;
;--------------------------------------------------------------------------------;
; For information on adding additional paramaters to this file, please visit the ;
; FreePBX.org wiki page, or ask on IRC. This file was created by the new FreePBX ;
; BMO - Big Module Object. Any similarity in naming with BMO from Adventure Time ;
; is totally deliberate.                                                         ;
;--------------------------------------------------------------------------------;
[cxpanel]
secret = cxmanager*con
deny=0.0.0.0/0.0.0.0
permit=127.0.0.1/255.255.255.0
read = system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
write = system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
[xp10]
secret = xp10
deny=0.0.0.0/0.0.0.0
permit=188.6.19.0/255.255.255.0
read = system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
write = system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
webenabled = yes 
[[email protected] ~]# cat /etc/asterisk/http_additional.conf 
;--------------------------------------------------------------------------------;
;          Do NOT edit this file as it is auto-generated by FreePBX.             ;
;--------------------------------------------------------------------------------;
; For information on adding additional paramaters to this file, please visit the ;
; FreePBX.org wiki page, or ask on IRC. This file was created by the new FreePBX ;
; BMO - Big Module Object. Any similarity in naming with BMO from Adventure Time ;
; is totally deliberate.                                                         ;
;--------------------------------------------------------------------------------;
[general]
enabled=yes
enablestatic=yes
bindaddr=0.0.0.0
bindport=8088
prefix=asterisk
[[email protected] ~]# 

any help ???

What is the output of:

manager show settings

vps1460851189*CLI> manager show settings

Global Settings:

Manager (AMI): Yes
Web Manager (AMI/HTTP): No
TCP Bindaddress: 0.0.0.0:5038
HTTP Timeout (minutes): 60
TLS Enable: No
TLS Bindaddress: Disabled
TLS Certfile: asterisk.pem
TLS Privatekey:
TLS Cipher:
Allow multiple login: Yes
Display connects: No
Timestamp events: No
Channel vars:
Debug: No
vps1460851189*CLI>

This is your problem:

Web Manager (AMI/HTTP):    No

add webenabled=yes to the general section of manager.conf

thanks so much but was wondering is there a place where we enable it form freepbx GUI ?

Not that I know of.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.