FreePBX FaxPro Will Not Send New Fax

Hello Everyone,

I’m running Asterisk (Ver. 13.0.1) with FreePBX 6.12.65-22 and while trying to send a fax via the UCP (12.0.0beta40) utilizing Fax Configuration Professional 12.0.30, faxes will not send. Also, they do not appear in the: “Outgoing” folder nor do they appear in the: “Failed” folder or “Sent” folder and there is nothing in the Asterisk log-files that even indicates a fax transmission was attempted…they pretty much just dissappear. However, if I forward a fax from my “Sent” folder (from when this setup worked) then the fax completes successfully. I’ve rebooted our system, as well as: > amportal chown, amportal a ma refreshsignatures and amportal a reload but faxes will still not work. Any ideas on what might be causing this?

P.S. Saw this in another post and thought I should try: amportal a dbug. Here is the output when I try to send a fax:

==> /var/log/asterisk/freepbx_dbug <==
2014-Dec-04 13:52:11 /var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:245
[NOTICE]: Undefined index: coversheet

2014-Dec-04 13:52:11 /var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:254
[NOTICE]: Undefined index: destination

2014-Dec-04 13:52:11 /var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:254
[NOTICE]: Undefined index: files

2014-Dec-04 13:52:11 /var/www/html/admin/modules/faxpro/Faxpro.class.php:140
[WARNING]: Invalid argument supplied for foreach()

==> /var/log/asterisk/freepbx.log <==
[2014-Dec-04 13:52:11] [INFO] (enc/faxpro_background.php:51) - Critical Information Missing. Stopping

Keep in mind that I have not changed anything from when this setup previously worked. For example, I see something about an “Undefined index: coversheet” but when I go to: “Settings >> Fax Configuration” in the “FreePBX Administration” portal and click “Preview” next to the “Preview Cover Page” I am able to view my coversheet template.

Did you say Asterisk 13? Try switching to Asterisk 11 and let me know if you still have problems.

Faxing is broke in Asterisk 12 and 13 currently. Go back to Asterisk 11

Thank you both for the prompt reply! Before I switch back to Asterisk 11, do either of you foresee a problem in my other issue: [UCP Call History Not Able To Play Outbound Call Recordings or Download Them][1] which goes along with Issue ticket: FREEPBX-8233 and switching back to Asterisk 11? Mr. Andrew Naggy had been helping me with this and what I have gathered from him is that my CDR has been corrupted by Asterisk 13. So I was concerned going back to Asterisk 11 might make things worse all over…but hopefully I’m wrong.
[1]: UCP Call History Is Not Able To Play Outbound Call Recordings or Download Them

You need to go to Asterisk 11 for production stuff. 13 is experimental

Now running Asterisk (Ver. 11.14.1) and the issue is still present. Here is the output of amportal a dbug:

==> /var/log/asterisk/freepbx_dbug <==
2014-Dec-04 15:48:13 /var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:245
[NOTICE]: Undefined index: coversheet

2014-Dec-04 15:48:13 /var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:254
[NOTICE]: Undefined index: destination

2014-Dec-04 15:48:13 /var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:254
[NOTICE]: Undefined index: files

2014-Dec-04 15:48:13 /var/www/html/admin/modules/faxpro/Faxpro.class.php:140
[WARNING]: Invalid argument supplied for foreach()

==> /var/log/asterisk/freepbx.log <==
[2014-Dec-04 15:48:13] [INFO] (enc/faxpro_background.php:51) - Critical Information Missing. Stopping

I am having the same problem. Switched from 12 to Asterisk 11.14.1 and can’t send faxes.


[2014-Dec-04 15:25:09] [PHP-NOTICE] (/var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:245) - Undefined index: coversheet
[2014-Dec-04 15:25:09] [PHP-NOTICE] (/var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:254) - Undefined index: destination
[2014-Dec-04 15:25:09] [PHP-NOTICE] (/var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:254) - Undefined index: files
[2014-Dec-04 15:25:09] [PHP-WARNING] (/var/www/html/admin/modules/faxpro/Faxpro.class.php:140) - Invalid argument supplied for foreach()
[2014-Dec-04 15:25:09] [INFO] (enc/faxpro_background.php:51) - Critical Information Missing. Stopping

Brad your issue is completely different and related to the fact you aren’t sebding any files. Probably related to you trying to send a huge 4.5 mb doc

How is Bradbpw’s issue different from mine…they are the exact same errors? Or am I overlooking something?

Because in another thread he says he can send fine.

Even smaller files are no longer working. Sorry, forgot to update that thread. I just tried to send a 170Kb file and received the same error. I was able to send faxes two days ago.

[2014-Dec-04 16:32:29] [PHP-NOTICE] (/var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:245) - Undefined index: coversheet
[2014-Dec-04 16:32:29] [PHP-NOTICE] (/var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:254) - Undefined index: destination
[2014-Dec-04 16:32:29] [PHP-NOTICE] (/var/www/html/admin/modules/faxpro/ucp/Faxpro.class.php:254) - Undefined index: files
[2014-Dec-04 16:32:29] [PHP-WARNING] (/var/www/html/admin/modules/faxpro/Faxpro.class.php:140) - Invalid argument supplied for foreach()
[2014-Dec-04 16:32:29] [INFO] (enc/faxpro_background.php:51) - Critical Information Missing. Stopping

Ahhh, just for fun I want to take a stab at it, but does Bradbpw’s issue have something to do with one or more of the settings under: “Resource Limits” in the /etc/php.ini file? Those default settings occasionally crept up on me with problems and it always seemed to happen on Mondays.

Nevermind, didn’t refresh my browser in time.

Ah I see. There are two things going on here. There’s a bug in faxpro and there’s a bug in res_fax in asterisk 13. Tony and Preston have assumed this is related to the res_fax asterisk issue but it’s not. I can have a fix for this particular issue in an hour. However you may still be affected by the asterisk 13 issue as well (because it might be in asterisk 12. Have not checked yet)

Again this issue is unrelated to res_fax.

So as long as we stay on Asterisk 11 then we should be okay?

This has nothing to do with Asterisk…

Okay…I was just confused on why you stated: [quote=“tm1000, post:14, topic:25944”]
However you may still be affected by the asterisk 13 issue as well (because it might be in asterisk 12. Have not checked yet) [/quote] If our issue has nothing to do with Asterisk then why would you make that statement? I interpret that statement as we may still be affected by the Asterisk 13 issue (even though we are running Asterisk 11). As in, this issue may have carried over when we did the asterisk-version-switch, not to mention this whole ordeal supposedly has nothing to do with Asterisk (therein lies my confusion). Just really confused on why that statement was made if it doesn’t pertain to us or this issue.

I think he was referring to the bug in res_fax in Asterisk 13, which this issue is not about.

1 Like

Okay, not trying to pick on anybody I just want to make sure I understand completely. Thanks to everyone for the help and I look forward to the module fix.

No no. I didn’t think you were picking on anyone. Just trying to clarify as this thread got a little confusing for a while on both sides of the fence.

Anyways checkout 12.0.31 for this fix. Sorry about that. (for you coders out there it was the difference between “this” and “$this”)

Please note that UCP and it’s related modules are in rapid development and beta. This is why I encourage you to checkout the rollback feature in module admin if you need something to work because it’s mission critical as you can come here and tell us it’s broken and then just rollback so your user base is happy. Thats the whole reason I wrote rollback… because I knew UCP ish issues could/would be a nightmare.