FreePBX 14 - Can't send FAX through FAXPro anymore

After upgrading to FreePBX 14 (Distro) I can’t send FAXes through UCP anymore - it gives the following:

If you click on the PDF Icon to look at it, you get “File not found” on a blank web page - Where does it go when it is uploaded? I am guessing the folder either doesn’t exist, or it’s permissions are borked.

Also went back and looked - The file is at least being uploaded - if you click the link after you upload it, it shows - so it looks like the handoff to Asterisk is where it is dying.

Anybody else seeing this?

Just went and tried to look through the code to see where it is failing - looks like it’s all obscured by Zend I am assuming.

You used the upgrade scripts from 13 to 14 right? This works on a clean install. It’s something with the upgrade.

Yeah, this was an upgrade - How can I fix it?

Hi!

Hopefully this was not done on a Production system…

Did you try restoring permissions with fwconsole chown just in case it’s something as simple as that?

Good luck and have a nice day!

Nick

Yup - that was my first thought too - but it does actually get uploaded - it’s the handoff to the Sending part that dies.

fwconsole chown works perfectly and throws no errors.

CDR’s are borked too - I am going to try a Backup/Reload/Restore.

Hi!

As in no new data gets added but you can still view entries which were added before the upgrade?

If so, read this

(By at all I actually meant is there anything new added to it globally without any possible filtering done in UCP since Jared was consulting the CDRs from there. I wanted him to try from the Dashboard to see if anything got added at all since the upgrade…)

Good luck and have a nice day!

Nick

Thanks - that fixed the CDR’s - In looking through the logs on the FAXing, it looks like the conversion is never happening on the Send:

[2017-08-21 07:57:37] ERROR[13242][C-00000003]: res_fax.c:2699 sendfax_exec: access failure. Verify ‘/var/spool/asterisk/tmp/fax-1503323855491.tif’ exists an d check permissions.

I checked and the folder didn’t exist - so I created it and chown’ed it to Asterisk and tried again - It still gives the same error. I think it’s failing on the PDF-2-TIF conversion - I am going to look for that.

Hi!

You are welcome and that’s good news!

From this thread

the conversion in the opposite direction was done with tff2pdf…

Maybe the conversion the other way is done with pdf2tiff and it’s somehow missing?

Good luck and have a nice day!

Nick

I think it does it with Ghostscript actually - there is no tiff2pdf anywhere on the system - or any pdf2tiff either - Schmooze folks - what do you use to convert so I can look at that?

It’s obscured code, but that is definitely where it is failing:

-- Executing [[email protected]:2] System("Local/[email protected];1", "/var/lib/asterisk/bin/faxpro_helper.php --faxid="1503325353136" --stationid="5059674952" --status="In Progress" --channel="Local/[email protected];1" ") in new stack
-- Channel SIP/vitel-outbound-0000000e joined 'simple_bridge' basic-bridge <7e7bd1ca-5519-4e60-b149-e30aabd00b34>
-- Channel Local/[email protected];2 joined 'simple_bridge' basic-bridge <7e7bd1ca-5519-4e60-b149-e30aabd00b34>
-- Executing [[email protected]:3] SendFAX("Local/[email protected];1", "/var/spool/asterisk/tmp/fax-1503325354868.tif,zf") in new stack

[2017-08-21 08:22:37] ERROR[30119][C-00000011]: res_fax.c:2699 sendfax_exec: access failure. Verify ‘/var/spool/asterisk/tmp/fax-1503325354868.tif’ exists and check permissions.
== Spawn extension (send-fax, s, 3) exited non-zero on ‘Local/[email protected];1’

Hi!

I find that surprising, it is possible they changed how they convert from tiff2pdf but I would be surprised they did…

Do you have the package libtiff-tools installed on your system and which version of it, the el6 or the sng7 one?

We only see the part where they provide the .tif to be sent to Asterisk, not how it is generated unfortunately…

Good luck and have a nice day!

Nick

Both the 32-Bit and 64-Bit libtiff is installed:

Name : libtiff
Arch : x86_64
Version : 4.0.3
Release : 27.el7_3
Size : 483 k
Repo : installed
Summary : Library of functions for manipulating TIFF format image files
URL : http://www.remotesensing.org/libtiff/
License : libtiff
Description : The libtiff package contains a library of functions for manipulating
: TIFF (Tagged Image File Format) image format files. TIFF is a widely
: used file format for bitmapped images. TIFF files usually end in the
: .tif extension and they are often quite large.
:
: The libtiff package should be installed if you need to manipulate TIFF
: format image files.

but a locate shows no tiff2pdf or pdf2tiff - do you know the actual name of the executable?

Hi!

IIRC from when I had to search for that info when I posted in that thread I referred you to, tiff2pdf… This was with FreePBX 13 but I don’t expect this to have changed with FreePBX 14…

As for going the other way, it looks like this package usually has fax2tiff and raw2tiff but I don’t know if that is what the commercial faxing module uses…

Good luck and have a nice day!

Nick

You need libtiff-tools. It is not installed. @Marbled asked you to check for ‘libtiff-tools’ instead you checked for ‘libtiff’

[[email protected] ~]# tiff2pdf
tiff2pdf: No input file specified.
LIBTIFF, Version 4.0.3
Copyright (c) 1988-1996 Sam Leffler
Copyright (c) 1991-1996 Silicon Graphics, Inc.

[[email protected] ~]# yum provides tiff2pdf
Loaded plugins: fastestmirror, versionlock
Determining fastest mirrors
libtiff-tools-4.0.3-25.el7_2.x86_64 : Command-line utility programs for manipulating TIFF files
Repo        : sng-base
Matched from:
Filename    : /usr/bin/tiff2pdf



libtiff-tools-4.0.3-27.el7_3.x86_64 : Command-line utility programs for manipulating TIFF files
Repo        : sng-updates
Matched from:
Filename    : /usr/bin/tiff2pdf



libtiff-tools-4.0.3-27.el7_3.x86_64 : Command-line utility programs for manipulating TIFF files
Repo        : @sng-updates
Matched from:
Filename    : /usr/bin/tiff2pdf



[[email protected] ~]#

We have a winner - Yes, libtiff-tools once installed and now I am once again sending!

Thanks!

Greg

I am just looking on my Box I upgraded a week ago and it was upgraded. The script does a blanket yum update at the end so it should of been updated. Did you have the el5 version of it still installed?

Did you script error out at any point?

I watched the script - it threw quite a few errors, but the were moving by pretty quickly - but it never stopped - it said it was successful all the way through.

Out of an upgrade that huge, two little errors is AMAZING!

We are really liking it and all the new installs are going with it - we will wait another week or two and make sure we are not missing anything else and then start updating client machines.

Sorry I forgot we tracked this down last week with our -15 release of the upgrade RPM. The issue was redhat moved the tools we use from libtiff to libtiff-tools so on a upgrade it upgraded libtiff but never installed libtiff-tools as that did not exist in el6. So we explicitly install libtiff-tools now in the upgrade.