FreePBX and Application -> Call Recording

Hello to all!
Can’t add even one entity in Application → Call Recording. When I fill the fields and click “Submit” button - nothing happens. Here is a screenshot of how it looks:

Just in case I’ve tried to run:

fwconsole chown
fwconsole restart

and after fwconsole restart I saw this:

`Running FreePBX shutdown...In Self_Helper.class.php line 213: 
 Unable to locate the FreePBX BMO Class 'Array'A required module might 
be disabled or uninstalled. Recommended steps (run from the CLI): 1) 
fwconsole ma install array 2) fwconsole ma enable array`

Understanding some kind of nonsenseness of my actions, nonetheless I’ve tried to do as it was advised in error message and got next:

`fwconsole ma install arrayUnable to install module array: - Cannot find module`

I don’t know if it’s somehow related to the issue with Call Recording, but nevertheless I want to fix it too.
Will much appreciate any help!

I have the same problem, but different symptoms.
FreePBX with all modules up to date.
Call recording module 14.0.11
Asterisk 13.22.0

I can’t create any “Call recording” entities either, but I don’t get errors for missing modules when I restart from the console.

Looks like this was reported but the bug was closed (in error I believe): FREEPBX-18899

I have reopened that issue and linked back to this thread.

If it’s truly a known bug - hope, it would be fixed soon.

That’s, actually, is not a module, but somehow related to PHP and variables types I believe.

It’s fixed, now, if you install the “Edge” track callrecording module, either from the console with:

fwconsole ma --edge upgrade callrecording

or else follow this guide and do it from the GUI.

@michthom oh! Great thanks, man. It worked. I’m able to add a Call Recording now! Just great!

But the trouble with:

is still there…

The error message is unrelated to the Call Recording module, I suggest you raise that as a separate issue, but the closest I could find suggests there’s a problem with your system, so you might need to reinstall FreePBX to ensure you have a clean set of modules?

“FreePBX BMO Class” error

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.