Forward an incoming call to External Auto Attendant


(Canada) #1

This client want’s to send some calls that come in to another office’s IVR, then dial an extension to leave a voicemail there. I am trying to figure if this can be done via Misc Destinations, or a custom extension ? And how?

Thanks in advance!


(Dave Burgess) #2

What differentiates the calls?

??? - What do you mean by “another office’s”? Do you mean like a competitor, or are you trying to get a multi-tenant thing going?

If the call has come in to an IVR, who’s dialing?

I’m sure it can be, I think you need to explain what you’re really trying to do.


(Canada) #3

The calls that come in are answered by someone who then wants to forward it, by a case by case scenario.
They have teamed up with another office that is not on the same phone system, but that person is doing their marketing I believe.
The person that answers the call wants the ability to forward that call to in their words, an extension, that will in turn dial the other offices backdoor number, and hopefully have it automated to then dial the specific persons extension.


(Dave Burgess) #4

If the person answering the phone wants to transfer the call, they can use the ‘transfer’ function (either a transfer button on the phone or the *2 option, IIRC). If they want to forward their phone to another number, you can do that for them using FMFM or the can use the ‘forward’ function. The dial codes for these commands shows up on the Admin tab in the Feature Code list

.Transfers and Forwards can be sent through the POTS system to another PBX somewhere. Use the same Feature Codes you did above.

There are lots of ways to do this, including Custom Extensions and Misc Destinations. That extension can dial almost anything and move the call to the other service. The “specific person” part is going to be a challenge since you don’t appear to have control of that PBX, but as long as the phone number points to that extension, you should be good to go.


(Canada) #5

Yes i was trying Misc Destinations, but I am struggling getting a pause in to dial the extension once it connects to the other phone system. Can I add a pause somehow to Misc Destinations? Or if Custom extension, I am not sure I know how to add the custom dial string.


#6

after answer, wait(1) a second, then PlayDTMF(1234).


(Canada) #7

Sorry mind giving me an example, I am still somewhat of a newbie, and is this done in a Misc Destination or something else?


(Canada) #8

dicko, You have a chance yet to have a peek and a suggestion?


#9

Something like adding in /etc/asterisk/extensions_custom.conf

[custom-DTMF-extension]
exten => 1234,1,Dial(LOCAL/15551234567@outbound-allroutes)
exten => same,Wait(1)
exten => same,PlayDTMF(12345)

send the call to 1234


(Canada) #10

Thanks, does that need to be scripted or just entered into a custom extension?


#11

It IS a custom extension :wink:


(Canada) #12

Ok does this have to be done via command line or can I do it from the web interface?


#13

http://www.asteriskdocs.org/en/3rd_Edition/asterisk-book-html-chunk/index.html

https://wiki.freepbx.org/


#14

This should not require any scripts or special dial plan.

Create a Custom Extension. Under Asterisk Dial Options, check Override and make the field blank.
Under Dial, enter
LOCAL/15551234567@outbound-allroutes,300,D( ww1234 )

(Replace 15551234567 and 1234 as appropriate for your application.)
Submit, Apply Config, test.


#15

the ‘w’ in dial doesn’t always work with all sip providers, if it does, then use it.


(Canada) #16

That looks better than what I was trying, what is the 300 in the custom dial field for?

Trying it now…


(Canada) #17

Ok so I was able to get it to dial the number if I leave out the D,( ww1234 ), I am running Freepbx 14 if that makes any difference? Any suggestions?


#18

There should be no comma before or after the argument in parentheses.

This is the string I used for testing:
LOCAL/18004444444@outbound-allroutes,300,D( w2w2345678901 )
First try calling 18004444444 manually, then entering 2 then 2345678901 to hear the expected behavior.

Does that work on your system? If not, post a log of the failed call. If it works but with your numbers it doesn’t, post a log of that.

Edit: I hope that 18004444444 accepts calls from Canada.


(Canada) #19

Ok I had corrected the comma, and I either get the generic all circuits are busy, or it rings for 20-30 seconds, then says you call did not go through. I am also seeing this in the logs… 2020-11-05 15:11:29] WARNING[1501][C-0001e520] chan_sip.c: Received response: “Forbidden” from ‘<sip:700@sbc1.trunkcarrier.com:5XXX>;tag=as1c77f8af’.
I seem to be able to get it successfully to call the number if I leave out the waits and extension, but that is a key component here :slight_smile:


(Canada) #20

Oh I just realized as well, when I hit apply changes, it removes that final bracket. Any ideas there?