Forward an incoming call to External Auto Attendant


(Dave Burgess) #21

It looks like you’re trying to call extension 700 at your ITSP. That doesn’t sound right.


(Canada) #22

700 is the extension I am calling from, 705 is the extension I am calling, I think the forbidden was when i heard the message “all circuits are busy”.


(Dave Burgess) #23

In that case, you are trying to send ‘700’ as your caller ID? If so, yeah - that’s not going to work.


(Canada) #24

Oh ok how do I get around that? And why wouldn’t it work, I am curious…?


(Dave Burgess) #25

Usually, we see this when you mark your routes as “Intra-company”. If you’re not doing that, you’ll need to look through the /var/log/asterisk/full log file and find out where you’re Caller ID is getting set and adjust from there.

To be clear - you can set the caller id on a call in at least five different places:

  1. Your app (if you’re using a soft phone or android-based desk phone)
  2. Your extension configuration.
  3. Your Outbound Route (you can override the previous settings here)
  4. Your Trunk (once again, with override)
  5. Your provider (who may validate the CID you send and either block your call or change the CID if they don’t like what you are sending, depending on their policy)

Some providers will just block your call out of hand if it doesn’t match the Caller ID that is set on your account. Many providers do not allow any “foreign” (not your) CIDs, others will allow a foreign CID as long as it matches the general requirements for CID in your market, others will reset the caller id to whatever they want.

CID can be kind of a crap shoot that way.