FOP Web Root Dir is Read Only, how can I change it?

I’m using FOP2 instead of isymphony. I want to change where the operator panel link points.
From previous threads it seems you use to be able to change this in Advanced Settings using the setting;

FOP Web Root Dir

However it looks that this setting is hidden by default because it is a “read only” setting (you have to enable to show read only settings in Advanced Settings first). Obviously being a read only setting I can’t really change it here anymore.

Is there a way to change this now?

Nevermind, I’m stupid. You have to enable the “Override Readonly Settings” right under display readonly settings or it won’t let you change them. lol

I am also using FOP2. What are you putting into the FOP Web Root Dir field, just “fop2”?
Does that work?

No. To have to put …/fop2

The default path changed to being under /admin years ago, so by default it is /admin/cxpanel. If you just change it to fop2 it will point to /admin/fop2 which isn’t the default install if you follow fop2 install. Putting …/ will go up 1 directory to fix it.

Hi,

It is only a link to the FOP2 directory when you click the operator panel logo.
You need to enter the name of the directory that you have entered in your installation.
If you have called your web directory fop2, then write fop2 in the field.

Thank you,

Daniel Friedman
Trixton LTD.

Hi,

Actually, the cxpanel is a symbolic link:

[[email protected] ~]# ls -la /var/www/html/cxpanel
lrwxrwxrwx 1 asterisk asterisk 36 Nov  4 10:20 /var/www/html/cxpanel -> /var/www/html/admin/modules/cxpanel/

So just adjust it to your web server.

Thank you,

Daniel Friedman
Trixton LTD.

Nice, didn’t even notice that. Thanks.

I know this is an old topic but it comes closes to matching my problem

In the advanced settings for the operator panel, I tried both replacing cxpanel with

fop2 or
/fop2

In each case, the Operator Panel link disappears from the start-up screen

Also, in /var/www/html/ there is no symbolic link for cxpanel