External calls not making it through

Hello,

Since running the conversion tool to migrate from 32-bit to the latest 64-bit distro, I notice that external calls aren’t coming through. When a caller dials one of my extensions from outside, they hear silence for about 2 minutes. Eventually a telephone company recording saying “I’m sorry your call did not go through please try again”. Internally calls work fine, and I’m able to dial out (so my SIP trunk is working).

I suspect a firewall issue. I completely disabled the FW, but that didn’t make a difference. Any idea what I can check on my end?

Thank you!
Brian

I assume you’ve enabled the trunks? IIRC, trunks are disabled post migration to prevent interfering with the old system.

Hello,

Yes you’re correct they were initially disabled. Post-migration I enabled trunks. I’m able to make external calls, so I.m assuming that the trunks are working properly now. I also have the old system powered off, to ensure there’s no conflict,

Does the new server have a different internal IP address? Have you corrected any port forwards on the internet-facing router?

Hi. Same IP address; and yes port forwarding is set up on my router. I don’t see where there would need to e changed since the IP address hasn’t changed (as far as the router is concerned).

Hi all!

Wondering if anybody has any other ideas or things I can try? I’m still able to dial outside lines. But when users attempt to dial in, they hear silence and the call eventually fails.

One update; San Diego CA recently made a change where callers need to dial 1+area code+number, even for local calls. My incoming routes are currently set for 10-digit dialing (without the 1). I added the 1 for one of my extensions, but same result. So I don’t think that change led to my current problem, but thought I’d mention just in case.

Thanks again!

Logs for a failed call would help.

I would check SIP IP address settings.

Hi Dave,

Could you please tell me where to find these logs? Will do a test call and provide a log.

Thanks!

Hmmm all outgoing calls work (internal and external), and incoming internal calls work. Just not incoming external. You suspect SIP IP settings - I didn’t change any IP settings though, You still think that could be the case? I’ll definitely triple-check to be sure - but not really sure what I’m looking for. Really appreciate your recommendation!

As @cynjut said, please provide logs of a failed call.
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs

On another note: I’m not sure if this PBX has the same IP as the old one, if not, then could be your WAN to LAN rules are not forwarding the ports to the right IP.

Also as @VoIPTek said, go to Settings > SIP Settings, and make sure all your network config is correct. If you do (or did) make changes there, you’ll need to restart asterisk.

Thanks for the reference and ideas of things to check. I managed to get myself into a worse situation than I was before; I now have NO SERVICE to any extensions. But I did find some interesting things along the way,

For clarification my IP address never changed. I decommissioned the old physical system at the same time I stood up this new virtual platform.

With the info you provided regarding log files, I first determined that traffic was never making it to the PBX. I traced back to my hardware firewall, and found out it was being dropped. I fixed that (added a rule to ensure traffic is routed to the PBX). But still nothing. Went back to the PBX, made a few more attempts from outside, but still nothing coming through. I did notice that log file times were off, so I fixed that (put my system in local time zone instead of UTC). I noticed some error messages on the Dashboard that I decided to try to resolve; hoping that would fix my issue. Primary issue was regarding CHAN-SIP / CHAN-PJSIP. It guided me to use both. (Unfortunately I don’t remember which it was original using).

Once I enabled both, it guided me to enable WS & WSS for CHAN-PJSIP. Once I made all these changes and multiple reboots; now I have no service.

I realize I’ve crossed into another issue, and probably need to open a new topic. But since it occurred during troubleshooting the original issue, thought I’d explain it here first in case somebody notices that one of the changes I made probably caused the new problem.

Also one more point. I notice a message on the dashboard now telling me that the default bind port for CHAN_PJSIP is 5060; and CHAN_SIP is 5160. I think this is where my new issue lies.

UPDATE:

Changed everything back to CHAN_SIP, port to 5060, and rebooted the PBX. I’m back to my original problem of outside calls not coming through. But internally, and making outside calls is working again.

Thanks all!

This is my first attempt at using FreePBX and I am fading fast.
I am having the exact same problem as the rest of you!
I have built FreePBX on Raspberry Pi, VM Ware and finally I dedicated a whole desktop PC to it - all three have the same issue with incoming calls - they go straight to voice mail at the provider or the incoming line is constantly busy depending on the amount of config that has been made.

I am CONVINCED that it is a provider/setup issue but my provider ‘doesn’t’ provide support for FreePBX setup.

The incoming line only busies out when I have setup ‘register’ and incoming route so something isn’t right with one of them.

I will keep an eye on this topic to see if ANYONE actually gets it to work.

JTB,

I can assure you this does work. It worked fine for me prior to my recent upgrade. But if you haven’t already, you’ll need to purchase a SIP-trunk package to make it work. I purchased mine from Digium; roughly $5/mo for 5 lines. Also if you have a firewall you need to configure it to pass SIP traffic through to your PBX.

I hope this is helpful; let me know if you have questions (keeping in mind that mine isn’t currently working - but I’m sure will get it working soon enough!)

Thanks for the encouragement.

It is annoying as everything else works so well.

I have certainly notice that different versions ‘behave’ differently and I am currently using SNG7-FPBX-64bit-1712-2.
SNG7-FPBX-64bit-1805-1 didn’t like my service provider at all so it gets a bit of a drag trying to workout if it is a software/setup, service provider issue.

When I configure a SIP phone with the carrier it works fine.

Wanted to let everybody know the issue is resolved. Turned out to be a misconfiguration in my firewall, which was passing SIP traffic to the wrong interface. I’ve fixed that - now calls are coming through and I can sleep tonight :slight_smile: Thanks again for all the advice.

JTB I’d be more than happy to provide any assistance I can, to help get your system working.

Thanks Brian - I will take you up on your kind offer of assistance.

Summary -
Running 1712 as none of my platforms will run 1805!

4 extensions are running, 2 x Xlite softphone, 1 Yealink T20 and 1 Cisco 7960.
All extensions are using pjsip and can call and receive one another.

The Trunk, Telcom1, Outgoing contains user specific info in this format
host=
username=
secret=
type=peer

The Trunk Incoming contains nothing

Register String
user id:[email protected]/user id

Outgoing Route

Mapped to trunk Telcom1 and match pattern set to 0. - outside lines in UK start with 0.

Incoming Route

Set to extension 404 - the rest are default

Once the Incoming route has been setup the line busies to outside calls.
Before configuration it goes to carrier voice mail.
Outgoing calls are fine.
If I delete incoming route and the register settings then the calls are restored to carrier voice mail.

If a sip-phone is configured on its own then the line works both ways!!

My gut feeling is that there is a setup issue with the carrier but they cannot help.
Trying another carrier is the preferred option but getting one for a free trial and that works with FreePBX is a little bit more of a challenge.

Any ideas if I am doing something wrong?

Cheers

John

Hi John!

Sorry just saw your question (didn’t receive an email alert). As you can probably tell by my questions I’m a FreePBX novice :slight_smile: But I’ve found with persistence and assistance from the group I’m usually able to work through issues.

So reading your issue and setup I have a couple questions.

  • Have you ever received incoming calls from outside? It sounds like, internally, you have everything working properly. My initial thoughts are that you have a routing issue. Since callers don’t get the carrier message once you have incoming route established, it definitely seems to be getting through. But then something getting in the way. Firewall maybe? That was my issue.

  • You’re using pjsip? That caused me issues; but maybe because I originally set for Chan-sip. I’ve read mixed reviews of people trying to use pjsip.

Can I ask which SIP trunk provider you’re using? I use Digium. They were really helpful in getting it set up, and are very familiar working with freepbx.

I hope this is at least marginally helpful. Please feel free to reach out any time. I’ll make a point to check the board more closely!

vr,
Brian

One other question.

You mentioned that in the UK outside lines start with ‘0’. If you’re dialing from a landline within UK, do you have to dial a 0?

In the US to make long-distance calls a ‘1’ is required up front before the area code. But I’ve found that if I include that 1 in the inbound route, the call doesn’t go through. Caller gets a telco provider message that the call failed (or something like that). I can’t explain it, but I know in my case it only works when I leave off the ‘1’.